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Customer Service
To obtain product and service information, software upgrades, and technical assistance, visit
the eSight™ Service Center at http://www.esight.com. The center is open 24 hours a
day, seven days a week.

Finding information and software

The eSight Service Center at http://www.esight.com provides technical information,
product information, and descriptions of available services. Log in and select a service. The
eSight Service Center also provides software upgrades, release notes, and addenda. Or you can
visit the FTP site at ftp://ftp.ascend.com for this information.

Obtaining technical assistance

The eSight™ Service Center at http://www.esight.com provides access to technical
support. You can obtain technical assistance through email or the Internet, or by telephone.

If you need to contact Lucent Technologies for assistance, make sure that you have the
following information available:

• Active contract number, product name, model, and serial number

• Software version

• Software and hardware options

• If supplied by your carrier, service profile identifiers (SPIDs) associated with your line

• Your local telephone company’s switch type and operating mode, such as AT&T 5ESS
Custom or Northern Telecom National ISDN-1

• Whether you are routing or bridging with your Lucent product

• Type of computer you are using

• Description of the problem

Obtaining assistance through email or the Internet

If your services agreement allows, you can communicate directly with a technical engineer
through Email Technical Support or eSight Live chat. Select one of these sites when you log in
to http://www.esight.com.

Calling the technical assistance center (TAC)

If you cannot find an answer through the tools and information on eSight or if you have a very
urgent need, contact TAC. Access the eSight Service Center at http://www.esight.com
and click Contact Us below the Lucent Technologies logo for a list of telephone numbers
inside and outside the United States.

You can alternatively call (800) 272-3634 for a menu of Lucent services, or call
(510) 769-6001 for an operator. If you do not have an active services agreement or contract,
you will be charged for time and materials.
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About This Supplement

How to use this supplement
This supplement is intended for the person setting up security on the MAX. It explains how to
set up different kinds of security options using the MAX configuration interface, and contains
the following chapters:

• Chapter 1, “Getting Started: Basic Security Measures,” details recommended changes to
default security settings to protect the MAX from unauthorized access.

• Chapter 2, “Setting Up Security Profiles,” describes security levels for the MAX and
explains the privileges you can set in Security profiles.

• Chapter 3, “Setting Up User Authentication,” explains how to identify and permit access
to users dialing in over both analog and digital lines.

• Chapter 4, “Defining Static Filters,” details how to set up data filters and call filters.

• Chapter 5, “Setting Up Security-Card Authentication,” describes how the MAX supports
dynamic password challenges sent from an external authentication server at a secure site.

• Chapter 6, “Setting Up User Authorization,” describes how to limit user access to network
devices, resources, and services.

This supplement also contains an index.

What this supplement does not contain
This supplement does not describe how to set up security in RADIUS, how to use the Access
Control product, or how to set up the MAX to work with firewalls and the Secure Access
product. Further, it does not discuss general network security issues or provide guidelines
about the extent to which you should protect your network and local hosts. For pointers to
information about these products and topics, consult the following publications:

Topic Publication

RADIUS TAOS RADIUS Guide and Reference

Access Control Access Control User’s Guide

Firewalls and Secure Access Secure Access Manager User’s Guide

Detailed discussion of secu-
rity issues

Firewalls and Internet Security by William R. Cheswick and
Steven M. Bellovin
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About This Supplement
What you should know

What you should know
You should read this supplement if you are configuring security on the MAX. This supplement
does not discuss general network security issues, or provide guidelines for protecting your
network and local hosts. To use this book effectively, you should be familiar with network
security. If you need background information, you might find the book by William R.
Cheswick and Steven M. Bellovin helpful. (For a list of publications, see “What this
supplement does not contain.”

You might also want to consider RADIUS and other external servers that offer additional
methods for handling security.

Access Control is a software program that provides authentication, authorization, and
accounting services for users who request network connections.
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Documentation conventions
Following are all the special characters and typographical conventions used in this manual:

Note: In a menu-item path, include a space before and after each “>” character.

Convention Meaning

Monospace text Represents text that appears on your computer’s screen, or that could
appear on your computer’s screen.

Boldface
mono-space
text

Represents characters that you enter exactly as shown (unless the char-
acters are also in italics—see Italics, below). If you could enter
the characters but are not specifically instructed to, they do not appear
in boldface.

Italics Represent variable information. Do not enter the words themselves in
the command. Enter the information they represent. In ordinary text,
italics are used for titles of publications, for some terms that would
otherwise be in quotation marks, and to show emphasis.

[ ] Square brackets indicate an optional argument you might add to a
command. To include such an argument, type only the information
inside the brackets. Do not type the brackets unless they appear in bold
type.

| Separates command choices that are mutually exclusive.

> Points to the next level in the path to a parameter or menu item. The
item that follows the angle bracket is one of the options that appears
when you select the item that precedes the angle bracket.

Key1-Key2 Represents a combination keystroke. To enter a combination key-
stroke, press the first key and hold it down while you press one or
more other keys. Release all the keys at the same time. (For example,
Ctrl-H means hold down the Control key and press the H key.)

Press Enter Means press the Enter, or Return, key or its equivalent on your com-
puter.

Note: Introduces important additional information.

!
Caution:

Warns that a failure to follow the recommended procedure could result
in loss of data or damage to equipment.

Warning:

Warns that a failure to take appropriate safety precautions could result
in physical injury.
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About This Supplement
Manual set

Manual set
The MAX Documentation Set consists of the following manuals:

• MAX Administration Guide

• Hardware Installation Guide for your MAX

• Network Configuration Guide for your MAX

• MAX Reference

• MAX Security Supplement (this supplement)

• TAOS RADIUS Guide and Reference

• TAOS Glossary

• Remote Access Networking Services: Technology Overview

The MAX documentation set is available on the Documentation Library CD-ROM included
with your MAX unit, and on either CD-ROM or paper from the online bookstore
(http://www.lucent.com/ins/bookstore/).
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1Getting Started: Basic Security Measures

Introducing Security profiles
Security profiles consist of parameters you configure to control access to the MAX. All
Security profiles are located below the Security menu of the System profile in the MAX
configuration interface.

00-300 Security
>00-301 Default
00-302
00-303
00-304
00-305
00-306
00-307
00-308
00-309 Full Access

Introducing Security profiles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-1

Understanding basic security measures . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-3

Activating the Full Access profile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-3

Changing the Full Access password . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-4

Setting the Default profile for read-only access. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-5

Changing the SNMP read-write community string . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-6

Assigning a Telnet password . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-6

Requiring profiles for incoming connections. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-6

Turning off ICMP redirects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-7

Specifying the number of retry attempts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-7

Retrieving configuration updates from RADIUS . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-8
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Getting Started: Basic Security Measures
Introducing Security profiles

All MAX units provide two special profiles:

Note: Follow the instructions in “Changing the Full Access password” on page 1-3 and
“Setting the Default profile for read-only access” on page 1-4. These instructions result in two
security levels, one that is totally open (Full Access) and one that is very restrictive (Default).

If you are the only user who must configure the MAX or perform administrative tasks, you do
not need to create any Security profiles in addition to the Default and Full Access profiles.
However, you can define additional security levels allowing specific users to perform a subset
of administrative functions. You can create up to seven additional Security profiles. For more
information about these tasks, see Chapter 2, “Setting Up Security Profiles.”

Profile Description

Full Access Provides full access to the MAX. This is the superuser profile that
enables you to configure your system, dial remote locations, reset the
MAX, and upgrade system software.

Any user who knows the password for the Full Access profile can
perform any operation on the MAX. The default Full Access password
is Ascend. To maintain security, you should change the Full Access
password from its default value. For details, see “Changing the Full
Access password” on page 1-3.

Default The MAX assigns the Default profile to every user who logs in via
Telnet, the Control port, and remote management. The MAX activates
the Default profile when the MAX powers on or resets. The privileges
set in the Default profile are available to all users. You cannot change
the name of the Default profile or assign a password to it. However,
you can change its settings to make the profile more restrictive. For
details, see “Setting the Default profile for read-only access” on
page 1-4.
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Understanding basic security measures
When you first receive the MAX, all levels are set with full privileges. Initially, you can
activate only the Default and Full Access profiles. Before you can activate one of the other
Security Profiles, you must assign it a name. The default security settings of the Full Access
profile enable you to configure and set up the MAX without any restrictions. Before you make
the MAX generally accessible, you should protect the configured MAX from unauthorized
access. Proceed as follows:

1 Activate the Full Access profile.

2 Change the Full Access password.

3 Set the Default profile for read-only access.

4 Change the SNMP read-write community string.

5 Assign a Telnet password.

6 Require profiles for incoming connections.

7 Turn off ICMP redirects.

8 Specify the number of times the MAX retries a connection.

9 Retrieving configuration updates from RADIUS.

Activating the Full Access profile
You must activate the Full Access profile for your own use in performing the rest of the basic
security measures. To activate the Full Access profile, proceed as follows:

1 From any VT100 menu, press <Ctrl> D.

The DO menu appears. For example:

DO...
>0=Esc
P=Password
C=Close TELNET

2 Press P or select P=Password.

A menu appears listing all security profiles:

Security profile...?
>00-301 Default
00-302 test
00-303
00-304
00-305
00-306
00-307
00-308
00-309 Full Access

3 Select Full Access.

The MAX displays a password prompt.

4 Enter the password assigned to the Full Access security profile.
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If you enter the correct password, the MAX displays the message Password
accepted. Using new security level. If you enter the incorrect password,
the MAX prompts you again for the password.

Changing the Full Access password
The Full Access Security profile is the super-user profile that enables you to configure your
system, dial remote locations, reset the MAX, and upgrade system software. Because this
profile allows complete access, all privileges are set to Yes. The default password assigned to
the profile is Ascend. A user who knows the password for the Full Access profile can
perform any operation on the MAX.

Change the default password as soon as possible.

To assign a password protecting the Full Access profile, proceed as follows:

1 From any VT100 menu, press Ctrl-D.

The DO menu appears. For example:

DO...

>0=Esc

P=Password

C=Close TELNET

2 Press P or select P=Password.

A menu appears listing all security profiles:

Security profile...?

>00-301 Default

00-302 test

00-303

00-304

00-305

00-306

00-307

00-308

00-309 Full Access

3 Select Full Access.

The MAX displays a password prompt.

4 Enter the password assigned to the Full Access security profile.

If you enter the correct password, the MAX displays the message Password
accepted. Using new security level. If you enter the incorrect password,
the MAX prompts you again for the password.

5 Open the System > Security > Full Access profile.

6 Select the Passwd parameter and press Enter to open a text field.

7 Type a new password, and press Enter.

8 Exit the Full Access profile, and select the Exit and Accept option to save your changes.
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Setting the Default profile for read-only access
The first profile in the Security menu is called Default. It has no password, and you cannot
modify the profile’s name or create a password. The MAX activates this profile whenever you
power on or reset the MAX, and whenever a user begins a new login session.

Although the Default profile is set initially with full privileges, it is intended to be very
restrictive. Every user who logs in via Telnet, the Control port, or remote management is
granted the privileges specified there.

To make the Default profile appropriately restrictive, proceed as follows:

1 Open the System > Security menu.

2 Open the Default profile.

The first two parameters in the Default profile cannot be changed. The name is always
Default and the password is always null.

3 Set Operations=No.

00-301 Default
Name=Default
Passwd=
>Operations=No
Edit Security=N/A
Edit System=N/A
Edit Line=N/A
Edit All Ports=N/A
Edit Own Port=N/A
Edit All Calls=N/A
Edit Com Call=N/A
Edit Own Call=N/A
Edit Cur Call=N/A
Sys Diag=N/A
All Port Diag=N/A
Own Port Diag=N/A
Download=N/A
Upload=N/A
Field Service=N/A

All other parameters are set to N/A when Operations=No.

Users who access the MAX terminal server cannot make any changes to its configuration
or to perform restricted operations. For all users with the Default security level, passwords
(including the null password) are hidden by the string *SECURE* in the MAX unit’s user
interface.

4 Exit the Full Access profile, and select the Exit and Accept option to save your changes.
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Changing the SNMP read-write community string
An SNMP community string is an identifier that an SNMP manager application must specify
before it can access the MIB (Management Information Base). The MAX has two community
strings:

You cannot turn off SNMP write, so you must change the default read-write string to secure the
MAX against unauthorized SNMP access. To change the read-write community string,
proceed as follows:

1 Open the Ethernet > Mod Config > SNMP Options menu.

2 For the R/W Comm parameter, specify a text string containing up to 16 characters.

For example, you can specify this setting:

R/W Comm=unique-string

3 Close the SNMP Options menu, and select the Exit and Accept option to save your
changes.

Assigning a Telnet password
Until you assign a Telnet password, any local user who knows the MAX unit’s IP address can
start a Telnet session with the MAX. When you assign a password, all users requesting
incoming Telnet sessions, whether locally or from across the WAN, must enter the password.

To assign a Telnet password, proceed as follows:

1 Open the Ethernet > Mod Config > Ether Options menu.

2 For the Telnet PW parameter, specify a password containing up to 20 characters.

For example, you might enter this setting:

Telnet PW=telnet-pwd

3 Close the Ether Options menu, and select the Exit and Accept option to save your changes.

Requiring profiles for incoming connections
You can use the MAX unit’s Answer profile to build connections that do not require a name
and password. Although some sites allow such connections, most sites impose much tighter
restrictions. You should consider limiting incoming connections to those that have a
configured Connection profile, Password profile, or RADIUS user profile.

String Function

Read Comm The read community string has the value public by default. It enables
an SNMP manager to perform read commands (get and get next) in
order to request specific information.

R/W Comm The read-write community string has the value write by default. It
enables an SNMP manager to perform both read and write commands
(get, get next, and set). Using the commands, the application can
access management information, set alarm thresholds, and change
settings on the MAX.
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Chapter 3, “Setting Up User Authentication,” describes the types of authentication you can
configure for incoming connections. At the most basic level, however, you can configure the
MAX to reject all incoming connections for which it finds no matching profile.

To require configured profiles for all incoming connections, proceed as follows:

1 Open the Ethernet > Answer menu.

2 To specify that a matching profile is required for incoming calls, set Profile Reqd=Yes.

Note: If you configure the MAX to support AppleTalk Remote Access (ARA)
connections, setting Profile Reqd=Yes disables Guest access to your network.

3 Exit the Answer profile, and select the Exit and Accept option to save your changes.

Turning off ICMP redirects
ICMP enables a MAX to find the most efficient IP route to a destination. ICMP Redirect
packets are one of the oldest route discovery methods on the Internet and one of the least
secure. It is possible to counterfeit ICMP Redirects and change the way a device routes
packets. If the MAX is routing IP, Lucent recommends that you turn off ICMP redirects.

To configure the MAX to ignore ICMP redirect packets, proceed as follows:

1 Open the Ethernet > Mod Config menu.

2 Set ICMP Redirects=Ignore.

3 Save your changes.

Specifying the number of retry attempts
When a MAX attempts to make a connection and the attempt fails, the MAX continues to
attempt to complete the connection. The number of retry attempts allowed without using call
blocking is very large and successive retries can cause excessive charges, congestion, and
performance problems. With call blocking, you can specify a maximum number of
unsuccessful attempts. After the specified number of attempts have been made and failed, the
blocking timer starts. The MAX continues to block further retries for a the length of time you
specify.

To configuring call blocking, proceed as follows:

1 Open the Ethernet > Connections > any Connection profile > Session options menu.

2 Set Block calls after to the number of retry attempts the MAX allows when
placing a call.

3 Set Blocked duration to the length of time the MAX continues to block calls.

Call blocking applies only to outgoing calls that are not answered by the far end. It does not
apply to incoming calls or outgoing calls that connect and are immediately disconnected.
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Retrieving configuration updates from RADIUS
When you power up the MAX, it can retrieve a potentially large quantity of configuration
information from the RADIUS server. Some of the data on the RADIUS server can change
during operation. You can direct the MAX to retrieve this information in one of two ways:

• Using the Upd Rem Cfg command from the Sys Diag menu, you can instruct the MAX to
retrieve a fresh configuration.

• You can initiate a RADIUS configuration update by using the SNMP Set command. Use
SNMP to poll the status of the update.

• The SNMP variable sysConfigRadiusCmd allows an SNMP manager to initiate a
RADIUS configuration retrieval of routes, IP pools, connection information, and terminal
server banners. You can poll the status of the retrieval by getting the value of another
SNMP variable, sysConfigRadiusStatus.
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2Setting Up Security Profiles

Understanding Security profiles
A Security profile consists of parameters you can set to control access to the MAX. All
Security profiles are located below the Security menu of the System profile in the MAX
configuration interface. Table 2-1 lists the parameters in a Security profile.

Understanding Security profiles. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-1

Configuring a Security profile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-3

Activating a Security profile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-6

Using the Full Access profile. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-7

Table 2-1. Security profile parameters

Parameter Specifies Possible values

Name Name for the profile. Text string of up to 16 characters. The
default value is null.

Passwd Password. Text string of up to 20 characters. The
default value is null.

Operations Enable/disable read-only
security.

Yes (the default)
No

Edit Security Level of privileges for editing
Security profiles.

Yes (the default)
No

Edit System Level of privileges for editing
the System profile and the
Read Comm and R/W Comm
parameters in the Ethernet
profile.

Yes (the default)
No

Edit Line Operator can/cannot edit Line
profiles.

Yes (the default)
No
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Edit All Ports Operator can/cannot edit all
Port profiles.

Yes (the default)
No

Edit Own Port Operator can/cannot edit his or
her own Port profile.

Yes (the default)
No

Note: The No setting is ineffective
unless you Edit All Ports=No.

Edit All Calls Operator can/cannot edit all
the parameters in all Call
profiles and Connection
profiles.

Yes (the default)
No

No specifies that an operator can edit
only the Dial # and Base Ch Count
parameters in the current Call profile.

Edit Com Call Operator can/cannot edit Call
profiles that are not specific to
any serial host port (such
profiles are known as common
Call profiles.)

Yes (the default)
No

Note: The No setting is ineffective
unless you also set Edit All Calls=No.

Edit Cur Call Indicates whether an operator
can/cannot edit all the
parameters in the current Call
profile.

Yes (the default)
No

No specifies that an operator can edit
only the Dial # and Base Ch Count
parameters in the current Call profile.
To disable editing of the Dial # and
Base Ch Count parameters, you must
set Edit Cur Call=No and Edit All
Calls=No.

Edit Own Call Operator can/cannot edit the
Call profile that defines the
connection between his or her
MAX and the MAX being
remotely managed over an
AIM channel.

Yes (the default)
No

Note: The No setting is ineffective
unless you also set Edit All Calls=No.

Sys Diag Indicates whether an operator
can/cannot perform all system
diagnostics.

Yes (the default)
No

All Port Diag Indicates whether an operator
can/cannot perform all serial
host port diagnostics.

Yes (the default)
No

Table 2-1. Security profile parameters (continued)

Parameter Specifies Possible values
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Configuring a Security profile
To configure a Security profile, proceed as follows:

1 Open the System > Security menu.

2 Open any Security profile.

3 Set Name to a descriptive designation for the profile.

You can enter up to 16 characters. For example:

Name=Calabasas

4 Specify a password value of up to 20 character for the Passwd parameter.

5 Set the Operations parameter to enable or disable read-only security.

Yes allows a user to view MAX profiles and to change the value of any parameter. The
default value is Yes.

No permits a user to view MAX profiles, but not to change the value of any parameter. If
you specify No, a user cannot access most DO commands. Only DO Esc, DO Close
Telnet, and DO password are available.

6 Set the Edit Security parameter to grant or restrict privileges to edit Security profiles.

Own Port Diag Indicates whether an operator
can/cannot perform port
diagnostics for his or her own
serial host port.

Yes (the default)
No

To completely disable the operator’s
ability to perform diagnostics for his or
her own port, you must set Own Port
Diag=No and All Port Diag=No.

Download Indicates whether an operator
can/cannot download the
configuration of the MAX
using the Save Cfg command.

Yes (the default)
No

Note: Whether you choose Yes or No,
a user cannot download passwords to
another device.

Upload Indicates whether an operator
can/cannot upload the MAX
configuration from another
device using the Restore Cfg
command.

Yes (the default)
No

Note: When you save a configuration
to file, passwords are not included in
the download, so restoring from file
clears all passwords in the MAX.

Field Service Level of privileges for
performing field service
operations, such as uploading
new system software.

Yes (the default)
No

Table 2-1. Security profile parameters (continued)

Parameter Specifies Possible values
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Yes grants privileges. When you specify Yes, a user can edit Security profiles, and can
access all other operations permitted in his or her active Security profile. In addition, all
passwords in Security profiles are visible as text. This privilege is the most powerful one
you can assign, because it allows users to change their own privileges. The default value is
Yes.

No restricts privileges. When Edit Security=No, all passwords are hidden by the string
“*SECURE*.”

Note: Do not set the Edit Security parameter to No on all nine Security profiles. If you
do, you cannot edit any of them.

7 Set the Edit System parameter to grant or restrict privileges to edit the System profile and
the Ethernet profile.

Yes allows an operator to edit the System profile, and to edit the Read Comm and R/W
Comm parameters in the Ethernet profile. The default value is Yes.

No restricts edit privileges.

8 Set the Edit System parameter to indicate whether an operator can edit Line profiles.

Yes enables an operator to edit Line profiles. The default value is Yes.

No prevents an operator from editing Line profiles.

9 Set the Edit All Ports parameter to indicate whether an operator can edit all Port profiles.

Yes specifies that an operator can edit all Port profiles by local or remote management.
The default value is Yes.

No specifies that an operator cannot edit Port profiles.

10 Set the Edit Own Port parameter to indicate whether an operator can edit his or her own
Port profile.

Yes specifies that the operator can use remote management to edit the Port profile for the
port that has been called. The default value is Yes.

No specifies that an operator cannot edit his or her own Port profile. To keep an operator
from editing his or her own Port profile, you must set Edit Own Port=No and Edit All
Ports=No.

11 Set the Edit All Calls parameter to indicate whether an operator can edit all the parameters
in all Call profiles and Connection profiles.

Yes specifies that an operator can edit all the parameters in all Call profiles and
Connection profiles through Telnet, through local management (the Control port), or
through remote management. The default value is Yes.

No specifies that an operator can edit only the Dial # and Base Ch Count parameters in the
current Call profile. To disable editing of the Dial # and Base Ch Count parameter, you
must set Edit All Calls=No and Edit Cur Call=No.

12 Set the Edit Com Call parameter to indicate whether an operator can edit Call profiles that
are not specific to any serial host port.

Call profiles not specific to any serial host port are known as common Call profiles.
Numbers 201 through 216 denote port-specific Call profiles. Numbers 217 through 232
denote common Call profiles.

Yes specifies that an operator can edit common Call profiles by local or remote
management. The default value is Yes.

No specifies that an operator cannot edit common Call profiles. To keep an operator from
editing common Call profiles, you must set Edit Com Call=No and Edit All Calls=No.
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13 Set the Edit Own Call parameter to indicate whether an operator can edit the Call profile
that defines the connection between the user’s MAX and the MAX being remotely
managed over an AIM channel

Yes specifies that the operator can edit the Call profile. The default value is Yes.

No specifies that an operator cannot edit the Call profile. To keep an operator from editing
the Call profile between a local and a remotely managed MAX, you must set Edit Own
Call=No and Edit All Calls=No.

14 Set the Edit Cur Call parameter to indicate whether an operator can edit all the parameters
in the current Call profile.

Yes specifies that an operator can edit all the parameters in the current Call profile by local
or remote management. Yes is the default.

No specifies that an operator can edit only the Dial # and Base Ch Count parameters in the
current Call profile. To disable editing of the Dial # and Base Ch Count parameters, you
must set Edit Cur Call=No and Edit All Calls=No.

15 Set the Sys Diag parameter to indicate whether an operator can perform all system
diagnostics.

Yes specifies that an operator can use any of the options in the Sys Diag menu by local or
remote management. The default value is Yes.

No specifies that an operator cannot use any of the options in the Sys Diag menu.

16 Set the All Port Diag parameter to indicate whether an operator can perform all serial host
port diagnostics.

Yes specifies that an operator can perform all the tasks listed in the Port Diag menu. The
default value is Yes.

No specifies that an operator cannot perform any of the tasks listed in the Port Diag menu.

17 Set the Own Port Diag parameter to indicate whether an operator can perform port
diagnostics for his or her own serial host port.

Yes specifies that an operator can use remote management to perform any of the options in
the Port Diag menu for the port that has been called. The default value is Yes.

No specifies that the operator cannot perform port diagnostics for his or her own serial
host port. To completely disable the operator’s ability to perform diagnostics for his or her
own port, you must set Own Port Diag=No and All Port Diag=No.

18 Set the Download parameter to indicate whether an operator can use the Save Cfg
command to download the configuration of the MAX.

Yes specifies that a user can download profiles and other configuration parameters to
another device for backup. The default value is Yes.

No specifies that an operator cannot download profiles and other configuration
parameters.

Note: Whether you choose Yes or No, you cannot download passwords to another
device.

19 Set the Upload parameter to indicate whether an operator can use the Restore Cfg
command to upload the MAX configuration from another device.

Yes specifies that the user can upload profiles and other configuration parameters from
another device to the MAX. You must set Upload=Yes in order to use the Restore Cfg
command. The default value is Yes.



2-6 Preliminary November 29, 2000 MAX Security Supplement

Setting Up Security Profiles
Activating a Security profile

No specifies that the user cannot upload profiles and other configuration parameters from
another device to the MAX.

Note: When you save a configuration to file, passwords are not included in the
download, so restoring from file clears all passwords on the MAX.

20 Set the Field Service parameter to grant or restrict privileges to perform Lucent-provided
field service operations, such as uploading new system software.

Yes grants privileges. The default value is Yes.

No restricts privileges. Selecting No does not disable access to any MAX operations. Field
service operations are special diagnostic routines not available through MAX menus.

21 Close the new Security profile.

Activating a Security profile
When you log into the MAX, you can only view settings, because the Default profile is active.
To make any changes or perform any administrative tasks, you must activate the Full Access
profile or a profile that has been configured to allow setup or administrative tasks.

To activate a profile, follow these steps:

1 Press Ctrl-D to open the DO menu

2 Press P, or select P=Password.

3 In the list of Security profiles that opens, select the profile you want to activate.

The MAX prompts you for the password.

4 Specify the appropriate password, and press Enter.

When you enter the correct password, the MAX displays the message Password
accepted. Using new security level. If you enter an incorrect password, the
MAX prompts you again for the password.
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Using the Full Access profile
The Full Access profile is the superuser profile which allows you to configure your system,
dial remote locations, reset the MAX, and upgrade system software. This profile is intended to
remain totally open, with all privileges set to Yes. The default password assigned to the profile
is Ascend. A user who knows the password for the Full Access profile can perform any
operation on the MAX.

Note: To prevent unauthorized access, to change the default password as soon as possible.

Following are the default settings for the Full Access profile:

Name=Full Access

Passwd=Ascend

Operations=Yes

Edit Security=Yes

Edit System=Yes

Edit Line=Yes

Edit All Ports=Yes

Edit Own Port=N/A

Edit All Calls=Yes

Edit Com Call=N/A

Edit Own Call=N/A

Edit Cur Call=N/A

Sys Diag=Yes

All Port Diag=Yes

Own Port Diag=N/A

Download=Yes

Upload=Yes

Field Service=Yes
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3Setting Up User Authentication

:

Introducing user authentication
User authentication is a method of identifying and allowing access to specified remote users
dialing in over both analog and digital lines.

Types of Authentication

The MAX unit supports the following types of authentication:

CLID (Calling Line ID)

You can require the MAX to authenticate incoming calls by checking the calling party’s phone
number. The MAX performs CLID authentication before answering an incoming call. For
details about configuring the MAX for CLID authentication, see “Setting up CLID
authentication” on page 3-5.

Introducing user authentication . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-1
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Called Number

Called Number authentication works much like CLID authentication, except that the MAX
uses the number called by the remote end to authenticate the connection. The called number
appears in an ISDN message as part of the call when DNIS (Dial Number Information Service)
is in use. Called Number authentication is also known as DNIS authentication.

Callback

Callback security instructs the MAX to hang up on an incoming caller and immediately initiate
a call to that destination. For details about configuring the MAX to use callback security, see
“Setting up callback security” on page 3-11.

Name and password

You can configure the MAX to verify an incoming call on the basis of the user’s name and
password. You can also specify a name and password for outgoing calls. Name and password
authentication applies to the types of calls listed in Table 3-1:

Table 3-1. Call types authenticated by name and password requirements

Call Type Description

PPP, MP, and MP+ You can specify Password Authentication Protocol (PAP),
Challenge Handshake Authentication Protocol (CHAP), or
Microsoft Challenge Authentication Protocol (MS-CHAP)
authentication for name and password verification of incoming
and outgoing PPP, MP, or MP+ calls. For details, see “Setting up
authentication of PPP, MP, and MP+ calls” on page 3-15.

Terminal server You can specify that users logging into the terminal server
through a V.34, V.42, V.110, or V.120 connection must supply a
username and password before gaining admission to the terminal
server. For instructions, see “Setting up authentication for dial-in
terminal server users” on page 3-23.

Combinet Combinet authentication uses the remote station’s MAC address
as its username and allows you to require a password for
incoming calls. For details, see “Setting up Combinet
authentication” on page 3-28.

ARA You can specify name and password authentication for AppleTalk
callers dialing in through a V.34, V.42, V.120, or X.75 connection.
For details, see “Setting up ARA authentication” on page 3-31.

IP Address You can specify that the MAX authenticate an incoming
connection by checking the user’s IP address or, you can specify
that the MAX assign an IP address to each incoming call. For
details, see “Setting up IP addressing” on page 3-38.
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How user authentication works?

All user authentication relies on the MAX finding a matching profile to verify information
presented by the caller. The matching Connection profile or Names/Passwords profile can be
resident locally or, the profile can be managed by a third-party security server such as
RADIUS, TACACS, or TACACS+.

By default, when you require a profile for authentication the MAX always checks for a
Connection profile. If a Connection profile does not exist, the MAX checks for a remote
RADIUS, TACACS, or TACACS+ profile. However, you can change this default by setting
Local Profile First=No in the External-Auth profile. When Local Profile First=No, the MAX
first looks for a remote profile. If it cannot find one, the MAX looks for a local Connection
profile.

Note: You can also specify that the Answer profile be used for authentication. See
“Preventing dial-in calls with the Names/Passwords profile” on page 3-35.

This section describes how the MAX authenticates an incoming call, the following events take
place:

1 Before the MAX answers a call, it checks whether the Answer-Defaults profile requires
Calling Line ID (CLID) authentication, called number authentication, or both.

The CLID is the phone number of the calling device, which is not always provided by the
WAN carrier. When the profile requires CLID authentication, the caller’s phone number
must match a phone number specified in a local Connection profile or RADIUS user
profile.

The called-party number is the phone number the remote device called to connect to the
MAX, but does not include a trunk group or dialing prefix specification. This number is
always available if specified in a profile. When the profile requires called-number
authentication, the number called must match a called-party number in a local Connection
profile or RADIUS user profile.

2 If CLID authentication is required or preferred (Id Auth=Require or Prefer) in the Answer
profile, or called number authentication is required (Id Auth=Called Require or Called
Prefer), the MAX first looks for a matching phone number in a local Connection profile.

If unsuccessful, the MAX then looks for a matching phone number in a RADIUS user
profile. If it still cannot find the correct phone number, the MAX hangs up.

If CLID authentication is set to Fallback, the MAX must receive a CLID in the incoming
call. The MAX answers the call if the CLID matches the local Connection profile or a
RADIUS user profile. If the MAX does not receive a response from RADIUS, it uses the
authentication set up in the Answer profile.

3 If a matching profile to the CLID or called number is found, the call is answered and
further authentication is normally not required. If a matching profile to the CLID or called
number is not found and ID Auth=Require or Called Require, the call is not answered.

Note: The RADIUS attribute Ascend-Require-Auth specifies whether additional
authentication is required. For more information, see the TAOS RADIUS Guide and
Reference.

4 If CLID authentication and called number authentication are not required, or if a matching
phone number is found in a local Connection profile or RADIUS user profile, the MAX
answers the call.

5 The MAX checks its other Answer profile settings.
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6 If the Answer profile specifies the type of link encapsulation the call uses, the MAX
continues checking Answer profile parameters. If the Answer profile does not enable the
type of link encapsulation the call uses, the MAX drops the call.

7 The MAX checks the value of the Profile Reqd parameter in the Answer profile.

If Profile Reqd=Yes, the MAX must find a Connection profile, Names/Passwords profile,
RADIUS user profile, or TACACS/TACACS+ profile to authenticate the call. Setting up
Profile Reqd configures user authentication for the following:

– Unencapsulated calls

– Calls using ARA or any other encapsulation listed in step 7

8 The MAX prompts the user for a login name and password. If the name and password
match a local Connection profile or Names/Passwords profile, the call is authenticated. If
no match is found and RADIUS or TACACS remote authentication has been enabled, the
MAX requests authentication from the remote server. The MAX clears the call if
authentication fails.

9 If name and password authentication is required, the MAX attempts to match the caller’s
name and password to a local Connection profile.

If authentication using a local Connection profile succeeds, the MAX uses the parameters
specified in the profile to build the connection.

10 If it cannot find a matching Connection profile, the MAX looks for a Names/Passwords
profile.

If the MAX finds the user’s name and password in a Names/Passwords profile, them to
build the connection with the settings in the Answer profile.

Note: The Names/Passwords profile applies only to ARA, PPP, MP, and MP+ calls. It
does not apply to terminal server users.

11 If it cannot find a matching Names/Passwords profile, the MAX looks for a RADIUS,
TACACS, or TACACS+ profile containing a matching name and password.

If authentication using a RADIUS user profile succeeds, the MAX uses the specified
RADIUS attributes to build the connection. The MAX can then forward the call to its
bridge/router or other destination. For example, the MAX might forward a terminal server
call to a Telnet or TCP host.

If authentication using a TACACS or TACACS+ profile succeeds, the MAX must make a
request to the server for information about the resources and services the user can access.

12 If name and password authentication is not required (Recv Auth=None or Password
Reqd=No in the Answer profile), the MAX can match IP-routed PPP calls by using the IP
address specified by the Connection profile.

13 If the Answer profile does not require a profile (Profile Reqd=No), the MAX uses Answer
profile parameters to build the connection.

Note: You can limit the duration of incoming calls. For instructions, see “Setting Connection
profile parameters” on page 3-30.

No matter which authentication method you choose, you can access authentication and user
configuration data stored locally or remotely. You have the following options:

• Local authentication using a Connection profile or a Names/Passwords profile.

• Remote authentication using a TACACS, TACACS+, or RADIUS server. (For details of
configuring the MAX to use a TACACS or TACACS+ server, see “Setting up an
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authentication server” on page 3-42. For details of configuring the MAX to use a
RADIUS server, see the TAOS RADIUS Guide and Reference.)

• Remote authentication using a AssureNet Defender server. For details of configuring the
MAX to use a Defender server, see “Configuring direct Defender server authentication”
on page 5-24.

• Security-card authentication. You use an external authentication server, such as an ACE or
SafeWord server, and set up your network site to require that users change passwords very
frequently (many times per day). For details, see Chapter 3, “Setting Up User
Authentication.”

Setting up CLID authentication
You can require the MAX to authenticate incoming calls by checking the calling party’s phone
number (CLID authentication). The MAX performs CLID authentication before answering an
incoming call. You can thereby ensure that the call originates from a known location. To set up
CLID authentication, use the parameters listed in Table 3-2.

When you set up CLID authentication, you can choose one of the following configurations:

• Authenticate all callers using name, password, and calling line ID.

For details, see “Setting up authentication using a name, password, and calling line ID” on
page 3-7.

• Authenticate all callers using a calling line ID only. (For details, see “Setting up
authentication using a calling line ID only” on page 3-8.)

• Use an external authentication server, such as a token-card authentication server, to
authenticate users after CLID authentication. (For details, see the TAOS RADIUS Guide
and Reference.)

Table 3-2. CLID authentication parameters

Location Parameters with sample values

System > Sys Config Name=mygw

Ethernet > Answer Id Auth=Require
Profile Reqd=Yes

Ethernet > Answer > PPP Options Recv Auth=Either

Ethernet > Answer > COMB Options Password Reqd=Yes

Ethernet > Connections > any Connection profile Station=Emma
Calling #=555-1213

Ethernet > Connections > any Connection profile >
Encaps Options

Recv PW=office-pw

Ethernet > Ethernet > Mod Config > Auth menu CLID Timeout Busy=No
CLID Fail Busy=No
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• Request PAP, CHAP, or MS-CHAP after CLID authentication. (For details, see the TAOS
RADIUS Guide and Reference.)

General guidelines

Before you set up CLID authentication, keep the following limitations in mind:

• In some installations, the WAN provider might not be able to deliver CLIDs, or a caller
might choose to keep a CLID private.

• CLID authentication applies only for connections in which CLID is available end-to-end
and ANI (Automatic Number Identification) applies to the call.

• T1 access lines and Switched-56 lines do not support CLID.

• When a user dials into the MAX for a MP or MP+ connection, the calling device might
have more than one phone number associated with it. In this type of situation, the CLID is
the phone number associated with the channel in use.

• If you set up a RADIUS user profile for callback and CLID-only authentication, the MAX
never answers the call, and the caller therefore avoids possible billing charges.

CLID authentication requirement options

The Network Configuration Guide for your MAX provides instructions for setting up CLID
authentication and for requiring that a RADIUS entry be used for the CLID authentication.
You can also configure Connection Profiles to authenticate using caller ID. Lucent
recommends that you perform this function in RADIUS.

When you set up CLID authentication either in RADIUS or in a MAX Connection profile, you
must specify what the MAX requires for the CLID authentication. Table 3-3 lists the available
options:

Table 3-3. CLID authentication requirement options

Option Description

Require The MAX must receive a CLID from the incoming call. The CLID must
match a Calling # parameter in a local Connection profile or in a RADIUS
user profile that has Password set to Ascend-CLID (For more information, see
the TAOS RADIUS Guide and Reference). If the MAX does not receive a
CLID or if it cannot match the CLID, the call is not answered.

Note: The matching user profile in RADIUS can require name and password
authentication in addition to CLID, depending on the value of the
Ascend-Require-Auth attribute.

Prefer The MAX does not require a CLID from the incoming call. If a CLID is
received, the MAX compares the CLID with a Calling # parameter in a local
Connection profile or with a RADIUS user profile that has Password set to
Ascend-CLID. If the MAX does not receive a CLID from the incoming call, it
uses the authentication configured in the Answer profile.
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Setting up authentication using a name, password, and calling line ID

Note: To authenticate on all three criteria (name, password, and Caller ID), you must specify
RADIUS authentication by setting the Auth parameter to RADIUS. For information, see the
TAOS RADIUS Guide and Reference.

To require all callers to pass name, password, and CLID, authentication, proceed as follows:

1 In the Ethernet > Answer menu, set Id Auth=Prefer.

The Prefer setting specifies that, whenever CLID is available, the MAX compares the
calling party’s phone number to the value of the Calling # parameter in the Connection
profile or a RADIUS user profile set up for Ascend-CLID.

– If a match is found, and no further authentication is required, the MAX accepts the
call.

– If a match is found and the MAX requires further authentication (Profile Reqd=Yes in
the Answer profile), the MAX applies authentication using the Recv Auth or
Password Reqd parameters in the Answer profile.

– If the CLID is not available, or if the MAX cannot find a match to the calling party
number, the MAX applies authentication using the Recv Auth or Password Reqd
parameters in the Answer profile.

Note: You can also set Id Auth=Require or Id Auth=Fallback.

2 Verify that no local profiles are set up for CLID authentication.

3 Set Profile Reqd=Yes.

4 For PPP calls, set Recv Auth to the authentication protocol.

5 For Combinet calls, set Password Reqd=Yes.

6 Set the CLID Timeout Busy parameter to specify whether the MAX returns User Busy
when CLID authentication fails because of a RADIUS timeout.

Set CLID Timeout Busy=Yes, to specify that MAX returns User Busy as the disconnect
cause when CLID authentication fails because of a RADIUS timeout.

The default value is No. When CLID Timeout Busy=No, the MAX returns Normal Call
Clearing as the disconnect cause.

7 Set the CLID Fail Busy parameter to specify whether the MAX returns User Busy when
CLID authentication fails for any reason other than a RADIUS timeout.

Set CLID Fail Busy=Yes to specify that the MAX returns User Busy when CLID
authentication fails for any reason other than a RADIUS timeout.

Fallback The MAX must receive a CLID in the incoming call. If no CLID is received,
the MAX does not answer the call. If a CLID is received, the MAX compares
the CLID with a Calling # parameter in a local Connection profile or with a
RADIUS user profile with Password set to Ascend-CLID. If the CLID does
not match that has the Connection profile and the MAX does not receive a
response from the RADIUS server, it uses the authentication configured in the
Answer profile.

Table 3-3. CLID authentication requirement options (continued)

Option Description
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The default is No. CLID Fail Busy=No specifies that the MAX returns Normal Call
Clearing.

You can choose the value for this field regardless of the Server setting because the occurrence
of this failure does not depend upon using a RADIUS server.

8 Save your changes.

For further information, see the TAOS RADIUS Guide and Reference.

Setting up authentication that uses a calling-line-ID only

Although you can configure local Connection profiles for authentication by calling-line-ID
only. Lucent recommends that you use RADIUS for this type of configuration.

To require all callers to authenticate by a calling-line-ID only, proceed as follows:

1 In the System > Sys Config menu, specify the name of the MAX as the Name parameter.

2 In the Ethernet > Answer menu, set Profile Reqd=Yes.

3 In the Ethernet > Answer menu, set Id Auth=Require.

The Require setting specifies that the calling party’s phone number must match the value
of the Calling # parameter in the Connection profile before the MAX can answer the call.
If CLID is not available, the MAX does not answer the call.

4 Open the Ethernet > Connections menu.

5 In the Connection profile, specify the caller’s phone number by setting the Calling #
parameter.

6 Save your changes.

Setting up called number authentication
Called-number authentication works like CLID authentication, except that the MAX uses the
number called by the remote end to authenticate the connection. The called number appears in
an ISDN message as part of the call when DNIS is in use. Called-number authentication is also
known as DNIS authentication.

To set up called-number authentication, use the parameters listed in Table 3-4.

Table 3-4. Called Number authentication parameters

Location Parameters with sample values

System > Sys Config Name=mygw

Ethernet > Answer Id Auth=Called Require
Profile Reqd=Yes

Ethernet > Answer > PPP Options Recv Auth=Either

Ethernet > Answer > COMB Options Password Reqd=Yes
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Setting up called-number authentication options

You can choose one of the following configurations for called number authentication:

• Authenticate all callers with name, password, and called number. (For details, see “Setting
up authentication using a name, password, and called number” on page 3-10.)

• Authenticate all callers by called-number only. (For details, see “Setting up authentication
using the called number only” on page 3-10.)

• Authenticate with an external authentication server, such as a token-card authentication
server, to authenticate users after called number authentication.

When you configure called number authentication either in RADIUS or in a MAX Connection
profile, you must set the XX profile’s ID Auth parameter to specify what the MAX requires for
the called-number authentication. Table 3-5 shows the available options.

Ethernet > Connections > αny Connection profile Station=Emma
Called #=555-1213

Ethernet > Connections > αny Connection profile >
Encaps Options

Recv PW=office-pw

Table 3-4. Called Number authentication parameters (continued)

Location Parameters with sample values

Table 3-5. Called Number authentication options

Option Description

Called
Require

The MAX must receive a called number from the incoming call. The
called number must match a Called-number parameter, in a local
Connection profile or in a RADIUS user profile (For more information,
see the TAOS RADIUS Guide and Reference). If the MAX does not
receive a called number or if it cannot match the called number, the call is
not answered.

Note: The matching user profile in RADIUS can require name and
password authentication in addition to called number, depending on the
Ascend-Require-Auth attribute.

Called Prefer The MAX does not require a called number from the incoming call. If a
called number is received, however, the MAX compares the called
number with a Called # parameter in a local Connection profile or with a
RADIUS user profile. If the MAX does not receive a called number from
the incoming call, it uses the authentication configured in the Answer
profile.
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Setting up authentication using a name, password, and called number

To authenticate on all three criteria (name, password, and called number), you must specify
RADIUS authentication by setting the Auth parameter to RADIUS. (For further information,
see the TAOS RADIUS Guide and Reference.)

To require all callers to pass name, password, and called number authentication. Proceed as
follows:

1 In the Ethernet > Answer menu, set Id Auth=Called Prefer.

The Prefer setting specifies that whenever the called number is available, the MAX
compares the phone number called to the value of Called # in the Connection profile.

– If a match is found, and no further authentication is required, the MAX accepts the
call.

– If a match is found and the MAX requires further authentication (Profile Reqd=Yes in
the Answer profile), the MAX applies authentication using the Recv Auth or
Password Reqd parameters in the Answer profile.

– If the called number is not available, or if the MAX cannot find a match to the calling
party number, the MAX applies authentication using the Recv Auth or Password
Reqd parameters in the Answer profile.

2 Verify that no Connection profiles are set up to authenticate users by called number.

3 Set Profile Reqd=Yes.

4 For PPP calls, set Recv Auth to the authentication protocol.

5 For Combinet calls, set Password Reqd=Yes.

6 Save your changes.

Setting up authentication using the called number only

Although you can configure local Connection profiles to authenticate by the called number
only, Lucent recommends that you in RADIUS for this type of configuration.

To require all callers to pass a called-number authentication only, proceed as follows:

1 In the System > Sys Config menu, set the Name parameter to specify the name of the
MAX.

2 In the Ethernet > Answer menu, set Profile Reqd=Yes.

3 In the Ethernet > Answer menu, set Id Auth=Called Require.

The Called Require setting specifies that the called number must match the value of the
Called # parameter in the Connection profile before the MAX can answer the call. If the
called number is not available, the MAX does not answer the call.

4 Open the Ethernet > Connections menu.

5 In the Connection profile, specify the called number by setting the Called # parameter.

6 Save your changes.
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Setting up callback security
There are two types of callback security: Lucent’s callback security and Microsoft callback
security.

Callback security

Callback security instructs the MAX to hang up on an incoming caller and immediately initiate
call back. Callback ensures that the connection is with a known destination.

For outgoing calls, you can configure the MAX to expect a callback from the machine that is
called. This prevents problems that arise when CLID is set to Required (ID Auth=Required) on
the machine that is expected to call back.

For example, in Figure 3-1 Ping or Telnet is initiated through a MAX to a Pipeline, and CLID
is set to Required on the Pipeline (the side that is calling back). The Pipeline rejects the
incoming call before answering it. To the MAX (the initiating side), it appears as if the call
never got through.

Figure 3-1. Callback connection failure

The Callback process is disrupted when protocols like Ping and Telnet continuously try to open
a connection.

When Expect Callback is set to Yes, calls that dial out and do not connect (for any reason) are
put on a list that disallows any further calls to that destination for 90 seconds. This gives the far
end an opportunity to complete the callback. If a call fails for any reason, regardless of whether
or not the called machine requires CLID and is attempting a callback, the call initiator must
still wait 90 seconds before attempting to call the same number again.

Table 3-6 lists the Lucent callback parameters on the MAX.

Table 3-6. Lucent callback security parameters

Location Parameters with sample values

Ethernet > Connections > any Connection profile Calling #=555-1213
Dial #=555-1213

Call
Initiator
sends
Ping

Pipeline (CLID=Required)
rejects call, then tries to
call backMAX keeps calling to

connect for Ping

Call
Receiver

WAN
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For information about setting up callback security in RADIUS, see the TAOS RADIUS Guide
and Reference.

To set callback security on the MAX, proceed as follows:

1 Open the Ethernet > Connections menu.

2 Open a Connection profile.

3 Set the Dial # parameter to specify the number the MAX dials to reach the remote end of
the connection.

For example:

Dial #=555-1213

Note: The MAX can also use the CLID to reach the remote end of the connection, if the
CLID is available.

4 Set the Calling # parameter to specify the number the remote device dials to call the MAX.

For example:

Calling #=555-1213

5 Open the Telco Options submenu of the Connection profile.

6 Turn on callback security by setting the following parameters as shown:

Callback=Yes
Exp Callback=Yes
AnsOrig=Both

Note: Callback does not apply to leased lines (if Call Type=Nailed).

When you set Callback=Yes, you must also set AnsOrig=Both, because the Connection
profile must both answer the call and call back the device requesting access. Similarly, the
calling device must be able to both dial to and accept calls from the MAX.

To prevent a problem when CLID on the called machine is set to Required, set Exp
Callback to Yes.

7 Save your changes.

Note: If the Pipeline is the calling device and callback is set up on the MAX, the Pipeline
must be set to Expect Callback.

Microsoft’s Callback Control Protocol (CBCP)

Microsoft Corporation developed CBCP to address a need for greater security with PPP
connections. The standardized callback option defined in RFC 1570 has a potential security
risk because the authentication is performed after the callback. CBCP callback, like Lucent’s
proprietary callback, occurs after authentication, leaving no potential security hole.

Ethernet > Connections > any Connection
profile > Telco Options

Callback=Yes
Exp Callback=Yes
AnsOrig=Both

Table 3-6. Lucent callback security parameters (continued)

Location Parameters with sample values
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CBCP also offers features not available with the standard callback defined in RFC 1570. The
client side supports a configurable time delay to allow users to initialize modems or enable
supportive software before the MAX calls the client. You can configure the MAX with a phone
number to use for the callback, or you can configure it to allow the client to specify the phone
number used for the callback.

Currently, Microsoft’s Windows NT 4.0 and Windows 95 software support client-side
authentication using CBCP. The MAX supports a CBCP central-site solution.

Lucent’s implementation of CBCP

CBCP is an option negotiated during the LCP (Link Control Protocol) negotiation of a PPP
session. Although support for CBCP is configured systemwide on the MAX, not every
connection must negotiate its use. Parameters exist in the Answer Profile under Ethernet >
Answer > PPP Options, and in each Connection Profile under Ethernet > Connections > any
Connection profile > Encaps Options. The calling and called sides of a PPP session initiate
authentication after acknowledging that CBCP is to be used.

Note: Currently, the MAX does not initiate LCP negotiation of CBCP. The MAX responds to
caller requests to configure CBCP.

The MAX employs the username and password to link a caller with a specific Connection
profile or RADIUS User profile. Configured CBCP parameters in that Connection profile
specify variables for the callback. If, at any point, the client and the MAX disagree about any
CBCP variables, the MAX might drop the connection.

Both sides of the connection must agree on whether the callback phone number is supplied by
the client or by the MAX. A new trunk group parameter, configured on the MAX, supplies a
trunk group that is prepended to phone numbers when they are supplied by the client.

Table 3-7 lists the MAX parameters for CBCP.

For information about setting up callback security in RADIUS, see the TAOS RADIUS Guide
and Reference.

Negotiation of CBCP

Following are the steps in CBCP negotiation, from initial connection to MAX callback:

1 Caller connects to MAX.

2 LCP negotiations begin.

Table 3-7. Microsoft’s CBCP parameters on the MAX

Location Sample parameters

Ethernet > Answer > PPP options CBCP Enable

Ethernet > Connections > any
Connection profile > Encaps options

CBCP Mode

Ethernet > Connections > any
Connection profile > Encaps options

CBCP Trunk Group
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Caller and MAX must agree to use CBCP. Otherwise, the MAX terminates the connection.

3 After successful LCP negotiation, both sides have acknowledged that CBCP will be used,
and CBCP begins after authentication.

4 Caller authenticates itself to MAX. If authentication fails, the MAX terminates the
connection.

5 The MAX verifies that the profile has CBCP Mode set. CBCP begins.

6 The MAX sends a request to determine if a callback is to occur. The caller’s configuration
must match the CBCP Mode value on the MAX.

The client also supplies to the MAX the number of seconds it should delay before
initiating the callback, and, if applicable, the phone number.

7 If both sides agree on which phone number the MAX will dial, and the client clears the
connection.

8 The MAX delays the callback on the basis of the previous negotiation.

9 The MAX dials the client, by applying information from the same profile used during
negotiation.

Configuring Microsoft’s CBCP to use a Connection Profile

To configure CBCP to work with a Connection profile:

1 Open the Ethernet > Answer > PPP Options menu.

2 Set CBCP Enable = Yes.

3 Open the Ethernet > Connections > any Connection profile > Encaps Options menu.

4 Set CBCP Mode to the callback mode to be offered the caller.

5 If the caller is supplying the phone number, set CBCP Trunk Group to the value (4–9) that
the MAX prepends to the number when calling back.

6 Save your changes.

Setting up call authentication on serial AIM ports
For calls placed across the Host serial inverse multiplexing ports, you can specify a password
in the Call profile for outgoing calls and in the Port configuration profile for incoming calls.

Understanding serial call authentication

Serial call authentication is used only if the receiving unit has a password defined in its Port
profile. If the Port profile in the receiving unit does not have a password defined, the units
connect without authentication even though the originating unit might have sent authentication
parameters.

Note: The MAX only authenticates AIM and BONDING calls. Dual-port calls are not
authenticated.

Upon initial connection of the first channel, the originating unit passes the Call profile
password to the authenticating unit. The authenticating unit compares the password received
with stored in the Port profile. If the password received matches the stored password, the
session is established normally for the remainder of the call. If there is no match, the
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authenticating unit sends a message back to the originator and drops the session. The port
status screen in Host > Dual > portname > Message Log indicates that the call failed
authentication.

Configuring serial port passwords

To set the passwords, proceed as follows:

1 For outgoing AIM or BONDING calls, specify the DBA call password as the Call
Password setting in the Host/Dual (or Host/6) > Port N Menu > Directory > appropriate
Call profile.

Dynamic Bandwidth Allocation (DBA) enables the MAX to increase bandwidth as
needed and drop bandwidth when it is no longer required.

2 For incoming AIM and BONDING calls, specify the port password as the Port Password
setting in Host/Dual (or Host/6) > Port N Menu > Port Config (the Port profile)

Setting up authentication of PPP, MP, and MP+ calls
For PPP, MP, and MP+ calls, the answering unit always determines the authentication method.
You can specify PAP, CHAP, or MS-CHAP authentication for name and password verification
of incoming PPP, MP, or MP+ calls.

The only MS-CHAP format MAX units support is the Windows NT version, with DES and
MD4 encryption. A MAX can authenticate a Windows NT system and a Windows NT system
can authenticate a MAX. For more specific information about the MS-CHAP format, see
Microsoft’s Web site at:

ftp://ftp.microsoft.com/DEVELOPR/RFC/chapexts.txt

You can also request an authentication protocol for outgoing PPP, MP, and MP+ calls.

For information about how PPP, MP, and MP+ authentication works, see “How does user
authentication work?” on page 3-3. For complete information about setting up PPP, MP, and
MP+ calls on the MAX, see the Network Configuration Guide for your MAX. For complete
information about setting up PPP, MP, and MP+ calls and authentication in RADIUS, see the
TAOS RADIUS Guide and Reference.

Understanding PPP, MP, and MP+

PPP enables you to set up a single-channel connection to any other device running PPP. A PPP
connection can support IP routing, IPX routing, protocol-independent bridging, and password
authentication that uses PAP, CHAP, or MS-CHAP.

A PPP connection is usually a bridged or routed network connection initiated in PPP dialup
software. Figure 3-2 shows the MAX with a PPP connection to a remote user running
Windows 95 with the TCP/IP stack and PPP dialup software.
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Figure 3-2. A PPP connection

MP and MP+ are enhancements to PPP for supporting multichannel links.

MP supports a fixed number of multichannel links. The base channel count determines the
number of calls to place, and the number of channels does not change. In addition, MP requires
that all channels in the connection share the same phone number. That is, the channels on the
answering side of the connection must be in a hunt group.

MP+ supports multichannel links and Dynamic Bandwidth Allocation (DBA). DBA enables
the MAX to increase bandwidth as needed and drop bandwidth when it is no longer required.
MP+ is the only PPP-based encapsulation method that supports DBA. An MP+ connection can
combine up to 30 channels into a single high-speed connection.

Understanding PAP, CHAP, and MS-CHAP

For PAP, CHAP, and MS-CHAP authentication, the calling unit and the MAX each share a
different secret with the RADIUS server:

• The calling unit’s secret is called the remote secret. The MAX does not know the value of
this secret.

• The MAX unit’s secret is called the NAS secret (because the MAX is an Network Access
Server). The calling unit does not know the value of this secret.

PAP, CHAP, or MS-CHAP authentication is required if the incoming PPP call does not include
a source IP address.

Note: PAP, CHAP, and MS-CHAP authentication is not available for Combinet, ARA, V.34,
V.42, V.110, or V.120 calls.

How PAP works

PAP is a PPP authentication protocol that provides a simple method for the MAX to establish
its identity in a two-way handshake. Authentication takes place only upon initial link
establishment and does not use encryption. The remote device must support PAP.

For PAP authentication, the following events take place:

1 The calling unit sends the remote secret in the clear to the MAX.

2 The MAX uses the NAS secret to encrypt the remote secret.

3 The RADIUS server uses the NAS secret to decrypt the remote secret.

4 The RADIUS server passes the clear copy of the remote secret to a UNIX or other
password validation system.
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How CHAP works

CHAP specifies a PPP authentication protocol that is more secure than PAP. It provides a way
for the remote device to periodically verify the identity of the MAX by means of a three-way
handshake and encryption. Authentication takes place upon initial link establishment. A device
can repeat the authentication process any time after the connection is made. The remote device
must support CHAP.

For CHAP authentication, the following events take place:

1 The MAX sends a random, 128-bit challenge to the calling unit.

2 The calling unit uses the remote secret, the challenge, and the PPP packet ID to calculate
an MD5 digest.

3 The calling unit sends the MD5 digest, the challenge, and the PPP packet ID (but not the
remote secret) to the MAX. The MAX never has the remote secret.

4 The MAX forwards the digest, along with the original challenge and PPP packet ID to
RADIUS.

No encryption is necessary, because MD5 creates a one-way code that cannot be decoded.
In addition, RADIUS cannot extract the remote secret. Therefore, it cannot provide a
password to a UNIX password system. For this reason, CHAP and UNIX authentication
cannot work together.

5 The RADIUS server looks up the remote secret from a local database and uses the local
version of the remote secret, along with the challenge and the PPP packet ID it received
from the MAX, to calculate an MD5 digest.

6 The RADIUS server compares the calculated MD5 digest with the digest it received from
the MAX.

If the digests are the same, the remote secrets used by the calling unit and the RADIUS
server are the same, and the call is authenticated.

How MS-CHAP works

MS-CHAP is similar to CHAP with minor differences. For more information, see the
Microsoft Website at

ftp://ftp.microsoft.com/DEVELOPR/RFC/chapexts.txt

Configuring PAP, CHAP, or MS-CHAP for PPP, MP, and MP+ calls

To configure incoming and outgoing connections using PAP, CHAP, or MS-CHAP, you must
carry out the following tasks:

• Set systemwide System, Answer, and Ethernet profile parameters. These parameters
specify the name of the MAX, the types of encapsulation allowed, the kind of
authentication required, and the contents of one or more IP address pools.

• Set up a Connection profile, Names/Passwords profile, or RADIUS user profile
containing settings for each individual connection.

Note: You only need to set up one of these profiles.
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Table 3-8 lists the parameters you can set.

Setting systemwide parameters

To set systemwide parameters for PAP, CHAP, or MS-CHAP authentication, proceed as
follows:

1 To specify the name of the MAX used for making outgoing calls, set the Name parameter
in the System > Sys Config menu.

2 In the Ethernet > Answer menu, set Profile Reqd=Yes.

This setting specifies that the MAX rejects incoming calls for which it can find no
Connection profile, no Names/Passwords profile, and no entry on a remote authentication
server.

For an ARA connection, setting Profile Reqd=Yes prohibits Guest access.

3 In the Ethernet > Answer > Encaps menu, specify that the unit can receive PPP, MP, or
MP+ calls or any combination of PPP, MP, and MP+ calls.

Note: PAP, CHAP, and MS-CHAP authentication is available only if you choose MP,
MPP, or PPP.

– To specify that the unit can receive PPP calls, set PPP=Yes.

Table 3-8. Parameters for incoming connections using PAP, CHAP, or MS-CHAP

Location Parameters with sample values

System > Sys Config Name=mygw

Ethernet > Answer Profile Reqd=Yes

Ethernet > Answer > Encaps PPP=Yes
MP=Yes
MPP=Yes

Ethernet > Answer > PPP Options Recv Auth=PAP, CHAP,
MS-CHAP, or Either

Ethernet > Mod Config > WAN Options Pool#1 Start=100.0.0.20
Pool#1 Count=90
Pool Only=Yes

Ethernet > Connections > any Connection profile Station=dialmax
Encaps=PPP, MP, or MPP

Ethernet > Connections > any Connection
profile > Telco Options

Dialout OK=Yes

Ethernet > Connections > any Connection profile >
Encaps Options

Recv PW=office-pw

Ethernet > Names/Passwords > any
Names/Passwords profile

Name=Fred
Recv PW=office-pw
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– To specify that the unit can receive MP calls, set MP=Yes.

– To specify that the unit can receive MP+ calls, set MPP=Yes.

4 In the Ethernet > Answer > PPP Options menu. Set Recv Auth to PAP, CHAP, MS-CHAP,
or Either.

When you specify Either, the MAX allows authentication if the remote peer can
authenticate with any of the designated authentication schemes. If you specify a protocol,
the MAX allows authentication only if the remote peer uses that protocol for
authentication.

5 If you are using a Names/Passwords profile for an IP routing connection, open the
Ethernet > Mod Config > WAN Options menu to begin setting up one or more IP address
pools.

Unlike Connection profiles and RADIUS user profiles, Names/Passwords profiles cannot
specify an IP address for the calling station. When you use a Names/Passwords profile to
authenticate an IP routing connection, the MAX automatically assigns the PPP caller a
dynamic IP address as the connection is established. For a call configured in a
Names/Passwords profile, the address assignment is always from the pool of addresses
defined as Pool #1, if Pool #1 exists and has available addresses. If Pool #1 does not exist
or does not have available addresses, the MAX assigns an address from Pool #2.

6 Set up address pools by setting the Pool #n Count and Pool #n Start parameters.

The Pool #n Count parameter specifies the number of IP addresses in the IP address pool.
Specify a number between 0 and 254. The default value is 0 (zero).

The Pool #n Start parameter specifies the first IP address in the address pool. Specify an IP
address in dotted decimal notation. The default value is 0.0.0.0.

You can also set up address pools by setting the Ascend-IP-Pool-Definition attribute. For
details, see the TAOS RADIUS Guide and Reference.

7 Set Pool Only=Yes.

The Pool Only parameter determines whether a caller can reject an IP address assignment
and use his or her own IP address. To eliminate the possibility of a caller rejecting the
automatic dynamic assignment and spoofing a local, trusted address, set Pool Only=Yes
when using Names/Passwords profiles to authenticate IP routing connections.

For a call configured in a Names/Passwords profile, the address assignment is always
from the pool of addresses defined as Pool #1, if Pool #1 exists and has available
addresses. If Pool #1 does not exist or does not have available addresses, the MAX assigns
an address from Pool #2.

If the calling station rejects the assignment, the MAX ends the call.

8 Save your changes.

Setting Connection profile parameters

If you set up a Connection profile, you do not need to set up a Names/Passwords profile or a
RADIUS user profile. To set Connection profile parameters for PAP, CHAP, or MS-CHAP
authentication, proceed as follows:

1 Open the Ethernet > Connections menu.

2 Open a Connection profile.

3 Set the Station parameter to the name of the user or device making the incoming call.

4 Set the Encaps parameter to the type of encapsulation used on the link:
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– PPP, which specifies Point-to-Point Protocol, ensures basic compatibility with
devices produced by other manufacturers. For this setting to work, both the dialing
side and the answering side of the link must support PPP.

– MP specifies Multilink Protocol.

– MPP specifies Multilink Protocol Plus (MP+). Both the dialing side and the
answering side of the link must support MP+. If only one side supports MP+, the
connection attempts to use MP. If MP is not available, the connection uses standard
single-channel PPP.

MP+ calls cannot combine an ISDN BRI channel with a channel on a T1 access line
or a T1 PRI line.

5 Open the Encaps Options submenu of the Connection profile.

6 Set the Recv PW parameter to specify the password that the remote end of the link must
send.

If the password specified by Recv PW does not match the remote end’s value for Send PW
(in a Connection profile), Ascend-Send-Passwd (in a RADIUS user profile), or
Ascend-Send-Passwd (in a RADIUS user profile), the MAX disconnects the link.

7 Save your changes.

Setting Names/Passwords profile parameters

If you set up a Names/Passwords profile, by default you do not need to set up a Connection
profile or a RADIUS user profile. The Names/Passwords profile applies only to ARA, PPP,
MP, and MP+ calls and to terminal server users.

You have to set Names/Passwords profile parameters, including the Template Connection #
parameter and then activate the profile.

Setting the names and passwords profile parameters

To set Names/Passwords profile parameters for PAP, CHAP, or MS-CHAP authentication,
proceed as follows:

1 Open the Ethernet menu.

2 Open the Names/Passwords menu.

3 Open a Names/Passwords profile.

4 Set the Name parameter to the name of the user or device making the incoming call.

In a Names/Passwords profile, the Name parameter specifies the username associated with
the profile. The name you specify also becomes the name of the profile.

5 Set the Recv PW parameter to specify the password that the remote end of the link must
send.

If the password specified by Recv PW does not match the remote end’s value for Send PW
(in a Connection profile), Ascend-Send-Passwd (in a RADIUS user profile), or its
equivalent, the MAX disconnects the link.

Setting the Template Connection # parameter

To set the value for Template Connection #, proceed as follows:
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– Use the default, Template Connection=#0 (the Answer profile), to specify that the
Names/Passwords Profile use the Answer Profile as a template.

This mode supports clients dialing in over PPP and ARA, but does not support a
router dialing in.

– Enter a profile number from 1 to 31 to specify the Connection Profile to which the
number refers.

In this mode the Names/Passwords profile functions as an alias for the Connection
profile.

Activating the profile

To activate the Names/Passwords profile, proceed as follows:

1 Set Active=Yes.

2 Save your changes.

When a user calls the MAX and Recv Auth has been set to a value other than None in the
Answer profile, the MAX asks for a username and password. If the user enters the username
specified by the Name parameter in the Names/Passwords profile, and the password specified
by the Recv PW parameter in the Names/Passwords profile, the MAX uses the Answer profile
parameters to establish the connection.

Disabling groups of dial-in calls with the Names/Passwords profile

If you specify a Connection profile to use as a template for the Names/Passwords profile, you
can specify a single Connection profile for a group of users, but have individual
Names/Passwords profiles for each user by setting Template Connection # to a number that
refers to a Connection profile. The MAX uses that Connection profile for authentication.

For example, you can set up a Connection profile for the Sales group to use when dialing in,
then set up a Names/Passwords profile for each individual salesperson. To prevent a user (or
users) from dialing in, use one of the following two methods:

• To prevent a single salesperson from dialing in, deactivate the Names/Passwords profile
for that salesperson by setting the Names/Passwords Active flag for the user’s
Names/Passwords profile to No.

• De-activate the entire Sales group by setting the Connection profile Active flag for the
Sales group to No.

Note: You can set the Template Connection # parameter to the same value for different
Names/Passwords profiles.

Using a RADIUS user profile

If you set up a RADIUS user profile, you do not need to set up a Connection profile or a
Names/Passwords profile. For information about setting RADIUS attributes for PAP, CHAP, or
MS-CHAP authentication, see the TAOS RADIUS Guide and Reference.
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Requesting PAP, CHAP, or MS-CHAP for outgoing calls

To request PAP, CHAP, or MS-CHAP authentication for an outgoing PPP, MP, or MP+ call,
use the parameters listed in Table 3-9.

To specify PAP, CHAP, or MS-CHAP for an outgoing PPP, MP, or MP+ call, proceed as
follows:

1 Set the Name parameter in the System > Sys Config menu to specify the name of the
MAX,

2 Open the Ethernet > Connections menu.

3 In the Connection profile, set the Encaps parameter to the type of encapsulation used on
the link:

– PPP specifies that Point-to-Point Protocol, which ensures basic compatibility with
devices produced by other manufacturers. For this setting to work, both the dialing
side and the answering side of the link must support PPP.

– MP specifies Multilink Protocol.

– MPP specifies Multilink Protocol Plus. Both the dialing side and the answering side
must support MP+. If only one side supports MP+, the connection attempts to use MP.
If MP is not available, the connection uses standard single-channel PPP.

MP+ calls cannot combine an ISDN BRI channel with a channel on a T1 access line
or a T1 PRI line.

4 In the Encaps Options submenu of the Connection profile, set Send Auth=PAP, CHAP, or
MS-CHAP.

This parameter specifies the authentication protocol that the MAX requests when
initiating a connection using PPP, MP, or MP+ encapsulation. The answering side of the
connection determines which authentication protocol the connection uses (if any).

5 In the Encaps Options submenu, set the Send PW parameter to the password that the MAX
sends to the remote end of a connection on outgoing calls.

If the password specified by Send PW does not match the remote end’s value for Recv PW
(in a Connection profile), Ascend-Receive-Secret (in a RADIUS user profile), or its
equivalent the remote end disconnects the link.

6 Save your changes.

For complete information about setting up an outgoing call in the MAX configuration
interface, see the Network Configuration Guide for your MAX. For complete information

Table 3-9. Parameters for outgoing connections using PAP, CHAP, or MS-CHAP

Parameter Parameters with sample values

System > Sys Config Name=mygw

Ethernet > Connections > any Connection profile Encaps=PPP, MP, or MPP

Ethernet > Connections > any Connection
profile >
Encaps Options

Send Auth=PAP, CHAP, or
MS-CHAP
Send PW=office-pwd
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about setting up an outgoing call and requesting authentication in RADIUS, see the TAOS
RADIUS Guide and Reference.

Setting up authentication for dial-in terminal server
users

This section describes the authentication of users calling into the MAX from a terminal or
other device that transmits and receives asynchronous data. Such sessions are called remote-
terminal-server sessions even if the user never sees the MAX terminal-server commands or
menu.

A remote-terminal-server session uses one of the types of encapsulation shown in Table 3-10.

Table 3-10. Dial-in terminal-server encapsulation types

Encapsulation Type Description

Modem calls The calls originate from either analog or digital modems.
Incoming modem calls and incoming digital calls come over the
same digital line to the MAX unit’s integrated V.34 or V.42
digital modem. An incoming modem call could be initiated
from a PC running a communication program like Soft Comm,
which causes the user’s modem to dial into the MAX. The
MAX directs the call to its digital modems, and then forwards
the calls to its terminal-server software. The terminal server
either displays one of its interfaces to the caller or forwards the
call to a Telnet or TCP host on the local network, depending on
how it is configured.

V.110 A V.110 card provides eight V.110 modems, each of which
enables the MAX to communicate with an asynchronous device
over synchronous digital lines. An asynchronous device such as
an ISDN modem encapsulates its data in V.110. The V.110
module in the MAX removes the encapsulation and enables an
asynchronous session, that is, a terminal server session.

V.120 calls V.120 terminal adapters such as the BitSurfer (also known as
ISDN modems) asynchronous calls with CCITT V.120
encapsulation. The MAX handles V.120 encapsulation in
software, so it does not require installed devices to process these
calls. After removing the link encapsulation, the MAX forwards
these calls to its terminal-server software. The terminal server
either displays one of its interfaces to the caller or forwards the
call to a Telnet or TCP host on the local network, depending on
how it is configured. Or, if it detects PPP encapsulation, it can
forward the call to the bridge/router software for an async PPP
session.



3-24 Preliminary November 29, 2000 MAX Security Supplement

Setting Up User Authentication
Setting up authentication for dial-in terminal server users

How terminal server authentication works

You can set up standard terminal-server authentication or per-user terminals. This section does
not apply to authentication using the Answer or Connection profile as a template (as described
in “Using an Answer or Connection profile as a template” on page 3-27).

For more general information about how authentication works in the MAX, see “How does
user authentication work?” on page 3-3.

Standard terminal server authentication

Terminal-server authentication makes use of the following parameters and profiles:

• The Passwd parameter in the Ethernet > Mod Config > TServ Options menu

• Connection profile parameters

The following events take place:

1 A caller initiates a terminal-server session that uses a V.34, V.42, V.110, or V.120
connection.

2 If Security=Full or Partial and Initial Scrn=Cmd in the TServ Options menu, the MAX
compares the password to the Passwd parameter.

3 If the caller enters the wrong password, the MAX hangs up.

4 If the caller enters the proper password or if no password is assigned to the Passwd
parameter, the MAX attempts to verify the caller by using Connection profile information.

5 If Security=None or Partial and Initial Scrn=Menu, the MAX skips the Passwd parameter
and attempts to verify the caller by using the Connection profile information.

Per-user terminal server authentication

Authentication by CLID or called-party number is slightly different from authentication on a
general basis. For per-user terminal server authentication, the following events occur:

1 Before the MAX answers a call, it checks whether the Answer-Defaults profile requires
Calling Line ID (CLID) authentication, called number authentication, or both.

The CLID is the phone number of the calling device, which is not always provided by the
WAN carrier. When the profile requires CLID authentication, the caller’s phone number
must match a phone number specified in a local Connection profile or RADIUS user
profile.

Note: The called-party number is the phone number the remote device called to connect
to the MAX, but does not include a trunk group or dialing prefix specification.

This number is always available if specified in a profile. When the profile requires called-
number authentication, the number called must match a called-party number in a local
Connection profile or RADIUS user profile.

2 If CLID authentication is required (Id Auth=Require in the Answer profile) or
called-number authentication is required (Id Auth=Called Require), the MAX first looks
for a matching phone number in a local Connection profile.

If one does not exist, it then looks for a matching phone number in a RADIUS user profile.
If it cannot find the correct phone number, the MAX hangs up.
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3 If CLID authentication and called-number authentication are not required, or if the MAX
finds a matching phone number in a local Connection profile or RADIUS user profile, it
answers the call.

4 Terminal-server sessions can require a system-terminal-server password in addition to the
per-user password.Whether a system-terminal-server user password is required depends
upon how the Security and Initial Scrn parameters in the Ethernet profile have been set:

– If Security=None, no authentication is performed.

– If Security=Partial, The MAX checks the value of the Profile Reqd parameter in the
Answer profile. If Profile Reqd=Yes, the MAX must find a Connection profile,
Names/Passwords profile, RADIUS user profile, or TACACS/TACACS+ profile to
authenticate the call.

– If Security=Full, the MAX must find a Connection profile, Names/Passwords profile,
RADIUS user profile, or TACACS/TACACS+ profile to authenticate the call, and
then prompt the user for the correct name.

5 If the name matches a local Connection profile or Names/Passwords profile, the call is
authenticated. If no match is found and RADIUS or TACACS remote authentication has
been enabled, the MAX requests authentication from the remote server. The MAX clears
the call if authentication fails.

Note: If Security=Partial or Security=Full, the user must supply the system-terminal-server
password whenever changing from the menu mode to the command-line mode.

Modem calls

A modem call might contain PPP encapsulation. For example, if the user is running Windows
95 with the TCP/IP stack and Netscape, Windows 95 could be configured to dial up the MAX
whenever Netscape is started. In that case, Windows 95 would be running async PPP. After the
call is forwarded to the terminal-server software, if PPP encapsulation is detected, the call is
forwarded to the bridge/router software for an async PPP session.

For dial-in users using modems, V.120, or V.110 devices to transport asynchronous PPP, see
“Setting up authentication of PPP, MP, and MP+ calls” on page 3-15. In these cases, none of
the above steps apply. Asynchronous PPP and synchronous PPP sessions are treated identically
by the MAX, except that asynchronous PPP sessions do not allow the user access to the MAX
unit’s terminal-server menus or commands.

This section describes first-level authentication using the Passwd parameter. For information
about authentication using a Connection profile, see “Setting Connection profile parameters”
on page 3-20.

Dial-in calls with no login host specified

You can configure the MAX to accept dial-in calls when Login-Service=TCP-Clear or
Login-Service=Telnet and no Login Host is specified in the RADIUS user profile. This option
does not apply to PPP encapsulated calls, because the MAX does not accept dial-in PPP calls
with the Login-Service set either to Telnet or TCP-Clear.

To set up the MAX to accept dial-calls when no login server is specified, set Auth TS
Secure=No in the Ethernet > Mod Config > Auth menu. The default is Auth TS Secure=Yes,
which means the MAX drops dial-in calls if there is no login server and Login-Server is Telnet
or TCP-Clear.
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Immediate Service

You can specify that a remote terminal-server user can establish a Telnet session immediately
after the terminal-server banner appears. To do so, set Immed Service=Telnet and Telnet Host
Auth=Yes in Ethernet > Mod Config > TServ Options menu.

Configuring terminal server authentication

Table 3-11 lists the parameters you can use to set up terminal-server password authentication.

To set up password authentication for the terminal-server interface, proceed as follows:

1 Open the Ethernet > Mod Config > TServ Options menu.

2 Set TS Enabled=Yes.

This setting enables users to access the terminal server interface. If you set this parameter
to No, no one can access the terminal server interface.

3 Set the Passwd parameter to specify the password a user must enter to begin a terminal-
server session.

You can enter up to 20 characters. The password is case sensitive

4 Set Security either to Full or Partial.

The Security parameter specifies whether a user must enter a password under different
circumstances.

– Partial specifies that the user must enter the system-terminal-server password (as
specified by the Passwd parameter) before entering the terminal-server command line
mode, but the user is not prompted for a login name or password. The user must enter
a terminal-server password when changing between menu-driven mode and
command-line mode if Initial Scrn=Cmd or Toggle Scrn=Yes in the TServ Options
menu.

– Full specifies that the user must enter the system terminal server password (in the
Passwd parameter) before entering the terminal server command line mode. When
making the initial connection, the user must enter a login name and password that
match a local Connection profile or a RADIUS or TACACS profile. The user must
enter a terminal server password when changing between menu-driven mode and
command-line mode if Initial Scrn=Cmd or Toggle Scrn=Yes in the TServ Options
menu. For information about restricting the options available from the menu-driven

Table 3-11. Terminal server security parameters

Location Parameters with sample values

Ethernet > Mod Config > TServ Options TS Enabled=Yes
Passwd=office-paswd
Security=Full
Login Timeout=300
Login Prompt: Login:
Password Prompt: Password Prompt:
Toggle Scrn=No
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interface, see “Restricting Telnet, raw TCP, and Rlogin access to the terminal server”
on page 3-28.

5 Set the Login Timeout parameter. to specify the number of seconds the MAX waits for a
user to complete logging in before disconnecting the user.

You can enter any integer from 0 to 300 seconds. The default is 300 (seconds).

The timer starts when the login prompt appears on the terminal-server screen. It does not
reset when the user makes an unsuccessful login attempt. If the user has not logged in
successfully by the time indicated by Login Timeout has elapsed, the MAX disconnects
the call.

6 Set the Login Prompt parameter to specify the prompt the terminal-server displays when
asking the user for a login name.

A login prompt can consist of up to 31 characters.

7 Set the Password Prompt parameter.

Specify the prompt the terminal-server displays when asking the user for a password.

A login prompt can consist of up to 31 characters.

8 Save your changes.

Using an Answer or Connection profile as a template

When a user with a Names/Passwords profile attempts to connect to the terminal server, the
MAX uses a template profile constructed from the Answer or Connection profile and the name
and password from the Names/Passwords profile. For more information, see the TAOS
RADIUS Guide and Reference.

If you prefer, you can authenticate a terminal-server user with the name and password from a
Names/Passwords profile, with any additional required parameter settings from the Answer or
Connection profile. Because the Names/Passwords profile does not include all the parameters
a terminal-server session might require, the MAX uses the settings from the Answer profile or
Connection profile named in the Template parameter for the additional parameters.

Restricting Telnet, raw TCP, and Rlogin access to the terminal server

For the security of other hosts on your local network, you can:

• Give users a menu of specific hosts to which they can establish a Telnet, raw TCP, or
Rlogin session. For information about menu mode, see the Network Configuration Guide
for your MAX.

• Specify that users establish a Telnet, raw TCP, or Rlogin session with a device
immediately after login, bypassing the terminal server interface altogether. For
information about immediate mode, see the Network Configuration Guide for your MAX.

To restrict Telnet, raw TCP, and Rlogin access to the terminal server, proceed as follows:

1 Open the Ethernet > Mod Config > TServ Options menu.

2 Set the Host #n Addr and Host #n Text parameters to specify the hosts to which users can
establish Telnet, raw TCP or Rlogin sessions.

These parameters specify the IP addresses and descriptions of the first, second, third, and
fourth hosts to which an operator can Telnet. The user sees a list of hosts only if he or she
has access to the menu-driven interface. For details of granting such access, see
“Restricting Telnet, raw TCP, and Rlogin access to the terminal server” on page 3-28.
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For example, you might specify the following settings:

Host #1 Addr=10.2.3.1/24

Host #1 Text=host1.abc.com

Host #2 Addr=10.2.3.2/24

Host #2 Text=host2.abc.com

Host #3 Addr=10.2.3.3/24

Host #3 Text=host3.abc.com

Host #4 Addr=10.2.3.4/24

Host #4 Text=host4.abc.com

The MAX ignores the Host #n Addr parameter if a RADIUS server supplies the list of
Telnet hosts, that is, if you set Remote Conf=Yes. For information about setting up a list of
hosts in RADIUS, see the TAOS RADIUS Guide and Reference.

3 Save your changes.

Setting up Combinet authentication
The MAX supports Combinet bridging to link two LANs as though they were one segment.
Figure 3-3 shows a Combinet connection between two networks.

Figure 3-3. A Combinet connection

Combinet bridging uses a physical Media Access Control (MAC) address and a password to
authenticate calls. For information about how MAX authentication works, see “How does user
authentication work?” on page 3-3.

Table 3-12 lists the Combinet authentication parameters with sample values.

Table 3-12. Combinet authentication parameters

Location Parameters with sample values

System > Sys Config Name=mygw

Ethernet > Answer Profile Reqd=Yes

Ethernet > Answer > PPP Options Bridge=Yes

Ethernet > Answer > Encaps COMB=Yes

Ethernet > Answer > COMB Options Password Reqd=Yes
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This section describes how to set up authentication for Combinet calls in the MAX
configuration interface. For complete information about setting up Combinet calls on the
MAX, see the Network Configuration Guide for your MAX. For information about setting up
Combinet calls and Combinet authentication in RADIUS, see the TAOS RADIUS Guide and
Reference.

Understanding Combinet authentication

To configure incoming connections that support Combinet authentication, you must perform
the following tasks:

• Set systemwide System, Answer, and Ethernet profile parameters specifying the name of
the MAX, the type of encapsulation allowed, and whether a password is required.

• Set up a Connection profile or a RADIUS user profile containing settings for each
individual connection.

Note: You only need to set up one of these profiles.

When the MAX receives a Combinet call, it checks whether COMB encapsulation is enabled
in the Answer profile and, if so, whether a Combinet password is required. It then looks for a
Connection profile that matches the caller’s MAC address (and, if appropriate, the caller’s
password). If it finds a match, it accepts the call.

If it cannot find a matching Connection profile, the MAX looks for a RADIUS user profile, a
TACACS profile, or a TACACS+ profile.

Setting systemwide parameters

To set systemwide parameters for authenticating a Combinet connection, follow these steps:

1 Set the Name parameter in the System > Sys Config menu to specify the name of the
MAX.

2 Open the Ethernet > Answer menu.

3 To disable Guest access via Combinet, set Profile Reqd=Yes.

Ethernet > Mod Config Bridging=Yes

Ethernet > Connections > any Connection profile Station=000145CFCF01
Encaps=COMB
Bridge=Yes
MAX Call Duration=0

Ethernet > Connections > any Connection
profile > Telco Options

Dialout OK=Yes

Ethernet > Connections > any Connection
profile > Encaps Options

Recv PW=office-pw
Send PW=office-pwd
Password Reqd=Yes

Table 3-12. Combinet authentication parameters (continued)

Location Parameters with sample values
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Note that Combinet does not support PAP, CHAP, or MS-CHAP authentication.

4 In the Ethernet > Answer > PPP Options menu, set Bridge=Yes.

5 In the Ethernet > Answer > Encaps menu, set COMB=Yes.

6 To require a password in addition to a MAC address, set Password Reqd=Yes in the
Ethernet > Answer > COMB Options menu.

When Password Reqd=Yes, the MAX compares the caller’s MAC address to each of these
values until it finds a match:

– Station parameter in a Connection profile

– User-Name attribute in a RADIUS user profile

The MAX also compares the value of the caller’s password to one of these values:

– Recv PW in a Connection profile

– Password attribute in a RADIUS user profile

When Password Reqd=No, the MAX uses the caller’s MAC address only.

7 Set Bridging=Yes in the Ethernet > Mod Config menu.

8 Save your changes.

Setting Connection profile parameters

Note: If you set up a Connection profile, you do not need to set up a Names/Passwords
profile or a RADIUS user profile.

To set Connection profile parameters for authenticating a Combinet connection, follow these
steps:

1 Open the Ethernet > Connections menu.

2 Open the Connection profile.

3 Set the Station parameter to the MAC address of the device making the call.

4 Set Encaps=COMB.

5 Set Bridge=Yes.

6 To limit the duration of calls that use this Connection profile, specify a value for the MAX
Call Duration parameter.

You can specify from 1 to 1440 minutes. The connection is checked once per minute, so
the actual time of the call is slightly longer (usually less than a minute longer) than the
actual time you set.

The default is MAX Call Duration=0. With this setting, incoming calls are not timed.
They can be of unlimited duration.

To specify a maximum duration for calls that use the Answer profile for authentication, you
must set the MAX Call Duration value in the Answer profile.

7 Open the Encaps Options submenu of the Connection profile.

8 If Password Reqd=Yes in the Ethernet > Answer menu, set the Recv PW parameter in the
Connection profile to specify the password that the remote end of the link must send.

If the password specified by Recv PW does not match the remote end’s value for Send PW
(in a Connection profile), Ascend-Send-Passwd (in a RADIUS user profile),
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Ascend-Send-Secret (in a RADIUS user profile), or its equivalent the MAX disconnects
the link.

9 For outgoing calls, set the Password Reqd and Send PW parameters.

– To require the MAX to send a password for outgoing connections, set Password
Reqd=Yes.

– Set the Send PW parameter to specify the password that the MAX sends to the remote
end of a connection on outgoing calls.

If the password specified by Send PW does not match the remote end’s value for Recv PW
(in a Connection profile), Ascend-Receive-Secret (in a RADIUS user profile), or its
equivalent the remote end disconnects the link.

10 Close the Encaps Options submenu.

11 To grant access to the Immediate Modem feature, open the Telco options submenu of the
Connections profile and set Dialout OK=Yes.

For more information about restricting the Immediate Modem feature, see “Restricting
access to the Immediate Modem feature” on page 6-7.

12 Save your changes.

Setting up a RADIUS user profile

If you set up a RADIUS user profile, you do not need to set up a Connection profile for
Combinet. For information about setting RADIUS attributes for Combinet authentication, see
the TAOS RADIUS Guide and Reference.

Setting up ARA authentication
The MAX includes a minimal AppleTalk stack for AppleTalk Remote Access (ARA) support.
The minimal stack includes a Name Binding Protocol (NBP) network visible entity and an
AppleTalk Echo Protocol (AEP) echo responder. You can therefore use standard AppleTalk
management and diagnostic tools, such as InterPoll from Apple Computer, to obtain
information.

For a pure AppleTalk connection, a Macintosh user must have ARA Client software and an
asynchronous modem. For a TCP/IP connection through ARA, the Macintosh must also be
running TCP/IP software, such as MacTCP or Open Transport.

ARA is an asynchronous protocol. It supports V.34, V.42, and V.120 calls only. It does not
support V.110 calls or synchronous connections.

For more information about how authentication works on the MAX, see “How does user
authentication work?” on page 3-3.

This section describes how to set up ARA authentication in the MAX configuration interface.
Figure 3-4 shows a Macintosh with an internal modem dialing into the MAX. The Macintosh
uses the ARA Client software to communicate with an IP host on the Ethernet.
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Figure 3-4. An ARA connection

Table 3-13 shows ARA authentication parameters on the MAX. The values shown are
examples.

For complete information about setting up ARA calls on the MAX, see the TAOS RADIUS
Guide and Reference. For complete information on setting up ARA calls and authentication in
RADIUS, see the TAOS RADIUS Guide and Reference.

Understanding ARA authentication

To configure incoming connections that support ARA authentication, you must perform the
following tasks:

• Set systemwide System, Answer, and Ethernet profile parameters specifying the name of
the MAX, the type of encapsulation allowed, the type of authentication in use, and the
contents of one or more IP address pools.

Table 3-13. ARA authentication parameters

Location Parameters with sample values

System > Sys Config Name=mygw

Ethernet > Answer Profile Reqd=Yes

Ethernet > Answer > Encaps ARA=Yes

Ethernet > Mod Config Appletalk=Yes

Ethernet > Mod Config > AppleTalk Zone Name=Berkeley

Ethernet > Mod Config > WAN Options Pool#1 Start=10.0.0.20
Pool#1 Count=90
Pool Only=Yes

Ethernet > Connections > any Connection profile Station=Ted
Encaps=ARA

Ethernet > Connections > any Connection
profile > Encaps Options

Password=office-pw

Ethernet > Names/Passwords > any
Names/Passwords profile

Name=Ted
Recv PW=office-pw
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• Set up a Connection profile, or a Names/Passwords profile, or a RADIUS user profile, a
TACACS profile, or a TACACS+ profile containing settings for each individual
connection.

When the MAX receives an ARA call, it checks whether ARA encapsulation is enabled in the
Answer profile and, if so, whether a profile is required. It then looks for a Connection profile
that matches the caller’s name and password. If it finds a match, it accepts the call.

If the MAX cannot find a matching Connection profile, it looks for a Names/Passwords
profile. If it cannot find a matching Names/Passwords profile, the MAX looks for a RADIUS
user profile, TACACS profile, or TACACS+ profile.

Setting systemwide parameters

To set systemwide parameters for ARA authentication, proceed as follows:

1 In the System > Sys Config menu, set the Name parameter to the name of the MAX.

2 To disable Guest access via ARA, set Profile Reqd=Yes in the Ethernet > Answer menu.

Note that ARA does not support PAP, CHAP, or MS-CHAP authentication.

3 Enable ARA encapsulation by setting ARA=Yes in the Ethernet > Answer > Encaps
menu.

4 Set Appletalk=Yes in the Ethernet > Mod Config menu.

5 If the local Ethernet supports an AppleTalk router with configured zones, set the Zone
Name parameter in the Ethernet > Mod Config > AppleTalk menu.

6 If you are using a Names/Passwords profile for an IP routing connection, open the
Ethernet > Mod Config > WAN Options menu to begin setting up one or more IP address
pools.

Unlike Connection profiles and RADIUS user profiles, Names/Passwords profiles cannot
specify an IP address for the calling station. When you use a Names/Passwords profile to
authenticate an IP routing connection, the MAX automatically assigns the PPP caller a
dynamic IP address as the connection is established. For a call configured in a
Names/Passwords profile, the address assignment is always from the pool of addresses
defined as Pool #1, if Pool #1 exists and has available addresses. If Pool #1 does not exist
or does not have available addresses, the MAX assigns an address from Pool #2.

7 Designate address pools by setting the Pool #n Count and Pool #n Start parameters.

The Pool #n Count parameter specifies the number of IP addresses in the IP address pool.
Specify a number between 0 and 254. The default value is 0 (zero).

The Pool #n Start parameter specifies the first IP address in the address pool. Specify an IP
address in dotted decimal notation. The default value is 0.0.0.0.

You can also designate address pools by setting the Ascend-IP-Pool-Definition attribute.
For details, see the TAOS RADIUS Guide and Reference.

8 Set Pool Only=Yes.

The Pool Only parameter determines whether a caller can reject an IP address assignment
and use his or her own IP address. To eliminate the possibility of a caller rejecting the
automatic dynamic assignment and spoofing a local, trusted address, set Pool Only=Yes
when using Names/Passwords profiles to authenticate IP routing connections.

For a call configured in a Names/Passwords profile, the address assignment is always
from the pool of addresses defined as Pool #1, if Pool #1 exists and has available
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addresses. If Pool #1 does not exist or does not have available addresses, the MAX assigns
an address from Pool #2.

If the calling station rejects the assignment, the MAX ends the call.

9 Save your changes.

Setting Connection profile parameters

Note: If you set up a Connection profile, you do not need to set up a Names/Passwords
profile or a RADIUS user profile.

To set Connection profile parameters for ARA authentication, proceed as follows:

1 Open the Ethernet > Connections menu.

2 Open the Connection profile.

3 Set the Station parameter to the name of the remote device.

4 Set Encaps=ARA.

5 Open the Encaps Options submenu of the Connection profile.

6 Set the Password parameter to specify the ARA password.

7 Save your changes.

Setting Names/Passwords profile parameters

The Names/Passwords profile applies only to ARA and PPP-encapsulated calls. It does not
apply to terminal server users.

Note: If you set up a Names/Passwords profile, you do not need to set up a Connection
profile or a RADIUS user profile.

To set Names/Passwords profile parameters for ARA authentication, proceed as follows:

1 Open the Ethernet menu.

2 Open the Names/Passwords menu.

3 Open a Names/Passwords profile.

4 Set the Name parameter to specify the name of the remote device.

In a Names/Passwords profile, the Name parameter specifies the username associated with
the profile. The name you specify also becomes the name of the profile.

5 Set the Recv PW parameter to specify the password that the remote end of the link must
send.

If the password specified by Recv PW does not match the remote end’s value for Send PW
(in a Connection profile), Ascend-Send-Passwd (in a RADIUS user profile), or
Ascend-Send-Secret (in a RADIUS user profile), the MAX disconnects the link.

6 Set the value for Template Connection #:

– Use the default, Template Connection#=0 (the Answer profile), to specify that the
Name/Names/Passwords profile uses the Answer Profile as a template.

This mode supports clients dialing in over PPP and ARA, but does not support a
router dialing in.
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– Specify a Connection Profile profile by setting the parameter to a profile number
between 1 and 31.

In this mode the Names/Passwords profile functions as an alias for the Connection Profile.

7 Save your changes.

When a user calls the MAX and Recv Auth has been set to a value other than None in the
Answer profile, the MAX asks for a username and password. If the user enters the username
specified by the Name parameter in the Names/Passwords profile and the password specified
by the Recv PW parameter in the Names/Passwords profile, the MAX uses the Answer profile
parameters to establish the connection.

Preventing dial-in calls with the Name/Password profile

The Answer profile is the default template for a Name/Password profile, but you can specify
the use of a Connection profile as a template for the Name/Password profile. You can specify a
single Connection profile for a group of users, but have an individual Name/Password profile
for each user by setting Template Connection # to a number that refers to a Connection profile.
The MAX uses that Connection profile for authentication.

For example, you can set up a Connection profile for the Sales group to use when dialing in,
then set up a Names/Passwords profile for each individual salesperson. To prevent a user from
dialing in using one of the two following methods:

• De-activate the Names/Passwords profile for a single salesperson, to prevent that
salesperson from dialing in, by setting the Names/Passwords Active flag for the user’s
Names/Passwords profile to No.

• De-activate the entire Sales group by setting the Connection profile Active flag for the
Sales group to No.

Using a RADIUS user profile

If you set up a RADIUS user profile, you do not need to set up a Connection profile or a
Names/Passwords profile. For information about setting RADIUS attributes for ARA
authentication, see the TAOS RADIUS Guide and Reference.

Using a SecurID server with AppleTalk Remote Access (ARA)

A SecurID server can authenticate ARA callers by using the following profiles:

• Connection profile (described in “Setting Connection profile parameters” on page 3-30)

• Password profile (described in “Setting Names/Passwords profile parameters” on
page 3-34)

• RADIUS user profile

Authentication using RADIUS and a SecurID server

For authentication with RADIUS and a SecurID server, set Auth=RADIUS/LOGOUT in the
Ethernet>Mod Config menu.

The SecurID client module must be version 1.3 or later.
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Once the user makes the initial connection, SecurID authentication begins with a pop-up
screen on the Macintosh. At this point, the user must enter the User ID and Passcode. When
Auth=LOGOUT/RADIUS, the username must be SecurID, and no password should be
entered. If the user enters incorrect values, he or she gets two more tries to authenticate before
the connection fails.

If the user is required to enter a new PIN, a pop-up screen prompts for this information. The
user has three chances to enter the correct PIN. Once the new PIN is accepted, a pop-up screen
instructs the Macintosh user to first wait for the token code to change, then log in with the new
PIN and token code.

Setting up X.25 authentication
X.25 is an international standard protocol established by the Consultative Committee on
International Telephony and Telegraphy (CCITT) to transmit information between users over a
WAN. It handles both high-volume data transfers and interactive use of host machines.

X.25 terminals can connect to the MAX in an X.25/PAD or X.25/IP session. The MAX unit’s
X.25/PAD implementation allows users to access a packet-switched network over a leased line
or a nailed-up ISDN connection.

A Packet Assembler/Disassembler (PAD) is an asynchronous terminal concentrator that
enables several asynchronous devices to share a single network line. The PAD assembles data
from terminals into packets for transmission to an X.25 network, and disassembles incoming
packets from the network into a separate data stream for each terminal. In addition to this
multiplexing function, the PAD also provides a nearly error-free connection.

The MAX unit’s X.25/IP implementation supports the use of IP routing over an X.25 link. It
does not support bridging or other routing protocols. Lucent’s implementation of IP over X.25
follows the specification for IETF RFC1356 encapsulation. This implementation connects two
or more IP networks linked to a public or private packet-switched network (PSPDN).

Table 3-14 lists the parameters for X.25 authentication. The values shown are examples.

.

Table 3-14. X.25 authentication parameters

Location Parameters with sample values

Ethernet > Answer Profile Reqd=Yes

Ethernet > Answer > Encaps X25/PAD=Yes
X25/IP=Yes

Ethernet > Answer > PPP Options Recv Auth=Either

Ethernet > Mod Config/TServ Options Immed Service=X25/PAD
Immed Host=311021755555

Ethernet > Connections > any Connection
profile

Station=dialmax
Encaps=X25/PAD or X25/IP
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This section describes how to set up X.25 authentication in the MAX configuration interface.
For complete information about setting up X.25 connections on the MAX, see the Network
Configuration Guide for your MAX. For complete information about setting up X.25 calls and
authentication in RADIUS, see the TAOS RADIUS Guide and Reference.

To set up X.25 authentication, proceed as follows:

1 Open the Ethernet > Answer menu.

2 Set Profile Reqd=Yes.

3 Open the Ethernet > Answer > Encaps menu.

4 Set X25/PAD=Yes and X25/IP=Yes.

5 Open the Ethernet > Answer > PPP Options menu.

6 For an X.25/IP user, set Recv Auth=Either.

7 Open the Ethernet > Mod Config > TServ Options menu.

8 If you want terminal-server users to begin an X.25/PAD session immediately, upon
authentication:

– Set Immed Service=X.25/PAD.

– Set the Immed Host parameter to the X.121 address of the remote device.

Terminal server users must pass authentication according to the terminal-server
parameters you set. For instructions, see “Setting up authentication for dial-in terminal
server users” on page 3-23.

9 Open the Ethernet > Connections menu.

10 Open the X.25 user’s Connection profile.

11 For an X.25/PAD connection, set Encaps=X.25/PAD. For an X.25/IP connection, set
Encaps=X.25/IP.

12 For an X.25/IP connection, set the Station name parameter to the name of the remote
device.

13 Open the Encaps Options submenu of the Connection profile.

14 For an X.25/PAD or an X.25/IP connection, set the Recv PW parameter to the password
the remote user must enter.

15 Save your changes.

Setting up IP addressing
If password authentication is required, the MAX attempts to match each incoming call with a
caller’s name and password in a local Connection profile, or in a RADIUS user profile. If
password authentication is not required for an IP-routed PPP call, the MAX need only match
the call with an IP address specified in a Connection profile or in a RADIUS user profile. The

Ethernet > Connections > any Connection
profile > Encaps Options

Recv PW=office-pw

Table 3-14. X.25 authentication parameters (continued)

Location Parameters with sample values
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IP address in the Connection profile or user profile can be specified either statically or
dynamically. However, an address cannot be assigned dynamically to a profile that has been
assigned a static address.

• Static address

A static address is specified by the LAN Adrs parameter in the Connection profile or by
the Framed-Address attribute in the RADIUS user profile.

• Dynamic address

A dynamic address comes from the pool of addresses set by the Pool #n Start and Pool #n
Count parameters or by the Ascend-IP-Pool-Definition attribute.

If the calling end accepts the IP address, the MAX sets the LAN Adrs parameter or
Framed-Address attribute to the assigned address, depending on whether a Connection
profile or RADIUS user profile is in use. If a static address is already set in a Connection
profile or RADIUS user profile, it overrides any IP address from an IP address pool.

The MAX verifies the IP address as part of the PPP negotiation before a call is established.
Establishment of a connection involves one of the following sequences of events:

• If the caller’s PPP software presents an IP address and the MAX does not require dynamic
IP address assignment, the MAX must find a Connection profile or RADIUS user profile
that matches that address. If it finds a profile, the MAX establishes the connection if the
call passes PAP, CHAP, or MS-CHAP authentication. If the MAX does not find a
matching profile, it ends the call without attempting PAP, CHAP, or MS-CHAP
authentication.

• If the caller’s PPP software specifies dynamic IP address assignment, the MAX must
obtain an available IP address from pools defined in the Ethernet profile or in RADIUS. If
the MAX successfully assigns an address, it establishes the connection if the call passes
PAP, CHAP, or MS-CHAP authentication. If no addresses are available, the MAX ends the
call.

• If the caller’s PPP software presents an IP address and the MAX requires dynamic IP
address assignment, the calling station must accept the IP address. If it does, the MAX
establishes the connection if the call passes PAP, CHAP, or MS-CHAP authentication. If
the calling station does not accept the IP address assignment, the MAX ends the call
without attempting PAP, CHAP, or MS-CHAP authentication.

For more information about how authentication works on the MAX, see “How does user
authentication work?” on page 3-3.

Table 3-15 lists the parameters you can set for IP addressing. The values shown are examples.

Table 3-15. IP address parameters

Location Parameters with sample values

Ethernet > Answer Assign Adrs=Yes

Ethernet > Answer > PPP Options Route IP=Yes

Ethernet > Connections > any Connection profile > IP
Options

LAN Adrs=10.5.6.7/24
(or)
Pool=2
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You can set additional parameters in Name/Password profile.

See the Network Configuration Guide for your MAX for related information on setting up IP
routing connections in the MAX configuration interface. See the TAOS RADIUS Guide and
Reference for related information on setting up IP routing connections in RADIUS.

Specifying a static IP address

To set up a static IP address that must match a caller’s IP address, proceed as follows:

1 Open the Ethernet > Answer > PPP Options menu.

2 Set Route IP=Yes.

3 Open the Ethernet > Connections menu.

4 Open the Connection profile for the caller.

5 Open the IP Options submenu of the Connection profile.

6 To specify a static address, set the LAN Adrs parameter.

7 Save your changes.

Assigning a dynamic IP address to a caller requesting one

To configure the MAX to assign an IP address to a caller that requests one, follow these steps

1 Open the Ethernet > Answer menu.

2 Set Assign Adrs=Yes.

When you specify this setting, the MAX asks the device to accept an address chosen from
the pool of addresses specified by the Pool #n Start and Pool #n Count parameters or by
the Ascend-IP-Pool-Definition attribute. If the calling end accepts the IP address, the
MAX sets the LAN Adrs parameter in the Connection profile to the assigned address.

Note: In some TCP/IP implementations, when the workstation needs the MAX to set the
IP address, you must set the workstation’s address to 0.0.0.0. Setting the address to any
other value tells the workstation to use that value and notify the MAX.

3 Open the Ethernet > Answer > PPP Options menu.

4 Set Route IP=Yes.

5 Open the Ethernet > Mod Config > WAN Options menu.

6 Specify up address pools by setting the Pool #n Count and Pool #n Start parameters.

The Pool #n Count parameter specifies the number of IP addresses in the IP address pool.
Assign a number between 0 and 254. The default value is 0 (zero).

The Pool #n Start parameter specifies the first IP address in the address pool. Assign an IP
address in dotted decimal notation. The default value is 0.0.0.0.

Ethernet > Mod Config > WAN Options Pool #n Count=10
Pool #n Start=0.0.0.0
Pool Only=Yes

Table 3-15. IP address parameters (continued)

Location Parameters with sample values
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You can also specify address pools by setting the Ascend-IP-Pool-Definition attribute in
RADIUS. For details, see the TAOS RADIUS Guide and Reference.

7 Open the Ethernet > Connections menu.

8 Open a Connection profile.

9 In the Connection profile, set the Pool parameter to the number of the pool to use for the
call.

10 Save your changes.

Requiring that a caller accept an IP address from the MAX

To require that a caller accept an IP address from the MAX, proceed as follows:

1 Open the Ethernet > Answer menu.

2 Set Assign Adrs=Yes.

When you specify this setting, the MAX asks the device to accept an chosen address
specified from the pool of addresses by the Pool #n Start and Pool #n Count parameters or
by the Ascend-IP-Pool-Definition attribute. If the calling end accepts the IP address, the
MAX sets the LAN Adrs parameter in the Connection profile to the assigned address.

3 Open the Ethernet > Answer > PPP Options menu.

4 Set Route IP=Yes.

5 Open the Ethernet > Mod Config > WAN Options menu.

6 If the assigned address is to be chosen dynamically, specify address pools by setting the
Pool #n Count and Pool #n Start parameters.

The Pool #n Count parameter specifies the number of IP addresses in the IP address pool.
Specify a number between 0 and 254. The default value is 0 (zero).

The Pool #n Start parameter specifies the first IP address in the address pool. Assign an IP
address in dotted decimal notation. The default value is 0.0.0.0.

You can also set up address pools by setting the Ascend-IP-Pool-Definition attribute in
RADIUS. For details, see the TAOS RADIUS Guide and Reference.

7 To require a calling station to accept an IP address from the MAX, set Pool Only=Yes.

This setting requires the calling station to accept the static address specified in a
Connection profile or RADIUS user profile, or a dynamic address. If the calling station
rejects the assignment, the MAX ends the call.

If you set Pool Only=No, the MAX accepts the IP address specified by the caller.

8 Open the Ethernet > Connections menu.

9 Open a Connection profile.

10 In the Connection profile, set the LAN Adrs parameter to specify a static address, or set
the Pool parameter to the number of the pool to use for assigning a dynamic IP address.

11 Save your changes.

Using Names/Passwords profiles to prevent IP address spoofing

IP address spoofing is a technique in which outside users pretend to be on the local network in
order to obtain unauthorized access.
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Unlike Connection profiles and RADIUS user profiles, Names/Passwords profiles cannot
specify an IP address for the calling station. When you use a Names/Passwords profile to
authenticate an IP routing connection, the MAX automatically assigns the PPP caller a
dynamic IP address as the connection is established, ensuring that the user is not spoofing the
address. Table 3-16 shows the relevant parameters on the MAX.

Note: You also can set up data filters to prevent IP address spoofing. For details, see “A
sample IP filter to prevent address spoofing” on page 4-12.

To set parameters to prevent IP spoofing, proceed as follows:

1 Open the Ethernet menu.

2 Open the Names/Passwords menu.

3 Open a Names/Passwords profile.

4 Set the Name parameter to the name of the user or device making the incoming call.

In a Names/Passwords profile, the Name parameter specifies the username associated with
the profile. The name you specify also becomes the name of the profile.

5 Set the Recv PW parameter to specify the password that the remote end of the link must
send.

If the password specified by Recv PW does not match the remote end’s value for Send
PW, the MAX disconnects the link.

6 Open the Ethernet > Mod Config > WAN Options menu.

7 Specify address pools by setting the Pool #n Count and Pool #n Start parameters.

The Pool #n Count parameter specifies the number of IP addresses in the IP address pool.
Assign a number between 0 and 254. The default value is 0 (zero).

The Pool #n Start parameter specifies the first IP address in the address pool. Specify an IP
address in dotted decimal notation. The default value is 0.0.0.0.

You can also specify up address pools by setting the Ascend-IP-Pool-Definition attribute.
For details, see the TAOS RADIUS Guide and Reference.

8 Set Pool Only=Yes.

The Pool Only parameter determines whether a caller can reject an IP address assignment
and use his or her own IP address. To eliminate the possibility of a caller rejecting the
automatic dynamic assignment and spoofing a local, trusted address, set Pool Only=Yes.

For a call configured in a Names/Passwords profile, the address assignment is always
from the pool of addresses defined as Pool #1, if Pool #1 exists and has available
addresses. If Pool #1 does not exist or does not have available addresses, the MAX assigns
an address from Pool #2.

Table 3-16. Names/Passwords profile address restriction parameters

Location Parameters with sample values

Ethernet > Mod Config > WAN Options Pool#1 Start=10.0.0.20
Pool#1 Count=90
Pool Only=Yes

Ethernet > Names/Passwords > Any
Names/Passwords profile

Name=Ted
Recv PW=office-pw
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If the calling station rejects the assignment, the MAX ends the call.

9 Save your changes.

Setting up an authentication server
The MAX supports resident Connection profiles and Names/Passwords profiles for
authenticating incoming connections, but the amount of RAM in the unit limits the total
number of supported profiles. Many ISPs and other large sites use a third-party authentication
server to centrally control, manage, and audit security.

Understanding authentication servers

When the MAX receives an incoming call, it first looks through its resident profiles
(Connection and Names/Passwords profiles). If it does not find a matching profile, it checks its
Ethernet profile for an authentication server’s address. If it finds one, it accesses the
authentication database in that server to search for a matching profile. The MAX supports the
following types of authentication servers:

Authentication
server

Description

RADIUS Remote Authentication Dial-In User Service (RADIUS) is a protocol
originally developed by Livingston Enterprises, and extended by
Lucent Technologies The Lucent extensions let you configure most of
the features supported by the resident profiles. The information resides
in a database on a PC or UNIX system. The RADIUS daemon on that
system accesses the data.

For complete information about installing and configuring a RADIUS
server, and about setting up the MAX to operate with a RADIUS
server, see the TAOS RADIUS Guide and Reference.

TACACS Terminal Access Concentrator Access Control Server (TACACS) is a
simple query/response protocol that enables the MAX to check a
user’s password and enable or prevent access. TACACS supports
Password Authentication Protocol (PAP), Combinet name and
password validation, and terminal server validation. It does not
support CHAP authentication.

For details about setting up a TACACS server, see the documentation
that came with your TACACS software. For information about setting
up the MAX to operate with a TACACS server, see “Configuring the
MAX to use a TACACS or TACACS+ server” on page 3-43.

TACACS+ TACACS+ is an extension of TACACS. For information about setting
up the MAX to operate with a TACACS+ server, see “Configuring the
MAX to use a TACACS or TACACS+ server” on page 3-43.

AssureNet
Defender

The MAX supports terminal-server authentication through the
Defender server. If the MAX is configured to use Defender
authentication, the service provided to authenticated users depends on
the parameters of the TServ Options submenu in the Ethernet profile.
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Configuring the MAX to use a TACACS or TACACS+ server

To configure the MAX to communicate with a TACACS or TACACS+ server, proceed as
follows, as in the following example:

1 Open the Ethernet > Mod Config > Auth menu.

X0-X00 Mod Config

Auth...
>Auth=TACACS
Auth Host #1=10.23.45.11
Auth Host #2=10.23.45.12
Auth Host #3=10.23.45.13
Auth Port=1645
Auth Timeout=5
Auth Key=N/A
Auth Pool=N/A
Auth Req=Yes
Local Profile First=Yes
APP Server=No
APP Host=N/A
APP Port=N/A
CLID Timeout Busy=No
CLID Fail Busy=No
SecurID DES encryption=N/A
SecurID host retries=N/A
SecurID NodeSecret=N/A

2 Set Auth=TACACS or TACACS+.

3 Set each Auth Host parameter, to specify the IP address of a TACACS or TACACS+ host.

You can specify up to three addresses. The MAX first tries to connect to Auth Host #1. If
it receives no response within the time specified by the Auth Timeout parameter, it tries
again to connect to Auth Host #1 and waits for the same amount of time. If the MAX does
not receive a response within the specified timeout, it sends a request for authentication to
Auth Host #2. If it again receives no response within the time specified by Auth Timeout,
it tries to connect to the next server on the Auth Host List and repeats the process. If the
MAX unit’s request again times out, it reinitiates the process with Auth Host #1. The
MAX can complete this cycle of requests a maximum of ten times. If the MAX is
unsuccessful in obtaining a response from any of the servers on the list, the connection
fails.

ACE The MAX can authenticate terminal server users by directly contacting
an ACE server, developed by Security Dynamics. Although SecurID
ACE authentication is also indirectly supported through RADIUS,
direct support for the SecurID ACE server can provide a significant
advantage. For those installations in which other RADIUS features are
not required, SecurID ACE support on the MAX decreases the
complexity of the system, making the system easier to configure and
maintain.

Authentication
server

Description
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When it successfully connects to an authentication server, the MAX uses that machine
until it fails to serve requests. The MAX does not use the first host until the second
machine fails, even if the first host has come back online.

You can specify the same address for all three Auth Host parameters. If you do so, the
MAX keeps trying to create a connection to the same server.

4 For the Auth Port parameter, enter the UDP port number used by the TACACS or
TACACS+ software. For example:

Auth Port=1645

The MAX and the TACACS or TACACS+ software must agree about which UDP port to
use for communication, so make sure that the number you specify for the Auth Port
parameter matches the number specified in the TACACS or TACACS+ configuration file.

5 Set the Auth Timeout parameter to specify the number of seconds the MAX waits for a
response to an authentication request.

If the MAX does not receive a response within the time specified by Auth Timeout, it
sends the authentication request to the next authentication server specified by the Auth
Host parameter.

6 Specify whether to use remote authentication before local. The default is Yes.

If you enter No, the MAX tries remote authentication and the MAX waits for
authentication to succeed or for the timeout specified in Auth Timeout to expire. This can
take longer than the timeout specified for the connection. If the connection times out, all
connection attempts to fail.

To prevent this set the value for Auth Timeout low enough not to cause the line to be
dropped, but still high enough to permit the unit to respond if it is able to. The
recommended time is 3 seconds.

Some authentication methods do not work the same without a remote authenticator as they
do with one. Table 3-17 shows authentication methods and the specific information you
should consider if you use a particular method with Local Profile First=No.

Table 3-17. Remote authentication considerations

Method Remote Authentication Considerations

PAP None. Works the same with or without remote
authentication.

CHAP None. Works the same with or without remote
authentication.

PAP-TOKEN Works either way, but does not produce a challenge if there is
a local profile. This defeats the security of using
PAP-TOKEN.

PAP-TOKEN-CHAP Brings up one channel, but all other channels fail.

CACHE-TOKEN If the remote side has ever authenticated itself by responding
to a challenge, CACHE-TOKEN does not work with local
profiles. If the remote side has never been authenticated, the
local profiles cause no problems.
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7 Enter the port number for the source port for remote authentication requests.

Type a port number between 0 and 65535. The default value is 0 (zero). If you accept this
value, the MAX can use any port number between 1024 and 2000.

You can specify the same port for authentication and accounting requests.

8 Save your changes.

Vendor-Specific Attribute (VSA) support

RFC 2138, Remote Authentication Dial In User Service (RADIUS), specifies methods of
handling vendor extensions and of encrypting and decrypting the User-Password. The
RFC-defined methods differ from the way Lucent has implemented these functions in the past.
In the past, Lucent extended RADIUS operations by adding Lucent vendor attributes, such as
Ascend-Xmit-Rate, and used its own Lucent algorithm for User-Password encryption.

The MAX supports RADIUS RFC-compliance for the Vendor-Specific Attribute (VSA) and
the RFC-defined User-Password encryption algorithm. Lucent maintains backward
compatibility by making VSA compatibility mode configurable. However, attributes of Type
91 or smaller are supported only in VSA compatibility mode. Attributes of Type 92 or higher
are supported in both VSA compatibility mode and the default mode, which is compatible with
older Lucent implementations.

About the Vendor-Specific attribute

RFC 2138 defines the Vendor-Specific attribute (type 26), which encapsulates attributes
introduced by vendors. The purpose of the Vendor-Specific attribute is to enable companies to
extend RADIUS operations without leading to possible attribute collisions (two attributes with
the same type number but different meanings).

The format of Lucent vendor attributes in a request or response is new. The older Lucent
format for all attributes is as follows:

0 1 2
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
| Type | Length | Value ...
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-

The format of the VSA (as defined in RFC 2138) is as follows:

0 1 2 3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Type | Length | Vendor-Id
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Vendor-Id (cont) | Vendor type | Vendor length |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Attribute-Specific...
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-

The Type of the VSA is 26. The Length is 8 or greater. Lucent's Vendor-Id is 529.

The Vendor Type, Vendor Length, and Attribute-Specific Value are the same as the Type,
Length, and Value of the unencapsulated Lucent attribute found in the current dictionary. For
example, the Type of the Ascend-Xmit-Rate attribute is 255. Because it is an integer, it has a
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Length of 6. The Value is the transmit rate of the connection. So, the fields of the VSA will
specify the following values:

• Type = 26

• Length = 12

• Vendor-Id = 529

• Vendor Type = 255

• Vendor Length = 6

• Attribute-Specific Value = transmit-rate

Note: Some vendors have interpreted RFC 2138 to allow packing more than one vendor
attribute in a single VSA. Lucent does not support this use. The MAX sends a single vendor
attribute per VSA. If it receives a VSA that contains more than one vendor attribute, it
recognizes the first vendor attribute and ignores the rest.

Configuring the MAX for VSA compatibility mode

When you configure the MAX to support VSA, the MAX uses the Vendor-Specific attribute to

encapsulate Lucent vendor attributes and uses the RFC-defined User-Password encryption

algorithm.

When you configure the MAX not to support VSA, which is the default setting, the MAX does

not send the Vendor-Specific attribute to the RADIUS server and does not recognize it if the

server sends it. The MAX uses the Lucent algorithm when encrypting and decrypting the

User-Password attribute, and the Lucent algorithm differs from the RFC-defined algorithm,

because it does not null fill the password string to a multiple of 16 bytes before encryption, and

the Lucent algorithm does not use the previous segment’s hash to calculate the next

intermediate value when the password is longer than 16 bytes.

Because you can configure four different functions for RADIUS with each function operating

independently of the others and possibly interacting with different RADIUS servers (or

clients), the MAX displays four separate VSA-related parameters for specifying whether to

operate in the older Lucent mode or in VSA-compatible mode. Following are the relevant

parameters, shown with their default settings:

Parameter Description

Ethernet > Mod Config > Auth >
Auth Compat Mode

Enables or disables VSA support when the MAX supports
RADIUS for authentication. OLD is the default which
disables VSA support.

Ethernet > Mod Config >
Accounting > Acct Compat Mode

Enables or disables VSA support when the MAX supports
RADIUS for accounting. OLD is the default which
disables VSA support.

Ethernet > Mod Config >
RADIUS Server > Compat Mode

Enables or disables VSA support when the MAX acts as a
RADIUS server that is able to accept some requests for
certain limited purposes; for example, to change filters or
disconnect a user. OLD is the default which disables VSA
support.
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For additional details, see the MAX Reference.

Ethernet > Mod Config > Call
Logging > Compat Mode

Enables or disables VSA support when the MAX supports
RADIUS for call logging to NavisAccess. OLD is the
default which disables VSA support.

Parameter Description
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4Defining Static Filters

Introduction to Lucent filters
Static filters are packet filters created by setting parameters in Ethernet > Filters menus.
A packet filter contains rules that specify what the MAX does when it encounters different
types of packets. When you specify a packet filter in a RADIUS user profile, the MAX
monitors the data stream associated with that profile and takes a specified action when packet
contents match the filter rules. Each filter specification either forwards or drops packets. You
can apply a filter to inbound packets, outbound packets, or both. In addition, you can specify
that the MAX forward or drop those packets that match the rules, or all packets except those
that match the rules.

You can set up three types of packet filters on a per-user basis:

How packet filters work

You can specify several filters in a RADIUS user profile. Filter entries apply on a first-match
basis. Therefore, the order in which you specify filter entries is significant. When you define a
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Type of filter Function

Generic filter Examines the byte- or bit-level contents of a packet. Focuses on
certain bytes or bits and compares them with a value defined in the
filter. To use generic filters effectively, you need to know the contents
of certain bytes in the packets you wish to filter. Protocol
specifications are usually the best source of such information.

IP filter Examines higher level fields specific to IP packets. Focuses on known
fields, such as source or destination address, or protocol number. An
IP filter operates on logical information that is relatively easy to
obtain.

IPX filter Examines fields specific to IPX packets. You can direct the MAX to
filter on the basis of network address, node address and socket number.
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filter in a RADIUS user profile, it applies to data the user sends or receives. If you make
changes to a filter, the changes do not take effect until a call uses that profile.

A match occurs at the first successful comparison between a filter and the packet being
examined. When a comparison succeeds, the filtering process stops and the MAX applies the
forward or drop action to the packet.

If no comparisons succeed, the packet does not match the filter. The MAX does not forward
such packets. When no filter is in use, the MAX forwards all packets. But by applying a filter
to a connection, you reverse this default. For security purposes, the MAX does not
automatically forward nonmatching packets. It requires a rule that explicitly enables such
packets to pass.

In a generic filter, all settings work together to specify a location in a packet and a number that
the MAX compares to the value in that location. In an IP filter, the MAX makes a set of
distinct comparisons in order. When a comparison fails, the packet goes on to the next
comparison. When a comparison succeeds, the filtering process stops and the MAX applies the
forward or drop action to the packet. The IP filter tests proceed in the following order:

1 Compare the source address specified by the filter to the source address of the packet. If
they are not equal, the comparison fails.

2 Compare the destination address specified by the filter to the destination address in the
packet. If they are not equal, the comparison fails.

3 If the protocol specified by the filter is zero (which matches any protocol), the comparison
succeeds. If it is non-zero and not equal to the protocol field in the packet, the comparison
fails.

4 If the source port specified by the filter does not compare to the source port of the packet
as the filter indicates, the comparison fails.

5 If the destination port specified by the filter does not compare to the destination port of the
packet as the filter indicates, the comparison fails.

6 If the filter specifies a match only if a TCP session is already established, and a TCP
session is up, the comparison succeeds.

If both a data filter (which defines packets the MAX can transmit over a connection) and a call
filter (which defines packets that can bring up a connection or reset the idle timer for an
established link) apply to an interface, the data filter is applied first.

For complete information about how filters work, see the filter configuration chapter in the
Network Configuration Guide for your MAX.

You can also set up filters on the MAX or define firewalls in SecureConnect Manager (SCM),
and then specify those filters or firewalls in a RADIUS user profile. When the connection is
made the RADIUS user profile determines which filters are used for the connection. For more
information, see the TAOS RADIUS Guide and Reference, or your SCM documentation.

Note: This chapter describes how to set up and use data filters only. For information about
how to configure call filters, see the Network Configuration Guide for your MAX. For
information about IPX SAP filters, which affect which NetWare services the MAX adds to its
service table, see the Network Configuration Guide for your MAX.
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Data filters for dropping or forwarding certain packets

A data filter defines which packets the MAX can transmit over a connection. Many sites use
data filters for security purposes, but you can apply data filters for any purpose that requires
the MAX to drop or forward only specific packets. For example, you can use data filters to
drop packets addressed to particular hosts or to prevent broadcasts from going across the
WAN. You can also use data filters to restrict user access to include only specific devices
across the WAN.

When you apply a data filter, its forward or drop action affects the actual data stream by
preventing certain packets from reaching the Ethernet from the WAN, or vice versa. In
Figure 4-1 the vertical bar represents a data filter blocking packets.

Figure 4-1. Data filters can drop or forward certain packets

Data filters do not affect the idle timer, and a data filter applied to a RADIUS user profile does
not affect the answering process.

Overview of filter profiles
Figure 4-2 shows how filters are organized and the terminology used to describe each part of a
filter.

Figure 4-2. Filter terminology

Filters menu

The Filters menu contains a list of numbered profiles. When applying a filter, you identify it by
the unique portion of its Filter profile number (for example, 1, 2, 3...). The MAX applies all
filter conditions within that profile.

Data filter

WAN

Filters menu
Filter profile Input filters

or Output
filters

Generic, IP,
or IPX filters Conditions

(rules)
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Filter profile

Each profile in the Filters menu defines a set of filters that are applied as a group. The term
filter can apply to a filter profile or to one of the individual filters defined in the profile.

Input and output filters

At the top level of a Filter profile are submenus labeled Input Filters and Output Filters. Each
submenu contains a list of 12 filters. In each of the 24 filters, you can set parameters to specify
conditions. The MAX first applies the Input Filters, in order from 1 to 12, then it applies the
Output Filters, in order from 1 to 12.

Generic, IP, or IPX filters

Each input filter or output filter can be a Generic filter, an IP filter, or an IPX filter. The type
you specify determines which parameters are included in the filter.

Filter conditions

Filter conditions specify the actual packet characteristics that the MAX examines in the data
stream. Generic filter conditions specify locations and values that can appear in any packet. IP
filter conditions specify IP-specific packet characteristics, such as address, mask, and port. IPX
filter conditions specify IPX-specific packet characteristics, such as network address, node
address, and socket number. Once you assign a type, you can open the corresponding submenu
to define the packet-level filter conditions.

Filtering inbound and outbound packets
To set up a filter, first assign it a name. Within the filter, activate each individual filter that you
want to apply and specify its type. Depending on the type you specify, define the Generic filter
conditions, IP filter conditions, or IPX filter conditions. Once you have defined each individual
(component) filter, you can apply the entire filter by specifying it in an Answer profile,
Connections profile, or Ethernet profile.

Specifying and activating an input or output filter

To begin setting up filters for inbound and outbound packets, proceed as follows:

1 Open the Filters menu.

2 Open a Filter profile.

3 For the Name parameter, specify a descriptive name for the profile. For example,

Name=IP Data

4 Open the Input Filters or Output Filters submenu.

When you select Input Filters, the following menu appears:

50-401 IP Data
Input filters...
>In filter 01
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In filter 02

In filter 03

In filter 04

In filter 05

In filter 06

In filter 07

In filter 08

In filter 09

In filter 10

In filter 11

In filter 12

You can specify up to 12 input filters and 12 output filters in a Filter profile. The MAX
applies these filters in the order in which they appear. A filter must be activated for the
MAX to apply it. Input filters cause the MAX to examine incoming packets. Output filters
cause the MAX to examine outgoing packets.

If the MAX applies the filter as a data filter on Ethernet, it affects packets from the
Ethernet into the MAX or from the MAX out to the Ethernet. If the MAX applies a data
filter on a WAN interface defined in a Connection profile, the filter affects packets from
that WAN interface into the MAX or from the MAX out to that interface.

If you define only input filters, the default action for output filters is to forward all packets.
The same is true in the other direction. If you define only output filters, the default action
for inbound packets is to forward them.

5 Select an In filter or an Out filter to configure.

When you open an In filter, a menu similar to the following appears:

50-401 IP Data

In filter 01

>Valid=Yes

Type=GENERIC

Generic...

IP...

IPX...

When you open an Out filter, the a menu similar to the following appears:

50-401 IP Data

Out filter 01

>Valid=Yes

Type=GENERIC

Generic...

IP...

IPX...

6 To activate the filter, set Valid=Yes.

To be able to apply the filter, you must activate it.

7 Define the filter type: Generic, IP, or filter.

Defining generic filter conditions

If the Type is set to Generic, you can define generic filter conditions. Table 4-1 shows the
parameters you can set. The values shown are examples.
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To specify generic filter conditions, proceed as follows:

1 Set the Forward parameter to specify whether the MAX forwards or drops packets that
meet the conditions.

If you set Forward to Yes, the MAX forwards a packet that matches the filter definition. If
you set Forward to No, the MAX drops a packet that matches the filter definition.

2 Set the Length, Offset, Mask, and Value parameters.

The Length parameter indicates the number of bytes in a packet. The Offset parameter
specifies the starting position of the bytes the filter examines. The MAX ignores the
portion of the packet that exceeds the Length specification. In other words, the Offset
parameter hides the left-most bytes of data, while the Length parameter hides the
right-most bytes of data.

The Mask value consists of the same number of bytes as the Length parameter. A mask
hides the part of a number that appears behind the binary zeroes in the mask. For example,
if Mask is set to FFFF0000 in hexadecimal format, the MAX uses only the first 16 bits in
the comparison, because F is set to 1111 in binary format. The MAX applies the value of
the Mask parameter before comparing the bytes to the setting of the Value parameter.

3 Set the Compare parameter to specify how the MAX compares a packet’s contents to the
Value specified in the filter.

After applying the Offset, Mask, and Length values to determine the appropriate location
in a packet, the MAX compares the contents of that location to the Value parameter.

– If you set Compare to Equals (the default) and the packet data is identical to the value
specified by Value, the MAX applies the filter.

– If you set Compare to NotEquals, the MAX applies the filter if the packet data is not
identical to the value specified by Value.

4 Set the More parameter to specify whether the current filter is linked to the one
immediately following it.

If More is set to Yes, the MAX can examine multiple non-contiguous bytes within a
packet by marrying the current filter to the next one.The match occurs only if both sets of

bytes contain the specified values. If More is set to No, the MAX makes a separate
forward or drop decision for each filter.

Table 4-1. Generic filter conditions

Location Parameters with sample values

Ethernet > Filters > any Filter profile > Input
filters > 01 to 12 > Generic

Ethernet > Filters > any Filter profile > Output
filters > 01 to 12 > Generic

Forward=No
Offset=14
Length=8
Mask=ffffffffffffffff
Value=aaa030000000080f3
Compare=Equals
More=No
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Defining IP filter conditions

If Type is set to IP, you can define filter conditions relevant only to TCP, IP, and UDP data
packets, including bridged packets.

An IP filter can examine source address, destination address, and IP protocol type and port.
Table 4-2 shows the filter conditions you can specify in an IP filter. The values shown are
examples.

To specify IP filter conditions, proceed as follows:

1 Set the Forward parameter to specify whether the MAX forwards or drops packets that
match the conditions.

If you set Forward to Yes, the MAX forwards a packet that matches the filter definition. If
you set Forward to No, the MAX drops a packet that matches the filter definition.

2 Set the Src Adrs parameter to specify the address to which the MAX compares a packet’s
source address.

Enter the address in dotted decimal format. The null address (0.0.0.0) is the default. If you
accept the default, the MAX does not use the source address as a filtering criterion.

3 Set the Src Mask parameter to specify the bits the MAX should mask when comparing a
packet’s source address to the value of the Src Adrs parameter.

A mask hides the part of a number that appears behind each binary 0 (zero) in the mask.
The MAX uses only the part of a number that appears behind binary 1s. The MAX applies
the mask to the address by performing a logical AND after both mask and address have
been translated into binary format.

The value 0 (zero) hides all bits, because the decimal value 0 is the binary value
00000000; the value 255 does not mask any bits, because the decimal value 255 is the
binary value 11111111. The null address (0.0.0.0) is the default. It specifies that the MAX
masks all bits.

To specify a single source address, set Src Mask to 255.255.255.255 and set Src Adrs to
the IP address that the MAX uses for comparison.

4 Set the Dst Adrs parameter to specify the address to which the MAX compares a packet’s
destination address.

Table 4-2. IP filter conditions

Location Parameters with sample values

Ethernet > Filters > any Filter profile > Input
filters > 01 to 12 > Ip

Ethernet > Filters > any Filter profile > Output
filters > 01 to 12 > Ip

Forward=Yes
Src Mask=255.255.255.192
Src Adrs=192.100.40.128
Dst Mask=0.0.0.0
Dst Adrs=0.0.0.0
Protocol=0
Src Port Cmp=None
Src Port #=N/A
Dst Port Cmp=None
Dst Port #=N/A
TCP Estab=N/A
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Enter the address in dotted decimal format. The null address (0.0.0.0) is the default. If you
accept the default, the MAX does not use the destination address as a filtering criterion.

5 Set the Dst Mask parameter to specify the bits the MAX should mask when comparing a
packet’s destination address to the value of the Dst Adrs parameter.

6 Set the Protocol parameter to identify a specific TCP/IP protocol. For example, 6 specifies
a TCP packet.

Common protocols are listed below, but protocol numbers are not limited to this list. For a
complete list, see the section on Well-Known Port Numbers in RFC 1700, Assigned
Numbers, by Reynolds, J. and Postel, J., October 1994.

– 1—ICMP

– 5—STREAM

– 8—EGP

– 6—TCP

– 9—Any private interior gateway protocol (such as Cisco’s IGRP)

– 11—Network Voice Protocol

– 17—UDP

– 20—Host Monitoring Protocol

– 22—XNS IDP

– 27—Reliable Data Protocol

– 28—Internet Reliable Transport Protocol

– 29—ISO Transport Protocol Class 4

– 30—Bulk Data Transfer Protocol

– 61—Any Host Internal Protocol

– 89—OSPF

7 Set the Src Port # parameter to specify the port number to which the MAX compares the
packet’s source port number.

The Src Port Cmp criterion determines how the MAX carries out the comparison.

For Src Port #, you can enter a number from 0 to 65535. The default setting is 0 (zero). If
you accept the default, the MAX does not use the source port number as a filtering
criterion.

8 Set the Src Port Cmp parameter to specify the type of comparison the MAX makes when
applying the Src Port # parameter. You can specify one of the following settings:

– None specifies that the MAX does not compare the packet’s source port to the value
specified by Src Port #.

None is the default.

– Less specifies that port numbers with a value less than the value specified by Src Port
# match the filter.

– Eql specifies that port numbers equal to the value specified by Src Port # match the
filter.

– Gtr specifies that port numbers with a value greater than the value specified by Src
Port # match the filter.
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– Neq specifies that port numbers not equal to the value specified by Src Port # match
the filter.

This parameter works only for TCP and UDP packets. You must set Src Port Cmp to None
if the Protocol parameter is not set to 6 (TCP) or 17 (UDP).

9 Set the Dst Port # parameter to specify the port number to which the MAX compares the
packet’s destination port number.

The Dst Port Cmp criterion determines how the MAX carries out the comparison.

For Dst Port #, you can enter a number between 0 and 65535. The default setting is 0
(zero). If you accept the default, the MAX does not use the destination port number as a
filtering criterion.

10 Set the Dst Port Cmp parameter specifies the type of comparison the MAX makes when
applying the Dst Port # parameter. You can specify any of the settings available for Src
Port Cmp (as described in step 8).

The Dst Port Cmp parameter works only for TCP and UDP packets. You must set Dst Port
Cmp to None if the Protocol parameter is not set to 6 (TCP) or 17 (UDP).

11 Set the TCP Estab parameter to specify whether the filter should match only established
TCP connections. You can specify one of these settings:

– Yes specifies that you want the filter to match only established TCP connections.

– No specifies that you want the filter to match both initial and established TCP
connections.

No is the default.

The TCP Estab parameter does not apply if the Protocol field is set to any value other than
6 (TCP).

Defining IPX filter conditions

If Type is set to IPX, you can define filter conditions relevant to IPX packets and bridged
packets.

An IPX filter can examine network address, node address, and socket number. Table 4-3 shows
the filter conditions you can specify in an IPX filter. The values shown are examples.

To specify IPX filter conditions, perform any or all of the following:

Table 4-3. IPX filter conditions

Location Parameters with sample values

Ethernet > Filters > any Filter profile > Input
filters > 01 to 12 > Ipx

Ethernet > Filters > any Filter profile > Output
filters > 01 to 12 > Ipx

Forward=Yes
Src Network Adrs=aaaa1234
Dst Network Adrs=bc34aa56
Src Node Adrs=111111111111
Dst Node Adrs=00000000000
Src Socket #=0451
Src Socket Cmp=Eql
Dst Socket #=N/A
Dst Socket Cmp=None
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1 Set the Forward parameter to specify whether the MAX forwards or drops packets that
meet the conditions.

If you set Forward to Yes, the MAX forwards a packet that matches the filter definition.
When you set Forward to No, the MAX drops a packet that matches the filter definition.

2 Set Src Network Adrs to specify the address to which the MAX compares a packet’s
source network address.

Enter the address in hexadecimal format. The null address (000000000000) is the default.
If you accept the default, the MAX does not use the source network address as a filtering
criterion.

3 Set Dst Network Adrs to specify the address to which the MAX compares a packet’s
destination network address.

Enter the address in hexadecimal. The null address (000000000000) is the default. If you
accept the default, the MAX does not use the destination network address as a filtering
criterion.

4 Set Src Node Adrs to specify the node address to which the MAX compares a packet’s
source node address.

Enter the address in hexadecimal. The null address (000000000000) is the default. If you
accept the default, the MAX does not use the source node address as a filtering criterion.

5 Set Dest Node Adrs to specify the node address to which the MAX compares a packet’s
source node address.

Enter the address in hexadecimal format. The null address (000000000000) is the default.
If you accept the default, the MAX does not use the destination node address as a filtering
criterion.

6 Set the Src Socket # parameter to identify a specific IPX socket. For example, 0451is the
socket used for NetWare file services.

7 Set the Src Socket Cmp parameter to specify the type of comparison the MAX makes
when applying the Src Socket # parameter.

8 Set the Dst Socket # parameter to identify a specific IPX socket. For example, 0451is the
socket used for NetWare file services.

9 Set the Dst Socket Cmp parameter to specify the type of comparison the MAX makes
when applying the Dest Socket # parameter.

Specifying a data filter in a profile

Using the Data Filter parameter, you can specify a data filter in an Answer profile, a
Connection profile, or an Ethernet profile. Keep the following information in mind:

• The Answer profile and Connection profile specify the packets that can cross the WAN
interface.

• The Ethernet profile specifies the packets that can cross the local Ethernet interface.

• The MAX uses the Answer profile specification only if no Connection profile exists for
the caller.

• If Profile Reqd is set to Yes in the Answer profile, Data Filter does not apply in the
Answer profile.

Specifying a data filter for the WAN interface

To define which packets can cross the WAN interface, proceed as follows:
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1 Open a Connection profile (under Ethernet > Connections) or the Ethernet > Answer
menu.

2 Open the Session Options menu.

3 Set the Data Filter parameter to specify a data filter.

If you set Data Filter to 0 (zero), the MAX forwards all data packets.

If IPX client bridging is in use (Handle IPX is set to Client in the Connection profile), set
the Data Filter parameter to 0 (zero).

4 Close the Connection profile or Answer profile and save your changes.

A filter applied to a Connection or Answer profile takes effect only when the connection goes
from an offline state to a call-placed state.

Specifying a data filter for the local Ethernet interface

To define which packets can cross the local Ethernet interface, proceed as follows:

1 Open the Ethernet > Mod Config > Ether Options menu.

2 Set the Filter parameter to specify a data filter.

If you set Filter to 0 (zero), the MAX forwards all data packets.

If IPX client bridging is in use (Handle IPX is set to Client in the Connection profile), set
the Filter parameter to 0 (zero).

3 Save your changes.

A filter applied to the Ethernet interface takes effect immediately. If you change the Filter
profile definition, the new filters apply as soon as you save the Filter profile.

Sample filters
This section provides a step-by-step examples of creating Filter profiles and defining IP filters
for network security purposes.

A sample IP filter to prevent address spoofing

IP address spoofing is a technique in which outside users pretend to be on the local network in
order to obtain unauthorized access. This section shows how to define an IP data filter whose
purpose is to prevent spoofing of local IP addresses. You can also use Password profiles to
prevent IP address spoofing (for details, see “Using Names/Passwords profiles to prevent IP
address spoofing” on page 3-40).

In this example, the filter first defines input filters that drop (inbound) packets whose source
address is on the local IP network or is the loopback address (127.0.0.0). The third input filter
defines every other source address (0.0.0.0) and specifies that inbound packets with those
source addresses are forwarded.

The data filter then defines an output filter that drops all outbound packets with nonlocal
source addresses.
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This example assumes a local IP network address of 192.100.50.128, with a subnet mask of
255.255.255.192. Of course, you use your own local IP address and mask when defining a
Filter profile.

To define an IP data filter to prevent address spoofing, proceed as follows:

1 Select an unnamed Filter profile in the Filters menu, and press Enter.

For example, select 50-404:

50-400 Filters
50-401 IP Data
50-402 NetWare Data
50-403 AppleTalk Data
>50-404
50-405
50-406
50-407
50-408
50-409
50-410
50-411
50-412

2 Assign a name to the Filter profile.

For example:

Name=no spoofing
50-404
>Name=no spoofing
Input filters...
Output filters...

3 Open the Input Filters submenu

4 Open In filter 01.

50-404
In filter 01
>Valid=Yes
Type=IP
Generic...
IP...

5 Set Valid to Yes and Type to IP.

6 Open the IP submenu and specify the following conditions:

Ip...

>Forward=No
Src Mask=255.255.255.192
Src Adrs=192.100.50.128
Dst Mask=0.0.0.0
Dst Adrs=0.0.0.0
Protocol=0
Src Port Cmp=None
Src Port #=N/A
Dst Port Cmp=None
Dst Port #=N/A
TCP Estab=N/A
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The Src Mask parameter specifies the local subnet mask, and the Src Adrs parameter
specifies the local IP address. If an incoming packet has the local address, the MAX does
not forward it onto the Ethernet.

7 Close In filter 01 and open In filter 02.

8 Set Valid to Yes and Type to IP.

9 Open the IP submenu and specify the following conditions:

Ip...
>Forward=No
Src Mask=255.0.0.0
Src Adrs=127.0.0.0
Dst Mask=0.0.0.0
Dst Adrs=0.0.0.0
Protocol=0
Src Port Cmp=None
Src Port #=N/A
Dst Port Cmp=None
Dst Port #=N/A
TCP Estab=N/A

These conditions specify the loopback address in the Src Mask and Src Adrs fields. If an
incoming packet has this address, the MAX does not forward it onto the Ethernet.

10 Close In filter 02, and then open In filter 03.

11 Set Valid to Yes and Type to IP.

12 Open the IP submenu and specify the following conditions:

Ip...
>Forward=Yes
Src Mask=0.0.0.0
Src Adrs=0.0.0.0
Dst Mask=0.0.0.0
Dst Adrs=0.0.0.0
Protocol=0
Src Port Cmp=None
Src Port #=N/A
Dst Port Cmp=None
Dst Port #=N/A
TCP Estab=N/A

These conditions specify every other source address (0.0.0.0). If an incoming packet has
any nonlocal source address, the MAX does not forward it onto the Ethernet.

13 Close In filter 03 and return to the top level of the no spoofing Filter profile.

14 Open the Output Filters submenu, and select Out filter 01.

15 Set Valid to Yes and Type to IP.

16 Open the IP submenu and specify the following conditions:

Ip...
>Forward=Yes
Src Mask=255.255.255.192
Src Adrs=192.100.40.128
Dst Mask=0.0.0.0
Dst Adrs=0.0.0.0
Protocol=0
Src Port Cmp=None
Src Port #=N/A
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Dst Port Cmp=None
Dst Port #=N/A
TCP Estab=N/A

The Src Mask parameter specifies the local subnet mask, and the Src Adrs parameter
specifies the local IP address. If an outgoing packet has a local source address, the MAX
forwards it.

17 Close the Filter profile and save the changes.

A sample IP filter for more complex security issues

This section illustrates some of the issues you might need to consider when writing your own
IP filters. The sample filter presented here does not address the fine points of network security,
but you can use it as a starting point and augment it to address your security requirements.

In this example, the local network supports a Web server and the administrator needs to carry
out the following tasks:

• Provide dial-in access to the server’s IP address.

• Restrict dial-in traffic to all other hosts on the local network.

However, many local IP hosts need to dial out to the Internet and use IP-based applications
such as Telnet or FTP. Therefore, their response packets need to be directed appropriately to
the originating host. In this example, the Web server’s IP address is 192.9.250.5.

Each input filter is defined as described in the following sections.

In filter 01

The first input filter specifies the Web server’s IP address as the destination and sets IP
forwarding to Yes. The MAX forwards all IP packets received with that destination address.
The parameter settings are as follows:

In filter 01...Ip...Forward=Yes

In filter 01...Ip...Src Mask=0.0.0.0

In filter 01...Ip...Src Adrs=0.0.0.0

In filter 01...Ip...Dst Mask=255.255.255.255

In filter 01...Ip...Dst Adrs=192.9.250.5

In filter 01...Ip...Protocol=6

In filter 01...Ip...Src Port Cmp=None

In filter 01...Ip...Src Port #=N/A

In filter 01...Ip...Dst Port Cmp=Eql

In filter 01...Ip...Dst Port #=80

In filter 01.Ip...TCP Estab=No

In filter 02

The second input filter specifies TCP packets (Protocol is set to 6) from any address and to any
address. The filter forwards them if the destination port number is greater than that of the
source port. For example, Telnet requests go out on port 23 and responses come back on some
random port above port 1023. Therefore, this filter defines packets coming back to respond to
a user's request to Telnet to a remote host. The parameter settings are as follows:
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In filter 02...Ip...Forward=Yes

In filter 02...Ip...Src Mask=0.0.0.0

In filter 02...Ip...Src Adrs=0.0.0.0

In filter 02...Ip...Dst Mask=0.0.0.0

In filter 02...Ip...Dst Adrs=0.0.0.0

In filter 02...Ip...Protocol=6

In filter 02...Ip...Src Port Cmp=None

In filter 02...Ip...Src Port #=N/A

In filter 02...Ip...Dst Port Cmp=Gtr

In filter 02...Ip...Dst Port #=1023

In filter 02...Ip...TCP Estab=No

In filter 03

The third input filter specifies UDP packets (Protocol is set to 17) from any address and to any
address. The filter forwards them if the destination port number is greater than that of the
source port. For example, suppose a RIP packet goes out as a UDP packet to destination port
520. The response to this request goes to a random destination port greater than 1023. The
parameter settings are as follows:

In filter 03...Ip...Forward=Yes

In filter 03...Ip...Src Mask=0.0.0.0

In filter 03...Ip...Src Adrs=0.0.0.0

In filter 03...Ip...Dst Mask=0.0.0.0

In filter 03...Ip...Dst Adrs=0.0.0.0

In filter 03...Ip...Protocol=17

In filter 03...Ip...Src Port Cmp=None

In filter 03...Ip...Src Port #=N/A

In filter 03...Ip...Dst Port Cmp=Gtr

In filter 03...Ip...Dst Port #=1023

In filter 03.Ip...TCP Estab=No

In filter 04

The fourth input filter specifies unrestricted Pings and Traceroutes. ICMP does not use ports
like TCP and UDP, so a port comparison is unnecessary. The parameter settings are as follows

In filter 04...Ip...Forward=Yes

In filter 04...Ip...Src Mask=0.0.0.0

In filter 04...Ip...Src Adrs=0.0.0.0

In filter 04...Ip...Dst Mask=0.0.0.0

In filter 04...Ip...Dst Adrs=0.0.0.0

In filter 04...Ip...Protocol=1

In filter 04...Ip...Src Port Cmp=None

In filter 04...Ip...Src Port #=N/A

In filter 04...Ip...Dst Port Cmp=None

In filter 04...Ip...Dst Port #=N/A

In filter 04.Ip...TCP Estab=No
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5Setting Up Security-Card Authentication

How security cards work
If you can configure your network site to require that users change passwords several times per
day, you use an external authentication server, such as a Security Dynamics ACE/Server or an
Enigma Logic SafeWord server. The external server syncs up with hand-held personal security
cards. These devices are typically the size of a credit card. The security card provides a user
with a current password in real time. The LCD on the user’s card displays the current,
one-time-only password required to gain access at that moment to the secure network.

You can configure a remote authentication server supporting security cards to work though
RADIUS. Or, an ACE/Server or Defender server can work with the MAX directly, without
using RADIUS.

Security card authentication with RADIUS

Figure 5-1 illustrates an environment that includes a Pipeline as the calling unit, a MAX
functioning as a Network Access Server (NAS), a RADIUS server, and an external
authentication server.
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Figure 5-1. Using an external authentication server

When you use security-card authentication, the following events take place:

1 A user sends his or her username to try to open a connection to the MAX.

This user is a client of the MAX. The user can be in terminal-server mode or use the APP
Server utility during the authentication phase. When authentication is complete, the user
can switch to PPP mode.

2 The MAX determines that it must access a RADIUS user profile to authenticate the user.

3 The MAX sends the user connection request to the RADIUS server in an Access-Request
packet.

The MAX is a client of the RADIUS server.

4 The RADIUS server forwards the connection request to the ACE or SafeWord client
residing on the same system as RADIUS.

5 The ACE client forwards the information to the ACE/Server authentication server. The
SafeWord client forwards the information to the SafeWord authentication server.

In this case, the RADIUS server is a client of the authentication server.

6 The authentication server sends an Access-Challenge packet back through the RADIUS
server and the MAX to the user dialing in.

7 The user sees the challenge message and obtains the current password from his or her
security card.

If the authentication server is an ACE/Server, the user has a SecurID token card that
displays a randomly generated access code, which changes every 60 seconds.

If the authentication server is a SafeWord server, the user can have one of the following
types of token cards:

– ActivCard

– CryptoCard

– DES Gold

– DES Silver

– SafeWord SofToken

– SafeWord MultiSync

– DigiPass

– SecureNet Key

– WatchWord
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8 The user enters the current password obtained from the security card in response to the
challenge message. This password travels back through the NAS and the RADIUS server
to the authentication server.

9 The authentication server sends a response to the RADIUS server, specifying whether the
user has entered the proper username and password.

If the user enters an incorrect password, the ACE./Server or SafeWord server returns
another challenge and the user can again attempt to enter the correct password. The server
sends up to three challenges. After three incorrect entries, the MAX terminates the call.

10 The RADIUS server sends an authentication response to the MAX.

If authentication is unsuccessful, the MAX receives an Access-Reject packet. If
authentication is successful, the MAX receives an Access-Accept packet containing a list
of attributes from the user profile in the RADIUS server’s database. The MAX then
establishes network access for the caller.

Direct SecurID ACE authentication

You can configure the MAX to use ACE/Server authentication without using RADIUS. The
authentication process is different from authentication using the RADIUS server. It supports
authentication of terminal-server users only (not dial-in PPP users using the APP Server utility,
which enables a user to respond to token challenges received from an external authentication
server such as ACE/Server or SafeWord server). If your installation requires support for dial-in
PPP users, you should configure it with RADIUS (as described in “Configuring the MAX to
recognize the authentication server” on page 5-5).

The direct method is useful for installations in which other RADIUS features are not required,
because it decreases the complexity of the system, making it easier to configure and maintain.
In addition, direct ACE/Server authentication supports the New PIN Mode feature, which
allows a dial-in user to change the personal identifying number (PIN). For information about
the New PIN Mode feature, see “New PIN Mode” on page 5-16.

You can also configure ACE/Server authentication to use PAP-TOKEN-CHAP authentication.
For more information, see “Configuring PAP-TOKEN-CHAP when using direct ACE
authentication” on page 5-22.

Overview of security-card authentication methods
When setting up SafeWord and ACE/Server security-card authentication of incoming calls,
you can specify PAP-TOKEN, CACHE-TOKEN, or PAP-TOKEN-CHAP authentication. You
can also specify that users request one of these authentication types when dialing out through
the MAX. This section provides an overview of token-based authentication.

Type of
authentication

Description

PAP-TOKEN PAP-TOKEN specifies an extension of PAP authentication. The user
authenticates his or her identity by entering a password derived from a
hardware device, such as a hand-held security card. The MAX
prompts the user for this password, and possibly for a challenge key.
The MAX obtains the challenge key from a security server that it
accesses through RADIUS.
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Setting up incoming security-card calls
When the MAX receives an incoming security-card password from a user, it must forward the
authentication request to RADIUS (unless you are using direct authentication). The RADIUS
server, in turn, forwards the request to an ACE/Server or SafeWord server. The security-card
caller must have a valid RADIUS user profile. Therefore, you must carry out both of the
following tasks:

• Configure the MAX to communicate with the RADIUS server.

• Configure a RADIUS user profile for the dial-in user.

For details about these tasks, see the TAOS RADIUS Guide and Reference.

You can set up the ACE/Server for use without RADIUS (as described in “Configuring direct
SecurID ACE authentication” on page 5-17). This method does not permit use of the APP
Server utility to authenticate PPP dial-in users.

To configure the Ace/Server to use PAP-TOKEN-CHAP authentication, see “Configuring
PAP-TOKEN-CHAP when using direct ACE authentication” on page 5-22.

If you are using Defender without RADIUS, see “Configuring direct Defender server
authentication” on page 5-23.

Setting up outgoing security-card calls
Most sites use the MAX as an NAS for incoming security-card calls. However, you can also
configure the MAX as the calling unit to allow a security-card user on the local network to call
out to an NAS at a secure site.

To set up your site for outgoing security-card calls, you must complete these tasks:

1 Configure the MAX to recognize the security-card authentication server.

2 Configure the MAX to recognize the APP Server utility for each security-card user.

The APP Server utility enables a user to respond to token password challenges received
from an external authentication server, such as an ACE/Server or SafeWord server. To

CACHE-TOKEN CACHE-TOKEN uses a shared secret, and simplifies the
authentication process by caching the user’s token for the fixed length
of time specified by the Ascend-Token-Expiry attribute. During the
lifetime of the token, subsequent calls by the user require only CHAP
authentication without the use of a hand-held security card.

PAP-TOKEN-CHAP PAP-TOKEN-CHAP uses an encrypted CHAP password with which
the answering unit authenticates second and subsequent channels of an
MP+ call. The advantage of a PAP-TOKEN-CHAP call over a
PAP-TOKEN call is that only the initial connection needs to be
verified by a hand-held security card. Any additional channels are
verified by CHAP only.

Type of
authentication

Description
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allow users to supply token passwords from a host on the local network, you must
configure the MAX to communicate with the APP Server utility on that host.

3 Set up dial-out connections in one or more Connection profiles.

4 Install the APP Server utility on each user’s computer.

Configuring the MAX to recognize the authentication server

You must set each of the parameters listed in Table 5-1 for the MAX to communicate with the
authentication server. (The values shown in the table are just examples.)

The parameters listed in Table 5-1 apply only to outgoing calls that use security-card
authentication. For the authentication-server parameters to have their intended effect, your
system must meet the following conditions:

– The MAX must request PAP-TOKEN authentication. (For details, see “Requesting
PAP-TOKEN authentication” on page 5-6.)

– You must have the APP Server utility running on a UNIX or Windows workstation on
the local network. (For details about installing the APP Server utility, see “Installing
the APP Server utility” on page 5-8.)

To configure the MAX to recognize the authentication server, proceed as follows:

1 Open the Ethernet > Mod Config > DNS menu.

2 For the Password Host parameter, specify the IP address of the authentication server on
the remote network.

3 Open the Ethernet > Mod Config > Auth menu.

4 Set the Password Port parameter to specify the UDP port number that the server specified
by Password Host is monitoring.

Valid port numbers range from 0 to 65535. The default value is 0 (zero), which specifies
that the authentication server does not monitor a UDP port.

5 Set Password Server to Yes to specify that callers use security-card authentication rather
than terminal server authentication.

6 Save your changes.

Configuring the MAX to recognize the APP Server utility

To allow users to supply token passwords from a PC or UNIX host on the local network, you
must configure the MAX to communicate with the APP Server utility on that host. APP is a
UDP protocol whose default port is 7001. The communication between the MAX and the host

Table 5-1. Authentication-server parameters

Location Parameters with sample values

Ethernet > Mod Config > DNS Password Host=10.0.0.1

Ethernet > Mod Config > Auth Password Port=10
Password Server=Yes



5-6 Preliminary November 29, 2000 MAX Security Supplement

Setting Up Security-Card Authentication
Setting up outgoing security-card calls

running the APP Server can be unicast (when both the MAX and the host have an IP address)
or broadcast (when the host might not have an IP address).

To set up the MAX to communicate with the APP Server utility, set the APP Server, APP Host,
and MAX Port parameters. Proceed as follows:

1 Open the Ethernet > Mod Config > Auth menu.

2 Set APP Server to Yes.

This setting enables the MAX to communicate password challenges to the host running
the APP Server utility.

3 Specify the IP address of the host running the APP Server utility.

For example:

APP Host=10.65.212.1

If the host obtains its address at boot time from a BOOTP or DHCP server, or if it has no
IP address, you can specify the IP broadcast address (255.255.255.255).

4 Specify the UDP port to use for communicating with the host running the APP Server.

The default for the APP Server is UDP port 7001. If you change this number, you must
specify the new UDP port number in the APP Server utility (DOS), the WIN.INI file
(Windows), or the /etc/services file (UNIX). The MAX and the host running the
APP Server utility must agree on the UDP port number.

5 Save your changes.

Setting up a dial-out connection to a secure site

For the MAX to place calls to an NAS at a secure site, it needs the appropriate Connection
profile requesting a token-based authentication type. The authentication type configured in the
calling unit affects

• How the MAX transmits the token passwords

• How the user must respond when the system adds channels to an established session

The calling unit requests an authentication type, but the RADIUS daemon and RADIUS user
profile accessed by the answering NAS determine the access mode to use.

Requesting PAP-TOKEN authentication

When PAP-TOKEN authentication is in use, the MAX sends the dial-out user’s password in
the clear by means of PAP. Because the password is used for one time only, sending it in the
clear does not constitute a serious security risk.

The response to the initial password challenge authenticates the base channel of the call. If
bandwidth requirements result in an attempt to add a channel to the call, the system challenges
the user for a password.

To request PAP-TOKEN authentication for an outgoing call, set the Send Auth and Send PW
parameters. Proceed as follows:

1 Open the Ethernet > Connections menu.

2 Open the Connection profile.

3 Open the Encaps Options submenu.
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4 Set Send Auth to PAP-TOKEN.

The Send Auth parameter specifies the authentication type requested by the caller.

5 For the Send PW parameter, specify a password.

The MAX sends the value of the Send PW parameter as part of the initial session
negotiation. If the session then presents a password challenge, the user types in the current
one-time-only password displayed on the security card.

6 Save your changes.

Requesting CACHE-TOKEN authentication

CACHE-TOKEN uses CHAP and caches the initial password for re-use in authenticating
additional channels. The RADIUS profile at the remote end must include attributes specifying
how long the token remains cached. For complete information about setting up the RADIUS
user profile at the remote end, see the TAOS RADIUS Guide and Reference.

To request CACHE-TOKEN authentication for an outgoing call, set the Send Auth and Send
PW parameters.

1 Open the Ethernet > Connections menu.

2 Open the Connection profile.

3 Open the Encaps Options submenu.

4 Set Send Auth to CACHE-TOKEN.

The Send Auth parameter specifies the authentication type requested by the caller.

5 Set the Send PW parameter to specify a password.

The MAX sends the value of the Send PW parameter as part of the initial session
negotiation. The system prompts the user for a token password and uses this password to
authenticate the base channel of the call by means of CHAP. The RADIUS server caches
the encrypted password for the period specified by the Ascend-Token-Expiry attribute, or
for the amount of idle time specified by the Ascend-Token-Idle attribute. When the system
adds channels to a call or places a new call, it uses the cached password to authenticate the
channels.

6 Save your changes.

Requesting PAP-TOKEN-CHAP authentication

In PAP-TOKEN-CHAP authentication, the remote NAS uses the dynamic password supplied
by the user to authenticate the base channel of the call. The MAX sends the dial-out user’s
password in the clear (by means of PAP). When the MAX adds additional channels to the base
channel of the call, it uses CHAP authentication for the new channels. CHAP sends encrypted
passwords, so it can take the auxiliary password specified by the Aux Send PW parameter and
transmit it securely.

If the calling unit requests PAP-TOKEN-CHAP authentication but the RADIUS user profile at
the remote end is not set up for PAP-TOKEN-CHAP, the remote end uses PAP-TOKEN
authentication instead.

To request PAP-TOKEN-CHAP authentication for an outgoing call, set the parameters as
follows.

1 Open the Ethernet > Connections menu.
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2 Open the Connection profile.

3 Open the Encaps Options submenu.

4 Set Send Auth to PAP-TOKEN-CHAP.

The Send Auth parameter specifies the authentication type requested by the caller.

5 Set the Send PW parameter to specify a password.

The MAX sends the value of the Send PW parameter as part of the initial session
negotiation. If the session then presents a password challenge, the user types in the current
one-time-only password displayed on the security card.

6 Set the Aux Send PW parameter to specify an auxiliary password.

When the MAX adds more channels after establishing the call’s base channel, CHAP
encrypts the auxiliary password specified by Aux Send PW and transmits it to the remote
end.

7 Save your changes.

Installing the APP Server utility

The APP Server utility enables a user to respond to token password challenges from an
external authentication server, such as a Security Dynamics (ACE) or Enigma Logic
(SafeWord) server.

Previous versions of the APP Server utility enabled a single user to respond to password
challenges from a remote ACE/Server or SafeWord server. The current version supports
multiple tokens (for a user name as well as the current password) so more than one user can use
the APP Server to respond to password challenges.

Getting the right version of the utility

The APP Server utility is available for five platforms: DOS, Windows 3.1, Windows 95,
Windows NT, and UNIX. The utility resides on ftp.ascend.com as a single tar archive
that contains all five versions of the utility.

The tar file expands into five directories, one for each version of the utility:

• The DOS and Windows executable files are:

– appsrvds.exe (for DOS)

– appsrv31.exe (for Windows 3.1)

– appsrv95.exe (for Windows 95)

– appsrvnt.exe (for Windows NT)

• The directory contents for the Windows 95 and Windows NT versions are compressed.

• The UNIX utility is supplied as source files.

Creating banner text for the password prompt

The current release incorporates a banner display facility. The banner text appears with the
password prompt on the APP Server screen when you receive a challenge message. You can
use the sample banner file included with this release. Or, you can specify the banner text in an
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ASCII file named appsrvr.ini. You can create the text file with any text editor. The file
must reside in the directory in which the APP Server utility is located.

The banner can contain up to 200 characters and five lines of text. The first line of the file must
contain the text [BANNER]. For example, you might set up the file as follows:

[BANNER]

line1=The security password has changed. Please consult your
line2=card and enter the current password now.

line3=You have 60 seconds to enter the new password.

Installing the APP Server utility for DOS

To install the APP Server utility for DOS, proceed as follows:

1 Create an \ascend directory below the root directory.

2 Copy appsrvds.exe into the \ascend directory.

3 If the appsrvr.ini file exists, copy the file into the \ascend directory.

For more information about the appsrvr.ini file, see “Creating banner text for the
password prompt” on page 5-8.

4 Open the autoexec.bat file and add a command line to start appsrvds.exe.

The appsrvds.exe DOS utility does not require an IP stack or IP address, but it does
require an ODI driver.

You must put the command line for appsrvds.exe after the line that loads the network
ODI driver and before the line that loads the network protocol stack (TCP/IP, IPX, or
another supported protocol). For example:

C:\novell\lsl.com
C:\novell\xxxodi.com
C:\ascend\appsrvds.exe

REM Protocol Stack is loaded next

5 Save your changes and close the autoexec.bat file.

6 Reboot your machine.

You can specify these options on the autoexec.bat command line:

• /t—Specifies a time delay between connection attempts (in seconds).

• /y—Specifies the number of cycle counts (attempts to connect) before timeout.

• /m—Specifies the MAC address (in decimal format) of the PC running the utility.

• /p—Specifies a UDP port number for communicating with the MAX.

• /b—Specifies a UDP port for broadcast messages.

• /f—Suppresses the call at startup.

• /d—Disconnects the call.

• /c—Specifies the name of the Connection profile to use to connect to the remote secure
network.

• /?—Displays a help screen.

Note: The PC sends a broadcast UDP packet that has the destination and the source port
7001, unless you specify otherwise with the /p or /b option. If you specify a number other
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than 7001 in the APP Port parameter, you must use the /p or /b option to specify the same
port.

If you do not specify any command-line variables, the APP Server utility uses the following
default values:

• Time delay between connection attempts is set to 20 seconds

• Number of cycles is set to 3 (3 times 20 seconds)

• APP Server PC MAC address is set to none (zeros)

• UPD port to use is set to 7001

• Broadcast UDP port is set to communication UDP port

• APP Server forces a connection upon execution

Note: A Connection profile is required for logging into the remote secure network, so if the
APP Server line in the autoexec.bat file does not specify which Connection profile to use,
the system prompts you for a Connection profile name as the system boots.

For example, consider this command line:

C:\ascend\appsrvds.exe /cChicago /t20 /p7005

This line specifies a Connection profile named Chicago, assigns a 20-second time delay
between connection attempts, and designates UDP port 7005 for communicating with the
MAX.

Now, consider the following command line:

C:\ascend\appsrvds.exe /cChicago /m00805110C7A44 /p7523 /t65 /b7112

This line specifies a Connection profile named Chicago, specifies 00805110C7A44 as the
MAC address of the PC running the utility, designates UDP port 7523 for communicating with
the MAX, assigns a 65-second time delay between connection attempts, and designates port
7112 for sending broadcast messages (to initiate a call).

Installing the APP Server utility for Windows 3.1

To install the APP Server on a Windows 3.1 workstation, proceed as follows:

1 Create an \ascend directory below the root directory.

2 Copy appsrv31.exe into the \ascend directory.

3 If the appsrvr.ini file exists, copy that file into the \ascend directory.

For details about the appsrvr.ini file, see “Creating banner text for the password
prompt” on page 5-8.

4 Copy ctl3d.dll into the Windows \system directory.

Lucent recommends adding the APP Server utility to the startup group (provided that you
connect to the network as part of normal system startup). If you do not add the APP Server
utility to your Startup group, you can launch the utility manually by double-clicking its icon.

To create an icon and add the APP Server to the startup group, proceed as follows:

1 Create a new program group. In the Program Manager, choose File > New > Program
Group and type:

Ascend
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2 Create an icon for appsrv31.exe. In the Program Manager, choose
File > New > Program Item.

3 To launch the APP Server utility when you start Windows, place the appsrv31.exe
icon in your Startup group.

4 Reboot your machine.

Installing the APP Server utility for Windows 95

To install the APP Server on a Windows 95 workstation, proceed as follows:

1 Copy the file xas-w95.exe into a temporary directory.

2 Execute the file from the DOS shell.

The xas-w95.exe zip file expands to several files that constitute the Setup program for
Windows 95.

3 From the Start menu, run the Setup program in the temporary directory.

4 Follow the prompts and select the directory in which to install APP Server for Windows
95.

APP Server for Windows 95 starts automatically whenever the system reboots. You can close
the APP Server utility in a session, but next time you reboot the system, the utility starts up
again. To permanently remove or disable the APP Server utility, you must edit the Windows 95
Registry to remove the key that refers to appsrv95.exe.

Installing the APP Server utility for Windows NT

To install the APP Server on a Windows NT workstation, proceed as follows:

1 Copy the file xas-nt.exe into a temporary directory.

2 Execute the file from the DOS shell.

The xas-nt.exe zip file expands to several files that constitute the Setup program for
Windows NT.

3 From the Start menu, run the Setup program in the temporary directory.

4 Follow the prompts, selecting the directory in which to install APP Server for
Windows NT.

APP Server for Windows NT starts automatically whenever the system reboots. You can close
the APP Server utility in a session, but next time you reboot the system, the utility starts up
again.

There are three icons provided during installation that enable you to temporarily disable the
APP Server, manually control when it runs, or remove it from the system.

Icon Function

Activate service icon Restarts the utility, or activates it for the first time.

Remove service icon Stops the utility if it is running and removes it from the service
database. It no longer appears as a service in the Services applet on the
Control Panel.
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Installing the APP Server utility for UNIX

To install the APP Server utility on a UNIX host:

1 Edit the Makefile appropriately for your operating system and compiler.

2 Compile the appsrvr source file (make).

3 Add a line to the /etc/services file, assigning UDP port 7001 to the APP Server
utility.

To use the default UDP port 7001, add the following line to the /etc/services file, to
document that the port is now in use:

appServer 7001/udp

If port 7001 is already assigned for a different purpose, you can use a different port for the
APP Server utility by adding a line such as the following to the services file:

appServer port_num/udp

The port_num argument is the port number the utility uses. Make sure you specify the
same number for the APP Port parameter on the MAX.

4 If the UNIX host has an IP address, you can run the utility in unicast mode by typing the
following command at the UNIX prompt:

./appsvr

When you run the utility in unicast mode, it transmits packets on the specified UDP port
with the source address set to its own IP address. When the MAX receives the packets on
the specified UDP port, it returns them to the specified IP address.

5 If the UNIX host does not have an IP address (for example, if it obtains its address from a
BOOTP or DHCP server), run the utility in broadcast mode by entering the following
command:

./appsrvr –b

The -b argument sets a socket option to allow broadcast transmissions and inhibits the
utility’s error messages about receiving invalid APP frame types when it receives its own
transmissions.

Note: On some UNIX systems, you need root privileges to run the APP Server utility in
broadcast mode. Some hosts disallow broadcast transmissions without root privileges. If you
are running the utility in broadcast mode, make sure that the MAX is configured with the
broadcast address in the APP Host parameter (APP Host=255.255.255.255).

Uninstall service icon Removes the files, icons, program groups, and registry entries from
the system.

Icon Function
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Dialing a connection to a secure site

This sections describes how to initiate a connection to a remote network from a terminal server
and from a DOS, Windows, or UNIX workstation.

Connecting to a remote network from the terminal server

To make an outgoing call to a secure site from a terminal server session, perform all the steps
of the following procedure. For a modem connection, begin at step 2.

1 At the terminal server prompt, enter the following command:

set password

The following message appears:

Entering Password Mode...

Then the prompt changes to the display following text:

[^C to exit] Password Mode>

2 Bring up a connection to the secure site in one of the following ways:

– Start a program that requires a connection to a host on the remote network.

– Use the DO menu on the MAX.

– Dial the remote NAS via modem.

The remote NAS returns a challenge prompt similar to the following:

From: hostname
0-Challenge: challenge

Enter next password:

where hostname is the name of the NAS you are calling. It is optional on some
systems.

If the Send Auth parameter is configured incorrectly, no challenge prompt appears, or you
see an error message such as the following:

From: hostname
Received unexpected PAP Challenge!... check PPP Auth Mode

3 At the challenge prompt, enter the password obtained from your security card.

You have 60 seconds to enter the password correctly. When you enter the correct
password, the MAX establishes the connection to the secure network. If you do not
specify the correct password within 60 seconds, the login attempt times out. If you enter
the password incorrectly, the challenge prompt displays again, up to three times.

4 Press Ctrl-C at the Password Mode prompt to return to normal terminal server operations.

Connecting to a remote network from a DOS workstation

To initiate a connection to a remote secure network, reboot the PC. After the initial session
negotiation, the remote ACE/Server or SafeWord server returns a password challenge similar
to the following:

From: hostname
0-Challenge: challenge
Enter next password:

where hostname is the name of the NAS the user is calling. It is optional on some systems.
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If the Send Auth parameter is configured incorrectly, no challenge prompt appears or you see
an error message such as the following:

From: hostname
Received unexpected PAP Challenge!... check PPP Auth Mode

You have 60 seconds to enter the password correctly. When you enter the correct password, the
MAX establishes the connection to the secure network. If you do not specify the correct
password within 60 seconds, the login attempt times out. If you enter the password incorrectly,
the challenge prompt appears again, up to three times.

If more than one user uses the APP Server to log into a remote secure network through the
MAX, each user must include a user name in the following format:

password.username

Connecting to a remote network from a Windows workstation

The user interface is the same for all Windows versions of the APP Server utility. To use the
Windows version, proceed as follows:

1 Start the utility by using the Services applet on the Control Panel.

2 In the dialog that displays, click Connect.

The Settings dialog box opens.

3 Enter the name of the Connection profile used to log into the remote secure network.

4 Enter your username.

You can specify up to 32 characters. Do not enter spaces.

5 Click OK.

After the initial session negotiation, the remote ACE/Server or SafeWord server returns a
password challenge in a dialog box. You have 60 seconds to obtain the current dynamic
password from the security card and enter it correctly.

6 Type the current password and click OK.

7 To log out of the remote network, click Disconnect.

8 In the dialog that appears, type the name of the Connection profile that defines your
connection to the remote network, then click OK.

Connecting to a remote network from a UNIX workstation

When you start an application that requires a connection to a host on a secure network, the
MAX initiates a call. After the initial session negotiation, the remote ACE/Server or SafeWord
server returns a password challenge similar to the following:

From: hostname
0-Challenge: challenge (or null challenge, depending on your
setup)
Enter next password:

where hostname is the name of the NAS you are calling. It is optional on some systems.

If the Send Auth parameter is configured incorrectly, no challenge prompt appears, or you see
an error message such as the following:
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From: hostname
Received unexpected PAP Challenge!... check PPP Auth Mode

You have 60 seconds to enter the password correctly. When you enter the correct password, the
MAX establishes the connection to the secure network. If you do not specify the correct
password within 60 seconds, the login attempt times out. If you enter the password incorrectly,
the challenge prompt appears again, up to three times.

If more than one user uses the APP Server to log into a remote secure network through the
MAX, each user must include a user name in the following format:

password.username

How the SecurID ACE/Server works without RADIUS
Users dialing into a MAX who are authenticated by a SecurID ACE server directly (without
RADIUS) can specify that one of the MAX unit’s local profiles provide the values for the
session parameters. When a user dials into the MAX, the usual banner and prompt appear. For
example:

** Ascend Pipeline Terminal Server **

Login:

When the user enters a name, the screen prompts for a password:

Password:

At this point, the user must enter his or her PIN, followed by the numbers currently displayed
on the SecurID token card.

Note: Unlike the SecurID ACE support in RADIUS, which ignores input entered in response
to the Password prompt and asks for a Passcode, this direct implementation does not take the
extra step. The MAX sends the password-prompt response to the ACE server as the passcode.
If you want the MAX to ask for a passcode, you can change the password prompt by setting the
Password Prompt parameter in the TServ Options submenu of the Ethernet Profile to a new
value.

If the login is correct, the terminal-server prompt appears:

ascend%

If the login is incorrect, the following message appears:

** Bad Password

and the MAX requests another login. The user gets three chances to enter a valid login
name/password (or passcode) combination.

NextCode Mode

If a particular user has three or more consecutive incorrect logins, the server marks that user's
token card as being in NextCode mode. When the user finally logs in successfully, he or she
must enter in an extra passcode from his or her token to verify actual possession of the token
card. When the user has sent his or her first correct PIN + passcode to the MAX, the following
message appears:
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Wait for the code on your token to change, then enter the new
code (without PIN).

Passcode:

The user must wait until the number displayed on the token card changes, and then type in that
number without the PIN. If the user enters a correct code, the terminal server command prompt
or menu appears. If the user enters an incorrect code, the MAX displays a **Bad
Password** message and the user's token remains in NextCode mode.

New PIN Mode

The ACE server system administrator can place particular tokens in New PIN mode. The next
time the user successfully authenticates and wants access to the system, the user must choose a
new PIN or allow the server to generate one.

After the normal authentication, the MAX displays one of the following three messages:

1 If the server has been configured to allow the user to choose a new PIN or request one
from the server, the following 5-line message displays:

Enter your new PIN, containing 4 to 8 digits:

or

<Return> to generate a new PIN and display it on the screen:

or

<Ctrl C> to cancel the New PIN procedure:

Note: The number of allowed digits might change according to the server configuration. The
server can also be configured to allow alphabetic characters in the PIN, in which case the word
characters appears in place of digits in the first message.

2 If the server has been configured to force the user to choose his or her own PIN, the
following message appears:

Enter your new PIN, containing 4 to 8 digits:

3 If the server has been configured to restrict the user from choosing a PIN, and to always
generate a random PIN for the user, the following message appears:

Press <Return> to generate a new PIN and display it on the screen:

User-chosen PIN

In cases 1 and 2, when the user enters a new PIN, the server checks the PIN. If the new PIN has
the appropriate number of characters or digits, the MAX asks the user to retype the same PIN
for verification:

Please re-enter new PIN:

The user types in the new PIN. If the PINs match, the new PIN is sent to the server, the user is
informed that the PIN has changed, and the following message appears:

Wait for the code on your token to change, then log in with the
new PIN

Login:
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If, after the second verifying PIN entry, the MAX detects that the user has entered two different
PINs, the following message appears:

PINs do not match. Please try again.

Login:

The user must log in again. The server then asks the user to choose a new PIN.

Server-chosen PIN

In cases 1 and 3, when the server generates a PIN for the user, the user simply presses Enter in
response to the initial “New PIN” prompt. The server then displays the following prompt:

ARE YOU PREPARED TO HAVE THE SYSTEM GENERATE A PIN? (y or n)
[n]:

If the user presses y or Y, the screen displays a new PIN chosen by the ACE server. For
example:

Your new PIN: 6467

Press Enter to clear screen:

The user must immediately memorize the PIN, and then press Enter. The screen clears, the PIN
is sent back to the MAX for confirmation, and if the ACE server accepts the PIN, the MAX
displays the following message:

Wait for the code on your token to change, then log in with the
new PIN

Login:

Note: Changing your PIN counts as one of the three allowed logins per dialup, so a correct
PIN change followed by a login counts as two attempts. Therefore, if you fail twice, you need
to redial and connect to complete authentication.

Configuring direct SecurID ACE authentication
If you configure the SecurID ACE as the external authentication server for your MAX, any
calls that are not authenticated by local Connection profiles are forwarded to the ACE server
for authentication. If you require your MAX to reach more than one authentication server, see
the TAOS RADIUS Guide and Reference. Other software products, such as Access Control,
support multiple external authentication servers through the MAX.

Although SecurID ACE authentication is indirectly supported through RADIUS, direct
support for the SecurID ACE server can be useful for two main reasons. The first applies to
installations in which other RADIUS features are not required. Direct SecurID ACE support
decreases the complexity of such a system, making it easier to configure and maintain.

The second reason is that you can specify one of the MAX unit’s local profiles to be used for
session parameters with ACE authentication, and configure different profiles/addresses for
each user on the basis of whether the user has dialed in with a modem (analog call) or ISDN
(digital call). You can also specify a LAN Address setting that overrides the LAN Address in
the specified profile (or in the default profile, if no specific profile is given). Therefore, you
can specify two different remote settings for a user with a single token card.
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To configure the MAX for direct authentication using a SecurID ACE server, proceed as
follows:

1 Open the Ether > net > Mod Config > Auth menu:

X0-X00 Mod Config
Auth
>Auth=SECURID
Auth Host #1=137.175.80.24
Auth Host #2=0.0.0.0
Auth Host #3=0.0.0.0
Auth Port=2626
Auth Timeout=10
Auth Key=N/A
Auth Pool=No
APP Server=No
APP Host=N/A
APP Port=
SecurID DES encryption=N/A
SecurID host retries=N/A
SecurID NodeSecret=N/A

2 Set Auth to SECURID.

Auth Host #2 and Auth Host #3 are not applicable, because the MAX can support only one
SecurID ACE authentication server at this time.

Note: For a SecurID server to authenticate an AppleTalk Remote Access (ARA) caller
through RADIUS, set Auth to RADIUS/LOGOUT. For more information about setting up
a ARA connection through RADIUS, see “Setting up ARA authentication” on page 3-31.

3 Set the Auth Port parameter to the UDP port number used by the SecurID ACE server.

For example, you might specify the following setting:

Auth Port=1545

4 Set the Auth Timeout parameter to specify the number of seconds the MAX waits for a
response to an authentication request.

If the MAX does not receive a response within the time specified by Auth Timeout, it
assumes the SecurID ACE server has become nonfunctional.

5 Choose one of the following values for SecurID DES encryption parameter to specify
whether the server uses standard DES or the native encryption provided by SecurID.

– Yes specifies that the server uses standard DES encryption.

– No specifies that the server uses the native encryption provided by SecurID.

6 Set the SecurID Host Retries parameter to an integer to specify the number of times the
MAX attempts to contact the SecurID host before timing out.

The default value is 3.

7 Set the SecurID Node Secret parameter.

For details on this parameter, see the MAX Reference.

Configuring user shell settings on the ACE server

You can configure a user shell setting for each user on the ACE server. The shell setting
specifies how calls are handled for each user, including the name of a MAX local profile to
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apply when setting up the call and an address and subnet mask to use in place of the LAN
address in the given profile.

Shell setting structure

The ACE shell setting, which is limited to 64 characters, consists of call type specifications
and the parameters and associated values that define how calls of each type are handled.

The syntax is:

[CallType ][ rp=password ] [la=ipaddress ] [prf=conn-prof ]

[|[CallType ][ rp=password ] [la=ipaddress ] [prf=conn-prof] ]

where:

CallType Specifies the call type to which the parameters that follow (up to the |
symbol) apply. Permitted values are:

A Analog (modem) calls
D Digital (ISDN) calls
no specifier Both analog and digital calls

For information about how calls are classified as analog or digital,
refer to the explanation of the NAS-Port attribute in the TAOS
RADIUS Guide and Reference.

= Parameters are used in simple assignment statements, in which the
equal sign assigns the value following it to the preceding parameter.

rp = password rp indicates that the string value that follows (password) is to be
used in place of the Receive Password in the Connection profile for
authentication of calls subsequent to the first call.

The rp value applies only to PAP-TOKEN-CHAP calls because
direct SecurID authentication does not support CACHE-TOKEN.
Note also that the rp value authenticates the second and subsequent
calls in an MP bundle, never the first call, which must be
authenticated by the user with a token value from the SecurID card.

la = ipaddress la indicates that the dotted decimal value that follows (ipaddress)
specifies the IP address of the remote caller that differs from that in
the selected or default Connection profile’s Lan Adrs parameter. You
can also use a subnet mask, such as 202.444.3.19/24.

prf= conn_prof prf indicates that the string value that follows (conn_prof) is the
name of the Connection profile stored in the MAX unit’s NVRAM to
configure the caller.

If there is no profile for a call, the MAX unit’s behavior depends on
whether the Answer profile’s Use Answer as Default parameter has
been set to yes or no. If set to yes, the Answer profile is used as the
default. If set to no, the Factory Default Profile is used.

| (vertical line/pipe
symbol)

Separates call type specifications and indicates the end of a string.
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Each parameter is copied in sequence onto the current state of the caller’s profile.
Consequently, it is possible for one setting to overwrite another. Take care to ensure that your
settings do not have unintended results. For example, in the following setting, the rp value of
joebob is read and applied first, then it is overwritten unintentionally by the Receive
Password parameter in the profile john.

rp=joebob prf=john

One way to limit the likelihood of overwriting is to place the prf parameter before the rp or
la parameter.

Authentication fails if string values in a shell setting are unrecognized or in error. Observe the
following rules in specifying strings:

• Use single quotes (‘string value’), double quotes (“string value”) or square
brackets ([string’s value]) to delimit strings only when the string contains a space
or one of the other delimiters.

• Do not use the vertical line/pipe symbol ( | ) in any string. Use it only to separate call
specifications.

• Use short strings to avoid exceeding the 64-character limit. If you exceed the permitted
number of characters, the setting is truncated and the authentication might fail. The ACE
server’s sdadmin program does not check to ensure compliance with the limitation.

Example User Settings:

Following are examples of ACE server user settings.

Notice that the previous setting just fits in the permitted space, with 64 characters. If the setting
were any longer, the end of modemroute would be cut off and authentication would fail for
analog calls. The same setting could be shortened to the following:

Another way to save space is to place parameters that are common to both analog and digital
calls in a section that precedes the parameters that set analog or digital specifics. For example:

|D prf="isdnroute" rp=[greco] la=192.0.2.1/24 |A prf=modemroute

If the caller is digital, then:
Use the profile called isdnroute.
Set Receive PW to greco.
Set Lan Addr to 192.0.2.1/24.

If the caller is analog, then use the
profile called modemroute.

|D prf=isdnroute rp=greco la=192.0.2.1|A prf=modemroute

The quotation symbols are
unnecessary and have been
removed.

The space between the | and the
A was unnecessary. The |
indicates end-of-string as well as
the start of a new call type
specifier.

The subnet mask is unnecessary
because /24 is the default subnet
for a class C network address.
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The section with common parameters can precede or follow the call-type-specific parameters.
In the following example, the common parameters follow the specific parameters:

You do not need to include separate sections for each call type in your user settings. For
example, in the following setting, the general assignment statements suffice without specifying
sections for different call types:

You can also have just one call type or the other. In the example that follows, the digital caller’s
settings are specified. The analog settings are not set explicitly. Consequently, the Default or
Answer profile is applied to analog callers, depending on the setting of the Use Answer as
Default parameter in the Answer profile:

Troubleshooting errors in user settings

If there is an error or unrecognized string in a user’s shell setting, the authentication fails. If
you have trouble determining what caused the failure, enter the MAX unit's debug mode and
turn on a diagnostic display of the string interpretation by executing the command
securiddebug, which is a toggle that turns the display on and off.

Verify that you have not exceeded the 64 character limit. If the final parameter is not complete,
you have exceeded the limit. For security, this debug mode does not display the password
string.

Because debug mode does not display the password string, you cannot tell directly from the
debug output whether the rp parameter is being truncated. If you encounter problems with the
second and subsequent channels of an MP call being automatically authenticated, the problem
could be that the end of the rp parameter is being cut off.

prf=john |D la=135.2.2.4/24 |A la=135.2.3.20

1. The settings are always
taken from the profile john.

2. The address is set differently depending on whether the call is
analog or digital.

|A prf=modemroute |D prf=isdnroute | la=10.0.0.20/32

1. Use the modemroute
profile for analog calls.

2. Use the isdnroute profile
for digital calls.

3. Use the address 10.0.0.20/32 for
all calls.

prf=john la=10.0.0.20/32

Whether the call is digital or analog:
Use the profile john
Set the Lan Adrs to 10.0.0.20/32

|D prf=isdnroute rp= "go for it"

1. The digital settings are explicit. 2. The analog settings are derived from the
settings for the Use Answer as Default
parameter in the Answer profile.
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Configuring PAP-TOKEN-CHAP when using direct ACE authentication

PAP-TOKEN-CHAP stores a static password in the user's shell setting on the ACE server and
sends it back to the MAX when the user first connects. Except for this, PAP-TOKEN-CHAP
configuration on the calling router is identical to configuring PAP-TOKEN-CHAP for any
other type of token card authentication.

To set the static password to use during PAP-TOKEN-CHAP for a particular user:

1 Run the sdadmin program on the ACE server machine.

2 From the Client menu, select Edit.

3 Select the MAX from the list of clients and click OK.

4 Click User Activations.

5 From the Directly Activated Users list, select the one using PAP-TOKEN-CHAP, then
click Edit Activation Data.

6 In the Activation Data window, delete any existing text in the Shell field, and replace it
with:

rp=”password”

where rp stands for Receive Password and password is the password to be configured
in step 8 as the Aux Send PW on the calling router (usually a Pipeline).

For example, if you type

rp=”Little Big”

in the Shell field (with quotation marks), the password the user types is

Little Big (without quotation marks).

In this example, the quotes are delimiters for the password. Different delimiters are
allowed so that the user can choose a password containing those delimiters, for example:

rp='Quote”quote'

which contains a double quote in the middle of the password.

You can use any character you like for the delimiters in place of the double quotes except
the vertical bar ( | ), which has a special meaning in the shell field. For example, the
following entry would produce the same Receive Password setting as rp=”Little
Big”:

rp=/Little Big/

However, rp=[Little Big] is not identical and would an produce error, because the
left bracket and right bracket are different characters.

7 Press OK to clear the Activation Data dialog and Exit to clear the Edit Client dialog.

8 Configure the calling router (usually a Pipeline) to use PAP-TOKEN-CHAP
authentication, and set Aux Send PW in the Connection profile Encaps options to be
identical to the string you entered in the ACE server as rp in step 6.

Assuming all other configuration is already done (configuring the answering MAX to use
SecurID authentication, and configuring the calling router to use the APP Server, for example),
you should now be able to bring up a multi-channel call, although it performs only a single
token authentication.
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Configuring direct Defender server authentication
This section describes how to configure the Defender as your MAX unit’s external
authentication server. When you configure the Defender as an external authentication server,
any calls that are not authenticated by local Connection profiles are forwarded to the Defender
server for authentication.

If you require your MAX to reach more than one authentication server, see the TAOS RADIUS
Guide and Reference. Other software products, such as Access Control, support multiple
external authentication servers through the MAX.

Note: The Defender server does not provide per-user control, such as enforcing a maximum
number of channels. It provides only per-user authentication. If you need both per-user control
and authentication, you need RADIUS.

How Defender server authentication works

Table 5-2 show the three major stages in authentication using AssureNet Pathways’ Defender.
The behavior of the MAX depends on the stage of the call dialing the MAX is in when it loses
the connection with the host.

Table 5-2. Token card authentication

Stage Duration of stage Authentication actions

1 Stage 1 usually occurs a short time
after the caller has connected to the
MAX and before the MAX has
received the first prompt from the
authentication host.

The Defender server provides the text
of the prompts or challenges, and the
MAX passes them through to the
caller.

Calls in Stage 1 are preserved if an
authentication host is unavailable or loses
its connection.

This might be the case when the very first
caller is authenticated with Defender after
the router boots up, and the first
authentication host is unavailable. The
Defender authentication code in the router
tries the second and third hosts to
authenticate the user.

2 Stage 2 occurs during the time the
caller is interacting with the
authentication host, but before the
authentication sequence is complete.

The Defender uses a
challenge-response protocol, with a
token card to provide the responses.

Calls in Stage 2 are never preserved if an
authentication hosts loses its connection.

Defender has no mechanism for having one
authentication server take over for another if
the first loses connection in the middle of a
state.
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When no authentication host is available

If a MAX cannot establish contact with any of the authentication hosts in Ethernet > Mod
Config > Auth > Auth Host n parameter, it drops all sessions, including calls in Stage 1.

If a caller who has been disconnected tries again to make a connection, the MAX begins the
process again of connecting to authentication hosts in the list until it either succeeds or has
tried every host in the list.

To configure a Defender server for direct authentication, proceed as follows:

1 Open the Ethernet > Mod Config > Auth menu:

X0-X00 Mod Config

Auth

>Auth=Defender

Auth Host #1=137.175.80.24

Auth Host #2=0137.174.81.0

Auth Host #3=0137.174.80.25

Auth Port=2626

Auth Timeout=10

Auth Key=****************

Auth Pool=No

APP Server=No

APP Host=N/A

APP Port=N/A

SecurID DES encryption=N/A

SecurID host retries=N/A

SecurID NodeSecret=N/A

2 Set Auth to Defender.

3 Specify up to three authentication hosts for the Auth Host # parameters.

4 Set the value of Auth Port to the TCP port number of the Defender authentication server
(usually 2626).

5 Set the value of Auth Key.

3 Stage 3 occurs when the caller has
completed authentication and is
interacting with the MAX normally
(either asynchronously or framed).

Callers in Stage 3 are not dropped by the
router because their calls are already
authenticated. However, because the host on
which they were authenticated is no longer
available, their logout time is not sent (as
would be the case if the host had remained
connected).

Defender provides no mechanism to notify
one authentication host when a user call that
was authenticated by another host is
terminated.

Table 5-2. Token card authentication (continued)

Stage Duration of stage Authentication actions
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Auth Key is used as a DES secret key shared between the MAX and the Defender
authentication server. This key is also used for authentication by the MAX in its role as a
Defender authentication agent.

6 Set Auth Timeout to indicate the number of seconds the MAX waits before assuming that
the Defender server has become nonfunctional.

7 Enter the port number for the source port for remote authentication requests.

Type a port number from 0 to 65535. The default value is 0 (zero). If you accept this value,
the MAX can use any port number from 1024 to 2000.

You can specify the same port for authentication and accounting requests.

8 Normally, APP Server is set to No. APP Server only applies when the MAX makes
outgoing calls to MAX units and other sites that use token card authentication. See the
MAX Reference for more information.

9 If the MAX must make outgoing calls to other MAX units and to other sites using
token-card authentication, you might need to set APP Servers. Normally APP Server is set
to No. For more details, see the MAX Reference.

10 Save your changes.
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6Setting Up User Authorization

Setting up terminal-server security
A terminal-server connection is a host-to-host connection that uses analog modem, ISDN
Terminal Adapter (using V.110 or V.120 encapsulation), or raw TCP. This section also applies
to locally connected terminal-server users, and describes how to limit access to the
terminal-server features such as Telnet server, raw-TCP, Rlogin server, and modem dialout.
(For more information about the authentication required before a remote user can get access to
any of these features, see “Setting up authentication for dial-in terminal server users” on
page 3-23.)

When the MAX receives an analog modem, ISDN TA, or raw TCP call, it determines whether
the call is PPP-encapsulated. If it is, the MAX forwards the call to the router. If the call is not
PPP-encapsulated, the MAX establishes a terminal-server connection.

In Figure 6-1, a PC running SoftComm initiates an incoming modem call. The MAX directs
the call to its digital modems, then forwards the call to its terminal-server software. In
Figure 6-1, the MAX immediately directs the call to a Telnet host.

Figure 6-1. A remote terminal-server connection

You can customize and limit access to the terminal-server interface in the following ways:

• Turn terminal-server operation on or off.

• Specify customized prompts for remote terminal-server users.
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• Restrict use of terminal-server commands and protocols.

• Restrict access to the terminal-server command line.

• Restrict Telnet, raw TCP, and Rlogin access to the terminal server.

• Permit TCP-CLEAR or Telnet dial-in access even when the RADIUS user’s profile does
not specify a login host.

• Set a timeout value so that users are disconnected if they have not completed logging in
when the timer has elapsed.

• Disconnect a user’s Telnet connection by using the session ID for the connection.

Table 6-1 lists the parameters you can use to customize and restrict access to the
terminal-server environment.

For complete information about setting up terminal-server connections in the MAX
configuration interface, see the Network Configuration Guide for your MAX. For complete
information on setting up terminal-server connections in RADIUS, see the TAOS RADIUS
Guide and Reference.

Turning terminal-server operation on or off

To specify whether users can access the terminal-server interface, proceed as follows:

1 Open the Ethernet > Mod Config > TServ Options menu.

2 To enable terminal-server access, set TS Enabled to Yes. To disable terminal-server
access, set TS Enabled to No.

Table 6-1. Terminal-server security parameters

Location Parameters with sample values

Ethernet > Mod Config > TServ Options

Note: The Passwd and Imm. Modem Pwd
parameter values appear only when you
view them with a Full Access Security
profile in effect. Otherwise, they appear as
*SECURE* and *password*,
respectively.

TS Enabled=Yes
Passwd=newcorpPW
Login Prompt=
Password Prompt=
3rd Prompt=Service?
3rd Prompt Seq=First
Initial Scrn=Cmd
Toggle Scrn=No
Security=None
Telnet=Yes
Rlogin=No
PPP=No
SLIP=No
Host #n Addr=0.0.0.0
Host #n Text=
Immed Host=0.0.0.0
Immed Port=0
Immed Service=Telnet
Imm. Modem Pwd=secure3me
Imm Modem Auth=Yes
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3 Save your changes.

Note: Any characters (Table 6-2) other than \n and \t that have a single backslash (\) in
front of them are removed.

For example, you could enter

Welcome to\n\t\\Ascend Remote Server\\\Enter your user name:

to display the following on the terminal-server screen:

Welcome to

\\Ascend Remote Server\\

Enter your user name:

4 Set Prompt Format to Yes.

This is the field that determines whether you are able to use the multi-line format for the
terminal-server prompt. If Prompt Format is set to No, the MAX does not interpret the line
feed/carriage return character or the tab character.

5 Set the Login Timeout parameter.

This value is an integer representing a value from 0 to 300 seconds. The default value is
300 seconds.

Users are disconnected if they have not completed logging in when the number of seconds
set in the Login Timeout field has elapsed. A user has the total number of seconds
indicated in the Login Timeout field to attempt a successful login. The timer begins when
the login prompt appears on the terminal-server screen, and it continues (is not reset) when
the user makes unsuccessful login attempts.

6 To customize the password prompt, set the Password Prompt parameter.

This parameter specifies the prompt the terminal server displays when asking the user for
his or her password. You can specify up to 80 characters. The default value is
Password:.

7 Enter a prompt string in the 3rd Prompt parameter to specify a third prompt to follow the
login and password prompts.

You can specify up to 20 characters. The default value is null. If you accept the default, the
MAX does not display an additional prompt.

The remote terminal-server user can enter up to 80 characters after this prompt. The MAX
passes the information the user enters to the RADIUS server as an attribute called
Ascend-Third-Prompt. This attribute appears in the Access-Request packet. If the user
enters more than 80 characters, RADIUS truncates the data before assigning a value to the
Ascend-Third-Prompt attribute.

Table 6-2.Characters used in the terminal-server prompt specification

Character
combination

Description

\n Carriage return/line feed

\t Tab

\\ Displays a double backslash
(\\)



6-4 Preliminary November 29, 2000 MAX Security Supplement

Setting Up User Authorization
Setting up terminal-server security

The 3rd Prompt parameter does not apply if the Auth parameter has a value other than
RADIUS or RADIUS/LOGOUT. If authentication occurs through a local Connection
profile, and not through the RADIUS server, the MAX ignores the 3rd Prompt
specification.

8 Set the 3rd Prompt Seq parameter to First or Last to specify whether the additional prompt
appears at the beginning or the end of the login sequence.

The 3rd Prompt Seq parameter works with any authentication method except Auth=None.

The default is Last. The parameter is N/A if TS Enabled is set to No or 3rd Prompt is null.

The third-prompt feature works slightly differently depending on whether you specify that
it appear in the Last position (a prompt issued after the login and password prompts) or the
First position (a prompt issued before login and password prompts). For more complete
information, see “Understanding how the third login prompt works” on page 6-4.

9 Save your changes.

Sample prompts

Suppose you accept the default settings for the Login Prompt and Password Prompt
parameters, and specify the following setting for 3rd Prompt:

3rd Prompt=Password2>>

The terminal server displays the following prompts:

Login:

Password:

Password2>>

Understanding how the third login prompt works

You can configure a prompt by specifying the string that appears with the prompt and where
the prompt appears in the login sequence (first or last). A prompt can emulate an existing
terminal-server login prompt sequence, depending upon what you specify in the prompt string.

The third prompt feature works differently depending upon whether you select First or Last as
the value of the 3rd Prompt Seq parameter.

Similarities in the way the third prompt works in either First or Last position are:

• Both settings work with any value for the Auth parameter except Auth is set to None.

• User's input is passed to RADIUS with the authentication request as the value of the
Ascend-Third-Prompt RADIUS attribute.

Differences in the way the third prompt works, depending on whether 3rd Prompt Seq is set to
First or Last, are:

• The First prompt appears before Login & Password prompts, the Last prompt appears
after Login & Password prompt

• User's input is echoed in response to a First prompt and is not echoed in response to a Last
prompt.
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Restricting the use of terminal-server commands and protocols

To specify whether users can initiate Telnet, Rlogin, PPP, or SLIP sessions from the
terminal-server interface, proceed as follows:

1 Open the Ethernet > Mod Config > TServ Options menu.

2 Set the Telnet parameter to specify whether a user can start a Telnet session.

– Yes indicates that a user can begin a Telnet session. The default value is Yes.

– No indicates that a user cannot begin a Telnet session.

3 Set the Rlogin parameter to specify whether a user can initiate an Rlogin session.

– Yes indicates that a user can begin an Rlogin session.

– No indicates that a user cannot begin an Rlogin session. The default value is No.

4 Set the PPP parameter to specify whether a client can use asynchronous PPP.

– Yes indicates that a client can use asynchronous PPP.

– No indicates that a client cannot use asynchronous PPP.

The default value is No.

5 Set the SLIP parameter to specify whether a user can initiate a Serial Line IP (SLIP)
session.

SLIP is a protocol that enables your computer to send and receive IP packets over a serial
link.

– Yes indicates that a user can begin a SLIP session.

– No indicates that a user cannot begin a SLIP session. The default value is No.

6 Save your changes.

Dial-in calls with no login host specified in RADIUS

You can configure the MAX to accept dial-in calls when Login-Service is set to TCP-CLEAR
or Telnet and no Login Host is specified in the RADIUS users file. Such a configuration does
not apply to PPP encapsulated calls, because the MAX does not accept dial-in PPP calls with
the Login-Service set either to Telnet or TCP-CLEAR.

To set up the MAX to accept dial-calls when no login server is specified, set Auth TS Secure to
No in the Ethernet > Mod Config > Auth menu. The default is Auth TS Secure set to Yes,
which means the MAX drops dial-in calls if there is no login server and Login-Server is Telnet
or TCP-CLEAR.

Configuring per-user access to terminal-server commands

The Framed Only parameter in the Answer profile and the Connection profile enables you to
limit specific users to the PPP, SLIP, CSLIP, and Quit commands in the MAX terminal-server
interface.You can configure per-user access to the terminal-server commands in the Answer
profile or in the Connection profile:

• The Answer profile affects users who do not have a Connection profile, users with a
Name/Password profile, or RADIUS-authenticated users whose connections are built
partly with the Answer profile
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• The Connection profiles only affect individuals, each of whom can be assigned a specific
Connection profile

To configure per-user access to the terminal server:

1 Select Ethernet > Answer > Session Options or

Ethernet > Connections > a Connection profile > Session Options

2 Specify one of the following values for Framed Only:

– No (the default) specifies that terminal-server users connecting through this profile
have unlimited access to the terminal-server commands.

– Yes specifies that terminal-server users connecting through this profile only have
access to the PPP, SLIP, CSLIP, and Quit terminal-server commands. An attempt to
execute any other terminal-server command produces the following message:

Unauthorized terminal-server Command.

3 Save and exit the profile.

Dealing with unauthorized Telnet and terminal-server sessions

When a user activates a Security profile, the MAX generates a Syslog message notifying you
that the event occurred (if Syslog is enabled). A user can activate a Security profile in a Telnet
session or a serial-line COM port session by selecting the Security profile and specifying the
proper password. When a user activates a Security profile, new Syslog messages show the
name of the Security profile, the IP address of the Telnet client or the COM port number, and
the local IP address.

The EventSyslog message is at the notice level and it has one of the following formats:

^DP(assword)ASCEND: "profile_name" ... for remote_IP on local_IP

ASCEND: "profile_name" ... from COM_port on local_IP

• The profile_name argument specifies the name of the activated Security profile.

• The remote_IP argument specifies the IP address of the Telnet client.

• The local_IP argument specifies the local IP address of the MAX.

• The COM_port argument specifies the COM port number for the session.

On system login, the MAX does not generate a Syslog message for the Default Security
profile. But it does generate a Syslog message if the Default Security profile is accessed for
anything other than system login.

The following two messages signal that a Telnet client has enabled a Security profile:

Jan 10 10:05:17 eng-lab-141 ASCEND: "Full Access" security profile

enabled for 206.65.212.9 on 192.168.6.141.

Jan 10 10:07:26 eng-lab-141 ASCEND: "Default" security profile enabled

for 206.65.212.23 on 192.168.6.141.

The following message signals that a COM port user has enabled the Full Access profile:

Jan 10 10:03:52 eng-lab-141 ASCEND: "Full Access" security profile

enabled from com port 0 on 192.168.6.141.
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Restricting access to the Immediate Modem feature

The Immediate Modem feature enables local terminal-server users (who have not dialed into
the MAX and have not been authenticated) to Telnet to a MAX to access the unit’s modems, so
that they can place outgoing calls without going through MAX terminal-server interface. You
can choose to restrict access to the Immediate Modem feature on a per-user basis, or you can
specify a global password for all users. You can also disable call restriction for the Immediate
Modem feature, so that all users can place outgoing calls.

To use Immediate Modem service, users specify the port number configured in the Imm.
Modem Port parameter when opening a Telnet session to the MAX. For example, a user can
access a digital modem on port 5000 in a MAX unit named max1 by typing the following
command:

telnet> open max1 5000

When the modem responds, the user can begin entering AT commands to dial out.

Understanding per-user Immediate Modem access restriction

When per-user Immediate Modem is enabled, the MAX does the following:

1 Requests a login name before enabling any user to access the Immediate Modem feature.

2 Attempts to find a profile with the name provided by the user, looking first for a local
Connection profile, then for a simple Name/Password profile, and finally for a RADIUS
profile.

– If the MAX finds a matching profile, it prompts the user for the password (if any)
associated with the profile and verifies that the user enters the correct password.

– If no profile matching the name provided by the user can be found, the MAX rejects
the user and closes the Telnet session.

3 If the user enters the correct password, the MAX checks the Dialout-OK parameter of the
appropriate profile.

– If Dialout OK is set to Yes, the user can access the Immediate Modem feature.

– If the user gets the password wrong or the Dialout OK parameter is set to No, the
MAX rejects the user (with an appropriate message) and closes the Telnet session.

Understanding password restriction for Immediate Modem

The Immediate Modem password separately governs whether a user is allowed to use the
Immediate Modem functionality. If Telnet is password protected, a user must know the Telnet
password as well as the Immediate Modem password to dial out. To use Telnet but not the
dialout functionality, a user only needs to know the Telnet password.

Configuring access to the Immediate Modem feature

To restrict access to the Immediate Modem feature, proceed as follows:

1 Open the Ethernet > Mod Config > TServ Options menu.

2 Set TS Enabled to Yes.

If TS Enabled is set to No, the Imm. Modem Pwd field is N/A and you cannot specify a
password for the Immediate Modem feature.
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3 Set the Modem Dialout parameter to specify whether the user can use this MAX unit’s
V.34 digital modems to dial out.

– Modem Dialout set to Yes permits terminal-server users access to the digital modems.

– Modem Dialout set to No denies terminal-server users access to the digital modems.

The default value is No.

4 Set the Immediate Modem parameter to enable or disable the Immediate Modem feature.

– Immediate Modem set to Yes enables the Immediate Modem feature.

– Immediate Modem set to No disables the Immediate Modem feature.

The default value is Yes.

5 Set the Imm. Modem Access parameter to specify whether the access is restricted on a
global or per-user basis, or unrestricted.

– None indicates that call restriction is disabled, and that all users can place outgoing
calls.

– Global indicates that a single password provides access to dialout (set in the Imm.
Modem Pwd parameter). Any user who knows this password can place outgoing
calls.

– User (the default) indicates the MAX requires a login before any user can access the
Immediate Modem dialout feature. The MAX attempts to match the user’s name and
password to a name and a receive password in a Connection profile, Name/Password
profile, or RADIUS users profile. If the user is authenticated by matching a
Name/Password profile, the Name/Password profile must point to a Connection
profile for the setting of the Dialout OK parameter.

6 Specify a password in the Imm. Modem Pwd. parameter if you set Imm. Modem Access to
Global,

This parameter is N/A if Imm. Modem Access is set to None or User.

Note: To enable unlimited access to the Immediate Modem feature, set Imm. Modem
Access to None. Do not set Imm. Modem Access to Global and leave the Imm. Modem
Pwd parameter null.

7 Close the Ethernet > Mod Config > TServ Options menu.

8 Open the Telco options submenu of the appropriate Connection profile.

9 Set the Dialout OK parameter to specify whether modem dialout is enabled for this
Connection profile.

– Dialout OK set to Yes specifies that the Connection profile allows modem dialout.

– Dialout OK set to No specifies that the Connection profile does not allow modem
dialout. Dialout OK set to No is the default.

Disconnecting a user’s terminal-server session

You can disconnect, by session ID, a user who establishes a Telnet connection with the MAX.
The disconnect code that results is identical to the RADIUS disconnect code, enabling you to
track all administrative disconnects.
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Displaying a list of active terminal-server sessions

To display a list of active user sessions on a MAX, enter:

show users

Note: At the terminal-server prompt, show users displays a list of user sessions active on a
system. Each user session is identified by the sessionID, which is followed by additional
information about the session. The Show Users command is included in the online help for the
Show command.

You can detect multiple concurrent sessions for the same user with the sessionActiveTable in
the Management Information Base (MIB).

Killing an active terminal-server session

To terminate a Telnet session, enter the following command line at the terminal-server prompt:

kill session ID

where session ID is the session ID as displayed by the terminal-server Show Users
command. The disconnect reason for the session is reported as DIS_LOCAL_ADMIN.

The active Security Profile must have Edit All Calls set to Yes. If Edit All Calls is set to No,
the following message appears when you issue the kill command:

Insufficient security level for that operation.

If you issue the kill command without the session ID argument, the following message
appears:

kill command requires an argument

When the session is properly terminated, a message similar to the following appears:

Session 216747095 killed.

When the session is not terminated, a caution similar to the following appears:

Unable to kill session 216747095.

Setting up SNMP security
Simple Network Management Protocol (SNMP) provides a way for computers to share
networking information. SNMP recognizes two types of communicating devices: agents and
managers. An agent (such as the MAX) provides networking information to a manager
application running on another computer. The agents and managers share a database of
information, called the Management Information base (MIB).

A trap is a mechanism in SNMP for reporting system change in real time. To report system
change, the MAX sends a traps-PDU across the Ethernet interface to the SNMP manager. A
complete list specifying the events that cause the MAX to send a traps-PDU appears in the
Enterprise Traps MIB.

You can set up SNMP security in the following ways:

• Specify passwords for SNMP managers with access to the MAX.
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• Set up SNMP traps.

• Restrict the hosts that can issue SNMP commands.

Table 6-3 shows the parameters for protecting access to SNMP on the MAX. The values
shown are examples.

Password-protecting SNMP

An SNMP manager application residing on a workstation on the local or remote network can
access management information, set alarm thresholds, and change some settings on the MAX.
To password protect this type of network access, you must assign the Read and Read/Write
SNMP community strings. To assign Read and Read/Write SNMP community strings, proceed
as follows:

1 Open the Ethernet > Mod Config > SNMP Options menu.

2 Set the Read Comm parameter to specify the Read community string.

This string authenticates an SNMP manager accessing the MAX to perform read
commands, that is, the Get and Get Next commands. The Get command requests
information. The Get Next command enables an SNMP manager to obtain a table of
information, such as a routing table. After you enter a string for the Read Comm
parameter, users must supply it to use the Get and Get Next commands.

3 Set the R/W Comm parameter to specify the Read/Write community string.

This string authenticates an SNMP manager accessing the MAX to perform read and write
commands, that is, the Get, Get Next, and Set commands. The Set command enables an
SNMP manager to change information maintained by the MAX. After you enter a string

Table 6-3. SNMP security parameters

Location Parameters with sample values

Ethernet > Mod Config > SNMP Options Read Comm=new-string
R/W Comm=unique-string
Security=Yes
RD Mgr1=10.21.4.5
RD Mgr2=10.21.4.7
RD Mgr3=10.21.4.55
RD Mgr4=10.21.4.103
RD Mgr5=10.21.4.64
WR Mgr1=10.21.4.11
WR Mgr2=0.0.0.0
WR Mgr3=0.0.0.0
WR Mgr4=0.0.0.0
WR Mgr5=0.0.0.0

Ethernet > SNMP Traps > any SNMP Traps
profile

Name=
Alarm=Yes
Port=No
Security=No
Comm=
Dest=0.0.0.0



Setting Up User Authorization
Setting up SNMP security

MAX Security Supplement Preliminary November 29, 2000 6-11

for the R/W Comm parameter, users must supply it to use the Get, Get Next, and Set
commands. You can use the original SNMPv1 definition of the community string (a string
of octets that is compared to a similar string in the receiving SNMP entity). If the string in
the packet received exactly matches a community string in the receiving entity, the packet
is considered “authentic.”

The defaults for SNMP v1 (without authentication) are:

Ethernet > Mod Config > SNMP Options > Read Comm=public

Ethernet > Mod Config > SNMP Options > R/W Comm=write

If you wish to use SNMP authentication, you use a new version of the Read/Write
community string as follows:

Ethernet > Mod_config > SNMP Options > R/W Comm=name|secretkey

where:

– name is the name you want to assign to the read-write community name.

– secretkey is the alphanumeric key used for authentication.

– | (vertical bar/pipe) separates the name from the secretkey.

This setting causes the MAX to require SNMP SET REQUEST packets to be
authenticated, with secretkey as the shared (but not transmitted) secret.

The data, time, and hash values are transmitted with the packet. This enables the
management station and MAX to verify that the packet has been produced by an
authorized system and that the packet has not been altered or significantly delayed in
transmission.

The MD5 hash ensures a high likelihood that the packet was generated by a system that
knows the secret authentication key, while the time variables guarantee a high likelihood
that an attacker did not collect an authenticated packet and retransmit it after a significant
delay.

Note: You cannot turn SNMP write off, so you must set a secret R/W Comm string. The
default R/W Comm string is write. Anyone who has used a product probably knows
this default string, so it does not provide any real security.

4 If you are using authenticated SNMP, configure the SNMP management station to
communicate with a MAX through authenticated SNMP (as described in “Configuring the
SNMP manager to use SNMP authentication” ).

5 Save your changes.

Configuring the SNMP manager to use SNMP authentication

To communicate with a unit that has been configured to use authenticated SNMP, an SNMP
management station must construct an SNMP packet in the new format for the Read/Write
community string, including the secret key:

name|secretkey

If you configure the unit to use authenticated SNMP, it does not accept packets from an SNMP
management station that uses the string format without the vertical bar/pipe.
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Setting up SNMP traps

To configure parameters related to SNMP traps security, proceed as follows:

1 Open the Ethernet > SNMP Traps menu.

2 Open a blank SNMP Traps profile.

3 For the Name parameter, specify the SNMP manager to which the MAX sends
traps-PDUs.

You can specify up to 31 characters. The default value is null. The value you specify
becomes the name of the profile.

4 Set the Alarm parameter to specify whether the MAX sends a traps-PDU to the SNMP
manager when an alarm event occurs.

Alarm events are defined in RFC 1215 and include the following:

– coldStart—The MAX started up from a power-off condition.

– warmStart—The MAX started up from a power-on condition, typically by a system
reset.

– linkDown—A WAN link or Ethernet interface has gone offline.

– linkUp—A WAN link or Ethernet interface has come online.

You can specify either Yes or No for the Alarm parameter. Yes specifies that the MAX
traps alarm events. No specifies that the MAX does not trap alarm events. The default
value is Yes.

5 Set the Port parameter to specify whether the MAX traps serial host port state changes and
sends traps-PDUs to the SNMP manager.

The MAX can record the following serial host port events:

– portInactive

– portDualDelay

– portWaitSerial

– portHaveSerial

– portRinging

– portCollectDigits

– portWaiting

– portConnected

– portCarrier

– portLoopback

– portAcrPending

– portDteNotReady

You can specify either Yes or No for the Port parameter. Yes specifies that the MAX traps
serial host port state changes. No specifies that the MAX ignores serial host port state
changes. The default value is No.

6 Set the Security parameter to specify whether the MAX traps these events:
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– authenticationFailure—Occurs when authentication has failed. See RFC-1215 for a
full explanation of this event.

– consoleStateChange—Occurs when a VT100, Palmtop, or Telnet port changes its
state.

– portUseExceeded—Occurs when the port exceeds the maximum number of DS0
minutes set by the MAX DS0 Mins parameter in the Port profile.

– systemUseExceeded—Occurs when the MAX exceeds the maximum number of DS0
minutes set by the MAX DS0 Mins parameter in the System profile.

You can specify either Yes or No for the Security parameter. Yes specifies that the MAX
traps the events. No specifies that the MAX does not trap the events. The default value is
No.

7 Set the Comm parameter to specify a community name.

The string you specify becomes a password that the MAX sends to the SNMP manager
when an SNMP trap event occurs. The password authenticates the sender identified by the
IP address in the IP Adrs parameter.

For the community name, you can enter an alphanumeric string of up to 31 characters. The
default value is null. To turn off SNMP traps, leave the Comm parameter blank and set
Dest to 0.0.0.0.

8 Set the Dest parameter to specify the IP address of the SNMP manager to which the MAX
sends traps-PDUs.

Specify an IP address in dotted decimal notation. An IP address consists of four numbers
from 0 to 255, separated by periods. If a subnet mask is in use, you must specify it.
Separate a subnet mask from the IP address with a slash. The default value is 0.0.0.0/0.

The MAX ignores any digits in the IP address hidden by a subnet mask. For example, the
address 200.207.23.1/24 becomes 200.207.23.0. To specify a route to a specific host, use a
mask of 32.

The Dest parameter does not apply if the MAX does not support IP (Route IP=No) or if
Combinet encapsulation is in use (Encaps=COMB).

9 Save your changes.

Restricting the hosts that can issue SNMP commands

The MAX is an SNMP-enabled device that supports a variety of MIBs. For large networks,
you should specify which stations can use SNMP manager applications to initiate read or
read/write access to those MIBs.

You can specify up to five IP hosts that can read traps and other information from the unit, and
five hosts that can access MIB read-write access. The MAX checks the version and community
strings before making source IP address comparisons.

To restrict the hosts that can issue SNMP commands, proceed as follows:

1 Open the Ethernet > Mod Config > SNMP Options menu.

2 Make sure that the Security parameter is set to Yes.

This parameter specifies that the MAX must compare the source IP address of packets
containing SNMP commands against a list of qualified IP addresses.

3 Specify the IP addresses of hosts that have SNMP read permission.

For example, you might enter the following settings:
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RD Mgr1=10.1.2.3

RD Mgr2=10.1.2.4

RD Mgr3=10.1.2.5

RD Mgr4=10.1.2.6

RD Mgr5=10.1.2.7

If the Security parameter is set to Yes, only SNMP managers at the specified IP addresses
can execute the SNMP Get and Get Next commands.

4 Specify the IP addresses of hosts that have SNMP write permission.

For example, you might enter the following settings:

WR Mgr1=10.9.8.1

WR Mgr2=10.9.8.2

WR Mgr3=10.9.8.3

WR Mgr4=10.9.8.4

WR Mgr5=10.9.8.5

If the Security parameter is set to Yes, only SNMP managers at the specified IP addresses
can execute the SNMP Get, Get Next, and Set commands.

5 Save your changes.

Support for SNMPv3 User-based Security Model

MAX units with the Network Management option enabled support security enhancements
based on the SNMPv3 User-based Security model (USM), which is compliant with RFC 2574.

To verify that the Network Management option is installed on your MAX unit, check the Sys
Options status window. If you have purchased and installed the Network Management option,
the status window indicates that it is installed as in the following example:

00-100 Sys Option

K56 Slot Card Only
Not Installed
Net Mgmt Installed

For complete information about using status windows, see the documentation that came with
the unit.

Limitations

Support for the Priv Protocol parameter is not included with this release. This parameter has a
default setting of N/A. You cannot change this setting.

Required SNMP Options profile settings

The Message Type parameter specifies the SNMP version(s) that the MAX unit’s SNMP agent
supports. You can specify one of the following values:

• V1-and-V3 (the default)—The SNMP agent supports both the SNMPv1 and SNMPv3
protocols.

• V1-only—The SNMP agent discards SNMPv3 messages.
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• V3-only—The SNMP discards SNMPv1 messages.

The Security Level parameter specifies whether or not the MAX unit verifies the user’s
Security Level settings. The unit compares the Security Level field in the incoming message to
the one specified on the unit. If the Security Levels do not match, the unit sends a report
message. You can specify one of the following settings:

• None—The MAX unit does not require a security level check for the incoming message.
None is the default.

• Auth-Nopriv—The MAX unit requires a Security Level of auth-nopriv in the
incoming message.

• Auth-Priv—The MAX unit requires a Security Level of auth-priv in the incoming
message.

For the MAX unit to accept SNMPv3 USM messages, you must configure the Message Type
and Security parameters (in the SNMP Options profile) to their default settings. The Message
Type parameter has a default setting of v1-and-v3 while the Security parameter has a
default setting of none. For example:

90-B00 Mod Config

SNMP Options...

Read Comm=public
R/W Comm Enable=Yes
R/W Comm=write
Security=No
RDmgr1=0.0.0.0
...

RD Mgr5=0.0.0.0
WR Mgr1=0.0.0.0
...

WR Mgr5=0.0.0.0
Queue Depth=0
Message Type=v1-andv3
Security Level=none

SNMPv3 USM Users profile

To enable SNMPv3 USM security features, you must configure at least one SNMPv3 USM
Users profile. You can enable up to nine profiles on the MAX unit. For example:

90-B00 SNMPv3 USM Users

90-B01
90-B02
90-B03
90-B04
90-B05
90-B06
90-B07
90-B08
90-B09
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For each SNMPv3 USM Users profile, you must specify a profile name and set the Active
parameter to Yes. You must also specify a password if the Auth Protocol parameter is set to any
setting other than none. For example:

90-B01

Name=Boston1
Passwd=******
Active=Yes
R/W Access=No
Auth Protocol=md5-auth
Priv Protocol=N/A

In the preceding example, the user has specified Name and Passwd values because the Auth
Protocol setting is md5-auth. Specification of a Password is not required if the Auth Protocol
parameter specifies none. In most cases, you can accept the default settings for the other
parameters in the SNMPv3USM Users profile.

Setting up a Domain Name System (DNS)
DNS is a TCP/IP service that enables you to specify a symbolic name instead of an IP address.
A symbolic name consists of a username and a domain name using the format
username@domain name. The username corresponds to the host number in the IP
address; the domain name corresponds to the network number in the IP address. A symbolic
name might be steve@abc.com or joanne@xyz.edu.

DNS maintains a database of network numbers and corresponding domain names on a domain
name server. When you use a symbolic name, DNS translates the domain name into an IP
address, and sends it over the network. When the Internet service provider receives the
message, it uses its own database to look up the username corresponding to the host number.

You can set up two types of DNS configurations:

• Global l DNS, in which you specify the DNS server(s) known to all MAX users on
connected local interfaces.

• Client DNS, in which you specify the DNS server(s) known to MAX users for which a
specify Connection profile has been applied.

Table 6-4 lists the parameters you can set.
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Setting global DNS parameters

To set global DNS parameters, proceed as follows:

1 Open the Ethernet > Mod Config > DNS menu.

2 Set the Domain Name parameter to specify a primary domain name to use for lookups.

The MAX searches for the DNS Server(s) in the Domain Name parameter first, and then
in the domain specified in the Sec Domain Name parameter.

3 Set the Sec Domain Name parameter to specify a secondary domain name to use for
lookups.

4 Set the Pri DNS parameter to specify the IP address of the primary domain name server
for use on connected local interfaces.

The address consists of four numbers from 0 to 255, separated by periods. The default
value is 0.0.0.0. Accept this default if you do not have a domain name server.

5 Set the Sec DNS parameter to specify the IP address of the secondary domain name server
for use on connected local interfaces.

The address consists of four numbers from 0 to 255, separated by periods. The default
value is 0.0.0.0. Accept this default if you do not have a secondary domain name server.

The MAX uses the secondary server only if the primary one is inaccessible. The Sec DNS
parameter applies only to Telnet and raw TCP connections running under the MAX unit’s
terminal-server interface.

6 Set List Attempt to Yes.

DNS can return multiple addresses for a hostname in response to a DNS query, but it does
not include information about availability of those hosts. Users typically attempt to access
the first address in the list. If that host is unavailable, the user must try the next host, and
so forth. However, if the access attempt occurs automatically as part of immediate
services, the physical connection is torn down when the initial connection fails.

The DNS List Attempt feature helps the MAX avoid tearing down physical links. The user
can try one entry in the DNS list of hosts when logging in through Telnet from the

Table 6-4. DNS parameters

Location Parameters with sample values

Ethernet > Mod Config > DNS Domain Name=abc.com
Sec Domain Name=xyz.com
Pri DNS=10.2.3.56/24
Sec DNS=10.2.3.107/24
List Attempt=No
List Size=6
Client Pri DNS=101.10.10.1
Client Sec DNS=101.10.10.2
Allow as Client DNS=Yes
Sec Domain Name=xyz.com

Ethernet > Connections > any
Connection profile > IP
Options

Client Pri DNS
Client Sec DNS
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terminal server or immediate Telnet, and, if that connection fails, the user can try each
succeeding entry.

You can specify one of the following settings:

– Yes specifies that the MAX enables a user to try the next host in the DNS list if the
first Telnet login attempt fails.

– No turns off the List Attempt feature.

The default value is No.

7 If you set List Attempt to Yes, set the List Size parameter.

8 The List Size parameter specifies the maximum number of hosts the MAX can list in
response to a DNS query. You can specify a number from 0 to 35. The default value is 6.

Setting client DNS parameters

To set up client DNS, in which connection-specific DNS parameters are applied, proceed as
follows:

1 Open the Ethernet > Connections menu.

2 Open a Connection profile

3 Open the IP Options menu.

4 Set the Client Pri DNS parameter.

5 Set the Client Sec DNS parameter.

The default value is 0.0.0.0. Accept this default if you do not have a secondary client DNS
server.

6 Set the Allow As Client DNS parameter to Yes or No.

– Yes enables WAN clients to use local DNS servers.

– No disables WAN clients from using local DNS servers.

No is the default.

Example of DNS configuration

This sample shows how to specify two local DNS servers and enable the DNS list feature.

1 Open the Ethernet > Mod Config > DNS menu.

2 Specify your domain name.

3 Specify the IP addresses of a primary and secondary DNS server, and turn on the DNS list
attempt feature. For example:

Mod Config
DNS…

Domain Name=abc.com
Pri DNS=10.2.3.56/24
Sec DNS=10.2.3.107/24
List Attempt=Yes

4 Save your changes.
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Disabling remote management access
To prevent an operator from accessing the MAX from a remote unit by means of AIM or MP+
remote management, set System > Sys Config > Remote Mgmt to No. Proceed as follows:

1 Open the System > Sys Config menu.

2 Set Remote Mgmt to No.

3 Exit and save your changes.

For related information about remote management, see the chapter about system
administration in the Network Configuration Guide for your MAX.

Password-protecting Telnet access
You can assign a Telnet password to restrict operators from accessing the MAX across the
network from a remote PC running Telnet. Proceed as follows:

1 Open the Ethernet > Mod Config menu.

2 Set the Telnet PW parameter.

Specify up to 20 characters. Any user who initiates an incoming Telnet session to the
MAX must supply this password before the Telnet session is established.

If a user initiates the Telnet session from the WAN, the connection must first be
authenticated as specified in a Connection profile.

For additional information about restricting Telnet in the terminal-server interface. see
“Restricting Telnet, raw TCP, and Rlogin access to the terminal server” on page 3-27.

3 Set the Telnet Security parameter to specify whether or not you allow a single
authentication process when users initiate a telnet session.

4 Save your changes.

Note: The Telnet password does not automatically grant access to the Immediate Modem
feature, which allows a user to dial out through the MAX modems without going through the
terminal-server interface. For more information, see “Restricting access to the Immediate
Modem feature” on page 6-7.

Understanding secure Dynamic Bandwidth Allocation
Dynamic Bandwidth Allocation (DBA) enables the MAX to increase bandwidth as needed and
drop bandwidth when it is no longer required. MP+ is the only PPP-based encapsulation
method that supports DBA.

When the system adds additional channels, the MAX must authenticate each one. You can
secure each circuit by one of the following methods:
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Authentication
method

Description

Static passwords Before the MAX dials a new circuit, it prompts the user to enter a
static, reusable password as specified in the Connection profile,
Password profile, RADIUS user profile, or TACACS/TACACS+
profile. To prevent intruders from capturing the password as it travels
across the WAN, you can specify that the MAX use the Challenge
Handshake Authentication Protocol (CHAP). This protocol uses
encryption to protect the password and verify the identity of the caller.

For information about specifying a static password and requiring
CHAP authentication in the MAX configuration interface, see
“Configuring PAP, CHAP, or MS-CHAP for PPP, MP, and MP+ calls”
on page 3-17. For information about configuring static passwords and
CHAP in RADIUS, see the TAOS RADIUS Guide and Reference.

Dynamic passwords Using PAP-TOKEN authentication, the MAX can require a user to
specify a one-time-only password, generated by a security-card server,
for each additional channel.

For information about setting up PAP-TOKEN authentication in the
MAX configuration interface, see “Requesting PAP-TOKEN
authentication” on page 5-6. For information about setting up
PAP-TOKEN authentication in RADIUS, see the TAOS RADIUS
Guide and Reference.

Combination of static
and dynamic
password

In the MAX configuration interface, you can indicate that the user
need only specify a dynamic password for the initial channel, and that
all other channels are authenticated by CHAP. Whenever the MAX
adds channels to a PPP or MP+ call using PAP-TOKEN-CHAP
authentication, the calling unit sends the encrypted value of Aux Send
PW (found in the Connection profile used to dial the call), and the
answering unit checks this password against the value of Recv Auth
(in a Connection profile) or Ascend-Receive-Secret (in a RADIUS
user profile). The answering unit receives the password when the first
channel of the call connects.

For details about setting up PAP-TOKEN-CHAP authentication in the
MAX configuration interface, see “Requesting PAP-TOKEN-CHAP
authentication” on page 5-7. For information about setting up
PAP-TOKEN-CHAP authentication in RADIUS, see the TAOS
RADIUS Guide and Reference.
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Cached passwords You can configure the MAX to reuse a password dynamically
generated during session initiation. In this case, both the user and the
MAX cache the password. Then, when the MAX needs to add
bandwidth, the user provides the CHAP-encrypted password
automatically and the MAX uses an internal key to authenticate the
additional channels. You can specify a timeout value for the cached
password, or configure the MAX to maintain the password throughout
the session.

For details about setting up cached passwords in the MAX
configuration interface, see “Requesting CACHE-TOKEN
authentication” on page 5-7. For information about setting up cached
passwords in RADIUS, see the TAOS RADIUS Guide and Reference.

Authentication
method

Description
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continued

PPP encapsulation, 3-18
RADIUS in DBA, 6-20
systemwide parameters, 3-18
TACACS, 3-44

CHAP. See Challenge Handshake Authentication
Protocol

CLID ANI, 3-6
CLID authentication, 3-6

WAN, 3-3, 3-6, 3-24
CLID Fail Busy parameter, 3-7
CLID Timeout Busy parameter, 3-7
CLID. See Calling Line ID
Client DNS configuration, 6-16
Client Pri DNS parameter, 6-18
Client Sec DNS parameter, 6-18
coldStart alarm (SNMP), 6-12
COMB parameter (Combinet), 3-28
Combinet authentication, 3-2

Connection profile, 3-30
overview, 3-29
PAP, CHAP, and MS-CHAP, 3-16
system parameters, 3-29

Combinet authentication parameters, 3-28
Comm parameter, 6-13
community string

Read Comm, 1-6
R/W Comm, 1-6

Compare parameter, 4-6
Configuration Profile

SNMP Options menu, 6-10
TServ Options menu, 6-2

Connection profiles, 6-6
and ARA authentication, 3-34
and static IP addresses, 3-39
ARA authentication, 3-33
authentication, 3-3
callback security, 3-12
CLID authentication, 3-6
Combinet, 3-29
dial-in calls using ARA, 3-35
dynamic IP addresses, 3-39
IP addresses, 3-37
local vs. remote authentication server, 3-3
outgoing calls, configuring, 3-22
PAP, CHAP, or MS-CHAP, configuring, 3-19
terminal server authentication, 3-24, 3-26
used as a template, 3-27
used as a template for Name/Password profile, 3-21
X.25, 3-37

connections
dialing to a secure site, 5-13

connections, continued
to remote network from DOS workstation, 5-13
to remote network from terminal server, 5-13
to remote network from UNIX workstation, 5-14
to remote network from Windows workstation, 5-14

consoleStateChange trap, 6-13
CryptoCard token card, 5-2

D

data filters
for dropping packets, 4-3
local Ethernet, specifying for, 4-11
profiles, specifying, 4-10
sample filter for IP spoofing, 4-11
WAN interface, specifying, 4-10

DBA. See Dynamic Bandwidth Allocation
default password, 2-7

full access, 1-2
Default profile, 1-2
default read-write string, 1-6
Default Security profile, 1-5, 6-6

password, 1-5
Defender server, 5-1
Defender server. See Digital Pathways Defender server
DES Gold token card, 5-2
DES Silver token card, 5-2
Dest Node Adrs parameter, 4-10
Dest parameter, 6-13
Dial # parameter, 2-2, 2-5, 3-12
dial-in access restriction, 3-21, 3-35
Dialout OK parameter

Combinet, 3-29
Immediate Modem, 6-8
PPP, MP, and MP+, 3-18

DigiPass token card, 5-2
Digital Pathways Defender server

configuring, 5-23
terminal server authentication, 3-42

direct ACE authentication
configuring, 5-17
described, 5-3

disconnecting a user’s Telnet session, 6-2
DNIS, 3-2
DNS. See Domain Name System
DO commands

restricting usage, 2-3
Domain Name System (DNS)

Client DNS configuration, 6-16
example configuration, 6-18
global DNS configuration, 6-16
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Domain Name System (DNS), continued
parameters, 6-18
setting connection-specific parameters, 6-18
setting up, 6-16
specifying global parameters, 6-17
symbolic name, 6-16

Domain Name System (DNS) parameters, 6-17
Download parameter, 2-3, 2-5
Dst Adrs parameter, 4-7
Dst Mask parameter, 4-7, 4-8
Dst Network Adrs parameter, 4-10
Dst Port # parameter, 4-7, 4-9
Dst Port Cmp parameter, 4-7, 4-9
Dst Socket Cmp parameter, 4-10
dual-port calls, 3-14
Dynamic Bandwidth Allocation (DBA), 3-15, 3-16

and cached passwords, 6-21
and dynamic passwords, 6-20
and MP+, 6-19
cached dynamic passwords, 6-20
overview, 6-19
PAP-TOKEN, 6-20
static passwords, 6-20

dynamic IP addressing, 3-38, 3-39

E

Edit All Calls parameter, 2-2
Edit All Ports parameter, 2-2
Edit Cur Call parameter, 2-2
Edit Line parameter, 2-1
Edit Own Call parameter, 2-2
Edit Own Port parameter, 2-2
Edit Security parameter, 2-1
Edit System parameter, 2-1
Encaps parameter, 3-29, 3-36

PAP or CHAP, 3-18
encapsulation, 3-22

and ARA, 3-32
and Combinet, 3-29
dial-in terminal server calls, 3-23
in authentication, 3-4
incoming PAP, CHAP, and MS-CHAP outgoing calls,

3-17
outgoing PAP, CHAP, and MS-CHAP calls, 3-22
PPP, 3-18
PPP and modem calls, 3-25
PPP modem calls, 3-25

encrypted password, 5-7
encryption for ACE authentication, 5-18
encryption, and CHAP, 3-17

Enigma Logic, 5-8
Enigma Logic SafeWord server, 5-1
Exp Callback parameter, 3-12
Expect Callback parameter, 3-11

F

Fallback parameter, 3-3
field service operations, restricting, 2-6
Field Service parameter, 2-3
field service, restricting, 2-3
filters

conditions and rules, 4-4
for inbound and outbound packets, 4-4
how packets are compared, 4-2
input and output, 4-4
overview, 4-1
profiles, 4-3

filters. See call filters
filters. See packet filters
filters. See data filters
firewalls, 4-2
first profile, 1-5
Forward parameter, 4-6, 4-7
Framed Only parameter, 6-5
Full Access profile, 1-2, 2-6

activating, 1-3
changing password, 1-4

Full Access Security profile, 2-7
super-user, 1-4

G

generic filter parameters, 4-6
generic filters, 4-4

conditions, defining, 4-5
Get command, 1-6, 6-10
Get Next command, 1-6, 6-10

H

Host #n Addr parameter, 3-27, 3-28, 6-2
Host #n Text parameter, 3-27, 6-2
Host #n Text parameter (terminal server), 6-2
host port diagnostics

restricting, 2-2
hosts (Telnet), 3-27
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I

ICMP redirects, 1-7
ID Auth parameter, 3-3, 3-7, 3-24
IETF RFC1356 specification, 3-36
Imm Modem Auth, 6-2
Imm. Modem Access parameter, 6-8
Imm. Modem Pwd, 6-2
Immed Host parameter, 3-36

terminal server, 6-2
Immed Port parameter, 6-2
Immed Service parameter, 3-36

terminal server, 6-2
Immediate Modem

configuring, 6-7
description, 6-7
parameter, 6-8
password, 6-7

Immediate Modem feature, 6-7
Immediate modem process, 6-7
Immediate Service, 3-26
incoming calls

and callback security, 3-11
and CLID authentication, 3-5
and IP address spoofing, 3-40
and serial AIM ports, 3-14
authenticating, 3-3
filtering, 4-4
PAP, configuring, 3-17
setting up security card authentication, 5-4

Initial Scrn parameter, 3-25, 6-2
input filters

specifying and activating, 4-4
inverse multiplexing authentication, 3-14
IP

hosts, 6-13
password profile, 3-19
routing over X.25, 3-36
spoofing, preventing, 3-19, 3-40, 4-11

IP address authentication, 3-2
IP address parameters, 3-38
IP addresses, 3-37

dynamic, 3-38, 3-39
requiring that a caller accept from the MAX, 3-40
spoofing, preventing, 3-19, 3-40, 4-11
static, 3-38, 3-39

IP filter parameters, 4-7
IP filter tests, 4-2
IP filters, 4-4

complex security example, 4-14
conditions, defining, 4-7
samples, 4-11
spoofing, preventing, 4-11

IP filters, continued
Web server, 4-14

IPX filters, 4-4
conditions, defining, 4-9

ISDN modems, 3-23

K

kill command, 6-9

L

LAN Adrs parameter, 3-38
LCP. See Link Control Protocol
Length parameter, 4-6
Link Control Protocol (LCP), 3-13

negotiation, CBCP, 3-13
linkDown alarm (SNMP), 6-12
linkUp alarm (SNMP), 6-12
List Attempt parameter, 6-17, 6-18
local authentication, 3-4
local Connection profile, 3-3
Local Profile First parameter, 3-3
Login Prompt parameter, 3-26, 6-2, 6-3
Login Timeout parameter, 6-3
Login-Service, 3-25

M

Management Information Base (MIB), 1-6, 6-9, 6-13
Mask parameter, 4-6
MAX

Defender server, configuring, 5-23
operations, restricting, 2-6
TACACS server, configuring, 3-43
TACACS+ server, configuring, 3-43

Max Call Duration parameter, 3-29
MD5 digest, 3-17
MIB. See Management Information Base
Microsoft Challenge Handshake Authentication

Protocol (MS-CHAP), 3-2
Microsoft Website, 3-17
outgoing calls, 3-22
parameters, 3-18
PPP encapsulation, 3-18
PPP, MP, and MP, configuring, 3-17
PPP, MP, or MP+, 3-15
system parameters, 3-18

Microsoft Website (for MS-CHAP), 3-15, 3-17
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N

Microsoft’s Callback Control Protocol (CBCP), 3-11,
3-12

LCP negotiation, 3-13
negotiation steps, 3-13
RFC 1570, 3-13

modem calls
and PPP encapsulation, 3-25
and terminal server security, 3-23

Modem Dialout parameter, 6-8
More parameter, 4-6
MP, 3-2, 3-6
MP multichannel links, 3-16
MP parameter (PAP or CHAP), 3-18
MP+, 3-2, 3-6
MP+ authentication

and DBA, 3-16, 6-19
explained, 3-15

MPP
encapsulation, 3-15
parameter (PAP or CHAP), 3-18

MS-CHAP. See Microsoft Challenge Handshake
Authentication Protocol

N

name and password authentication, 3-2
Name parameter, 2-1, 6-12

Combinet, 3-28
outgoing PAP, CHAP, or MS-CHAP calls, 3-22
Password profile, 3-41

Name/Password profile, 3-27, 3-33
PAP or CHAP, 3-18
preventing dial-in ARA calls, 3-35
preventing dial-in PPP, MP, and MP+ calls, 3-21

NAS (Network Access Secret), 3-16
network address, 4-9
NextCode mode, 5-15
node address, 4-9
Normal Call Clearing, 3-7

O

ODI driver, 5-9
Offset parameter, 4-6
Operations parameter, 2-1
outgoing calls

and PAP-TOKEN, 5-6
filtering, 4-4
MS-CHAP, 3-22
PAP-TOKEN-CHAP, 5-7
parameters, 3-22

outgoing calls, continued
setting up security card authentication, 5-4
specifying a dial-out connection, 5-6

Own Port Diag parameter, 2-3

P

Packet Assembler/Disassembler (PAD), 3-36
packet filters

applying, 4-5
described, 4-1
Ethernet traffic, 4-5
generic, 4-1
IP filter, 4-1
IPX filter, 4-1
TCP sessions, 4-2

PAD. See Packet Assembler/Disassembler
PAP. See Password Authentication Protocol
PAP-TOKEN

authentication, 5-3
dial-out to secure site, 5-6
TACACS, 3-44

PAP-TOKEN-CHAP
ACE server, 5-3, 5-22
authentication with security cards, 5-4
requesting, 5-7
TACACS, 3-44

parameters
for incoming connections using PAP or CHAP, 3-18
for outgoing calls using PAP or CHAP, 3-22

Passwd parameter, 2-1, 3-26, 6-2
password

*SECURE*, 1-5
changing Full Access, 1-4
default full access, 1-2
Default Security profile, 1-5
encrypted, 5-7
Telnet, 1-6

Password Authentication Protocol (PAP)
authentication, 3-2
authentication, incoming calls, 3-17
explained, 3-16
MP encapsulation, 3-18
MPP encapsulation, 3-18
Name/Password profile, 3-18
outgoing calls, requesting, 3-22
parameters, 3-18
PPP, MP, and MP+ calls, 3-15
systemwide parameters, 3-18
TACACS, 3-44

Password Host parameter (DNS), 5-5
Password Port parameter (authentication server), 5-5
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Password profile, 3-19
address restriction parameters, 3-41
and Connection profiles, 3-19
and RADIUS user profiles, 3-19
configuring, 3-20, 3-34

Password profile address restriction parameters, 3-41
Password Prompt parameter, 3-26, 6-2
Password Reqd parameter, 3-4, 3-28, 3-29
Password Server parameter, 5-5
password,default, 2-7
passwords

banner text for, 5-8
cached (in DBA), 6-21
CHAP-encrypted in DBA, 6-21
DBA, 6-20
dynamic, 6-20
dynamic (in DBA), 6-20
dynamically generating in DBA, 6-21
Immediate Modem, 6-7
NextCode mode, 5-15
RADIUS, 6-20
serial port, 3-15
SNMP, 6-10
specifying, 3-26
Telnet, 6-19

PIN
changing, 5-17
new PIN mode, 5-16
passcode, 5-15
requiring, 5-16
server-chosen, 5-17
user-chosen, 5-16

Pool #n Count parameter, 3-39
Pool #n Start parameter, 3-39
Pool Only parameter, 3-18, 3-39, 3-41
Pool#1 Count parameter, 3-18, 3-41
Pool#1 Start parameter, 3-18, 3-41
port 5000, and Immediate Modem, 6-7
Port Diag menu, 2-5
port diagnostics, restricting, 2-3
ports

serial inverse multiplexing (AIM), 3-14
source port for remote authentication, 3-45
TACACS/TACACS+ Auth port, 3-44

PPP
asynchronous sessions, 3-25
authentication, 3-2, 3-15
encapsulation, 3-18
encapsulation (modem calls), 3-25
parameter (PAP, CHAP, or MS-CHAP), 3-18
restricting access, 6-2, 6-5

PPP parameter, 6-5
Pri DNS parameter, 6-17

private packet-switched network (PSPDN), 3-36
privileges, read-only, 1-5
profile

See also specific authentication types, 3-5
Answer, 1-6
default, 1-2
Default Security, 1-5
Security, 2-1
Security, configuring, 2-3

Profile Reqd parameter, 3-36
Combinet, 3-28
PAP, CHAP, or MS-CHAP, 3-18

profiles
Answer, 3-4
Call, 2-2
filters, 4-10
Full Access, 1-2
how used in authentication, 3-3
incoming sessions, 1-6
Local and Remote authentication, 3-4
Name/Password, 3-4
Security, 1-1

Prompt Format parameter, 6-3
prompts

examples, 6-4
Password Prompt parameter, 6-3
terminal server, 3-26

Protocol parameter, 4-7, 4-8
PSPDN. See private packet-switched network

R

RADIUS, 3-4, 3-25
and packet filters, 4-1
authentication server, 3-42
daemon, 3-42
PAP, CHAP, or MS-CHAP in DBA, 6-20
PAP-TOKEN authentication in DBA, 6-20
passwords, 6-20
retrieving updates, 1-8
server, 3-3
terminal server connections, 6-2
user profile, 3-4, 3-19
user profile passwords in DBA, 6-20
user profiles (PAP, CHAP, and MS-CHAP), 3-21, 3-35

raw TCP (TCP-clear), 3-27
Read Comm, 1-6
Read Comm parameter, 6-10
read-only privileges, 1-5
Recv Auth parameter, 3-4, 3-18, 3-36
Recv PW parameter, 3-18, 3-22, 3-29, 3-37, 3-41
remote authentication types

supported, 3-4



Index-8 Preliminary November 29, 2000 MAX Security Supplement

Index
S

Remote Conf parameter (Telnet, raw TCP, or RLogin),
3-28

remote management
disabling access, 6-19
restricting, 2-4

remote profile, 3-3
Remove service icon, 5-11
Restore Cfg command, 2-3, 2-5
restricting access, 6-2

Rlogin, 6-2
TCP, 6-2
Telnet, 6-2

retries
call, 1-7

RFC 1570
Microsoft’s Callback Control Protocol (CBCP), 3-13

Rlogin, 6-2
restricting access, 3-27, 6-2, 6-5

Rlogin parameter, 6-5
Rlogin session, 6-5
Route IP parameter, 3-38
R/W Comm, 1-6
R/W Comm parameter, 6-10

S

SafeWord MultiSync MultiSync token card
authentication, 5-2

SafeWord server, 5-1, 5-8
SafeWord SofToken token card, 5-2
Save Cfg command, 2-3, 2-5
Sec DNS parameter, 6-17
SecureNet Key token card, 5-2
SecurID ACE authentication without RADIUS, 5-15
security

ACE/Server authentication, 5-3, 5-15
callback, 3-11, 3-12
configuring basic, 1-3
IP filters, 4-14
PAP-TOKEN-CHAP, 5-3
qualifying hosts by IP address, 6-13
restricting access, 6-2
Rlogin, 6-2
SNMP, 1-6
spoofing, 3-19
spoofing, preventing, 3-40
TCP, 6-2
Telnet, 6-2
terminal server, 6-1
token card, 5-1

security card authentication, 3-5, 5-4
ActivCard, 5-2

security card authentication, continued
and RADIUS, 5-1
and SecurID ACE, 5-3
CACHE-TOKEN, 5-4
configuring, 5-1
CryptoCard, 5-2
DES Gold, 5-2
DES Silver, 5-2
DigiPass, 5-2
explained, 5-1
for outgoing calls, 5-4
methods, 5-3
PAP-TOKEN, 5-3
PAP-TOKEN-CHAP, 5-4
parameters, 5-5
SafeWord MultiSync, 5-2
SafeWord SofToken, 5-2
SecureNet Key, 5-2
security cards, 5-2
types, 5-2
WatchWord, 5-2

Security Dynamics ACE server, 3-43, 5-1, 5-8
Security menu, 1-1, 2-1
Security parameter, 3-25, 6-2

SNMP, 6-12, 6-13
terminal server, 3-26

Security profile, 1-1, 2-1, 6-6
activating, 2-6
configuring, 2-3
parameters, 2-1
password, 6-6

Send Auth parameter, 3-22
Send PW parameter, 3-22, 3-29, 5-7
Serial Line IP (SLIP), 6-5
serial port

authentication, 3-14
password, 3-15

Set command, 1-6, 1-8
Set password command, 5-13
shell settings

ACE authentication, 5-18
shell string, limits, 5-19
Simple Network Management Protocol (SNMP)

disabling traps, 6-13
Options menu, 6-10
password protection, setting up, 6-10
qualifying IP source, 6-13
read-write community string, changing, 1-6
restricting the hosts that can issue SNMP commands,

6-13
security parameters, 6-9
security setup, 6-9
Traps menu, 6-10
Traps parameters, 6-10
traps, setting up, 6-9, 6-12
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SLIP parameter, 6-2, 6-5
SLIP. See Serial Line IP
SNMP

traps, 6-13
SNMP SET REQUEST packets, 6-11
SNMP Traps profile, 6-12
SNMP. See Simple Network Management Protocol
socket number, 4-9
SofToken authentication, 5-2
spoofing

Pool Only on PPP, MP, and MP+, preventing, 3-19
preventing with filters, 4-11
preventing with Password profiles, 3-40

Src Adrs parameter, 4-7
Src Mask parameter, 4-7
Src Network Adrs parameter, 4-10
Src Node Adrs parameter, 4-10
Src Port # parameter, 4-7
Src Port Cmp parameter, 4-7, 4-8
Src Port parameter, 4-8
Src Socket # parameter, 4-10
Src Socket Cmp parameter, 4-10
static passwords in DBA, 6-20
Station parameter, 3-29, 3-36

PAP or CHAP, 3-18
string errors, 5-21
super-user, 1-2, 1-4
super-user profile, 2-7
support for V.34, V.42, V.120, and V.110, 3-31
symbolic name, 6-16
Sys Diag parameter, 2-2
sysConfigRadiusCmd, 1-8
sysConfigRadiusStatus, 1-8
syslog message, 6-6
system diagnostics, restricting, 2-2
systemUseExceeded trap, 6-13

T

TACACS server, 3-3, 3-25, 3-42
CACHE-TOKEN, 3-44
CHAP, 3-44
MAX, configuring, 3-43
PAP, 3-44
PAP-TOKEN, 3-44
PAP-TOKEN-CHAP, 3-44

TACACS+, 3-4
TACACS+ server, 3-3, 3-42

configuring, 3-43

TCP
restricting access, 6-2
sessions, packet filters, 4-2

TCP Estab parameter, 4-7, 4-9
TCP-clear, 3-25
TCP-clear (raw TCP), 3-27
Telnet, 3-25, 6-2

access password protection, 6-19
and callback security, 3-11
disconnecting a user session, 6-2
host access, 3-27
password, assigning, 1-6
restricting access, 6-2, 6-5
session, 6-5

Telnet parameter, 6-5
Telnet PW, 1-6
template built from Answer or Connection profiles, 3-27
terminal adapters (ISDN modems), 3-23
terminal server

authentication, 3-2, 3-24, 3-26
authentication, setting up, 3-23
connecting to remote network, 5-13
connection, 6-1
disconnecting a user session, 6-8
Host #n Addr parameter, 3-28
hosts, 3-27
kill command, 6-9
modem call security, 3-23
parameters

Host #n Addr, 6-2
kill (user session), 6-9

Password Prompt parameter, 6-3
per-user authentication, 3-24
RADIUS connections, 6-2
restricting Telnet, raw TCP, and Rlogin access, 3-27
restricting use of command and protocols, 6-5
security parameters, 3-26, 6-2
security, setting up, 6-1
specifying passwords, 3-26
TServ Options, 6-2
turning operation on or off, 6-2

terminal server session
disconnecting user, 6-8

Toggle Scrn parameter, 6-2
token passwords, 5-5
traps-PDU, 6-9
TS Enabled parameter, 3-26, 6-2
Type parameter, 4-7, 4-9

U

UDP protocol, 5-5
Uninstall service icon, 5-12
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UNIX APP server installation, 5-12

Upd Rem Cfg, 1-8

Upload parameter, 2-3, 2-5

User Busy response from MAX, 3-7

user shell settings (ACE), 5-18

users
authenticating, 3-1
RADIUS user profile, 3-4

V

V.110, 3-16, 3-23

V.120, 3-16, 3-23

V.34, 3-16

V.42, 3-16

Valid parameter, 4-5

Value parameter, 4-6

W

WAN
CLID authentication, 3-3, 3-6, 3-24
data filters, 4-10
Telnet session, 6-19
Telnet sessions, assigning, 1-6
X.25 authentication, 3-36

WAN Options, 3-18, 3-32, 3-39, 3-41

warmStart alarm (SNMP), 6-12

WatchWord token card, 5-2

Windows NT MS-CHAP support, 3-15

Windows NT, APP server utility, 5-11

X

X.25
authentication parameters, 3-36
authentication, setting up, 3-36, 3-37
IP routing, 3-36
PAD

X.25 authentication
WAN, 3-36

X25/IP parameter, 3-36

X25/PAD parameter, 3-36

xas-nt.exe (APP Server for Windows NT), 5-11

xas-w95.exe (APP Server for Windows 95), 5-11
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