Subject: (usr-tc) Radius question

From: Corneliu Rudeanu <[email-masked]>
Date: Wed, 13 Oct 1999 02:43:25 +0000

I was really surprised to see how HARC deals with the radius packet
identifier.

RFC states as clear as posibile: "For retransmissions where the contents
are identical, the Identifier MUST remain unchanged.".

Yet watching (monitor radius) the id-s of the packets being retransmited I
found that hiperArc (4.2.29) assigns diferrent id for the packets being
re-sent to radius server for the same accounting request.

My question: how is suposed a Radius server to identify the duplicates?

TIA,
Corneliu

-
 To unsubscribe to usr-tc, send an email to "[email-masked]"
 with "unsubscribe usr-tc" in the body of the message.
 For information on digests or retrieving files and old messages send
 "help" to the same address.  Do not use quotes in your message.

---

From: Aaron Nabil <[email-masked]>
Date: Wed, 13 Oct 1999 03:17:28 +0000

Corneliu Rudeanu writes...
>re-sent to radius server for the same accounting request.

Hah!  It's much better than that!  (Note the date, too!)

>From: Aaron Nabil <[email-masked]>
>Subject: (usr-tc) HiperArc BUG, doesn't increment identifier after re-transmit
>Date: 14 Jun 1998 16:58:15 -0700 (PDT)
>
>
>The HiperArc has a nasty Radius bug.
>
>If a packet get lost in transit or for some other reason is never 
>acknoweldged, the HiperArc increments the identifier and tries 
>sending it again after the timeout period.
>
>But later, when it comes time to send another request, it has 
>"forgotten" that it previously incremented the identifier and merrily 
>uses the last one again!

Not only does it incorrectly increment the identifier, it then
goes on to re-use the same identifier again later!  Yes, this is
so incredibly broken it's not even imaginable that it hasn't
been fixed.  But it hasn't.  

>My question: how is suposed a Radius server to identify the duplicates?

The Radius server is supposed to contact the System Administrator
and get him to purchase products from a vendor that knows how to 
read a RFC, or, failing that, at least fixes problems when they
are pointed out to them.

-- 
Aaron Nabil

-

---

From: Corneliu Rudeanu <[email-masked]>
Date: Wed, 13 Oct 1999 04:44:29 +0000

> read a RFC, or, failing that, at least fixes problems when they

Thanks for the prompt response. And my apollogies for re-opening the
subject.

I do agree with you: things should be good. Yet things are bad. I guess I
am not the only one looking for a solution. Does some kind of checksum
over acct-session-id, username, status-type worth any thrust? 

Even this kind of 'hand made' solution would help me.
Any advice?

TIA,
Corneliu Rudeanu

-

---

From: Ed <[email-masked]>
Date: Wed, 13 Oct 1999 07:51:31 +0000

We were referred to FUNK Software's Steel-Belted Radius (by a 3com
technician). Does anyone have any experience in this and is it better than
the current 6.0.9 3com Radius? Hard to believe it could be worse...

Any problems known?

Ed

----- Original Message -----
From: Corneliu Rudeanu <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, October 12, 1999 10:49 PM
Subject: Re: (usr-tc) Radius question

TIA,
Corneliu Rudeanu

-

-

---

From: "Lon R. Stockton, Jr." <[email-masked]>
Date: Wed, 13 Oct 1999 08:00:39 +0000

Don't know anything about that one, but if you're going to buy something,
I'd suggest taking a look at Radiator. It's written in perl, so it's not
the fastest you can get, but you get the source and can make it do
*anything* you want. Not that you have to; I've seen a feature request
hit the support mailing list and the guys who wrote the package mentioning
that they've written it and tossed it on the ftp site...within *hours*.

Supports USR style VSAs and interfaces to your favorite sql or odbc
database out of the box.

-

---

From: Ed <[email-masked]>
Date: Wed, 13 Oct 1999 08:19:03 +0000

Perl? not sure I want to touch that one ;-)

Ed

----- Original Message -----
From: Lon R. Stockton, Jr. <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, October 13, 1999 2:09 AM
Subject: Re: (usr-tc) Funk Radius

-

-

---

From: Brian <[email-masked]>
Date: Thu, 14 Oct 1999 05:25:52 +0000

> Perl? not sure I want to touch that one ;-)

perl is a big plus though.  It can run on many platforms and is fully
extensable.  The code is very efficient and clean, you would be impressed
trust me.

>  "help" to the same address.  Do not use quotes in your message.

-----------------------------------------------------
Brian Feeny (BF304)     [email-masked]   
318-222-2638 x 109	http://www.shreve.net/~signal      
Network Administrator   ShreveNet Inc. (ASN 11881) 	      

-

---

From: Brian <[email-masked]>
Date: Thu, 14 Oct 1999 05:25:57 +0000

> *anything* you want. Not that you have to; I've seen a feature request

I will second Radiator.  As for speed.........well, use the radpwtst
program that comes with it, you will be impressed.  I know of ISP's with
80,000+ users using Radiator, and they don't seem to have any
problems.....

-

---

From: Brian Hitchcock <[email-masked]>
Date: Thu, 14 Oct 1999 05:49:03 +0000

anyone have a URL for these radius servers?

Brian Hitchcock

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Brian
Sent: Wednesday, October 13, 1999 10:20 PM
To: [email-masked]
Subject: Re: (usr-tc) Funk Radius

-

-

---

From: Brian <[email-masked]>
Date: Thu, 14 Oct 1999 05:59:50 +0000

radiator	http://www.open.com.au/radiator

-

---

From: "Lon R. Stockton, Jr." <[email-masked]>
Date: Thu, 14 Oct 1999 07:15:50 +0000

> anyone have a URL for these radius servers?

<http://www.open.com.au/radiator/> for Radiator

-