Subject: (usr-tc) hiperarc + freeradius woes

From: jason <[email-masked]>
Date: Tue, 30 Oct 2001 20:45:22 +0000

I'm not sure how active this list still is but here goes ::

I'm having a strange problem with getting Framed-IP-Address to work with a
HiperArc Total Control Unit.  It seems that even though the
Framed-IP-Address is set, it won't respect that and assigns a dynamic, when
my freeradius server is in action.  It works however when talking to the old
Cistron server.

The othe thing is that my good ole portmaster 2 works fine with either..
These hiperarcs seem to be finicky beasts and I imagine that either I'd not
seeing something it wants or there is some configureation setting that we're
not aware of that needs to be tweaked

Here's a copy of what I recieve when I do a radtest to either server..
localhost is the freeradius and svr4 is the cistron.

bash-2.05# ./radtest [email-masked] password localhost 5 testing123
Sending Access-Request of id 57 to 127.0.0.1:1645
        User-Name = "[email-masked]"
        Password = "2\006\n\323\316\371G\3334`*\315\033\020I\010\355"
        NAS-IP-Address = radius1.egix.net
        NAS-Port-Id = "5"
rad_recv: Access-Accept packet from host 127.0.0.1:1645, id=57, length=68
        Service-Type = Framed-User
        Framed-Protocol = PPP
        Framed-MTU = 1500
        Framed-Routing = None
        Framed-Compression = Van-Jacobson-TCP-IP
        Framed-IP-Address = 209.131.199.209
        Framed-IP-Netmask = 255.255.255.255
        Idle-Timeout = 0
bash-2.05# ./radtest [email-masked] password svr4.iei.net 5 testing123
Sending Access-Request of id 61 to 209.131.216.202:1645
        User-Name = "[email-masked]"
        Password = "\241`s\307r\330rQQ\2244x\233\314\344\367\334"
        NAS-IP-Address = radius1.egix.net
        NAS-Port-Id = "5"
rad_recv: Access-Accept packet from host 209.131.216.202:1645, id=61,
length=68
        Service-Type = Framed-User
        Framed-Protocol = PPP
        Framed-MTU = 1500
        Framed-Routing = None
        Framed-Compression = Van-Jacobson-TCP-IP
        Framed-IP-Address = 209.131.199.209
        Framed-IP-Netmask = 255.255.255.255
        Idle-Timeout = 300

Any help or insight would be greatly appreciated.

    -jason

-
 To unsubscribe to usr-tc, send an email to "[email-masked]"
 with "unsubscribe usr-tc" in the body of the message.
 For information on digests or retrieving files and old messages send
 "help" to the same address.  Do not use quotes in your message.

---

From: Marshall Morgan <[email-masked]>
Date: Thu, 01 Nov 2001 01:50:43 +0000

The results are the same minus the idle timeout value - what about changing
it from 0 to 999 or 300?

Marshall Morgan

Internet Doorway, Inc (aka NETDOOR)
http://www.netdoor.com

601.969.1434 x28 | 800.952.1570 x28 | 601.969.3629 x28 | Fax 601.969.3838
----- Original Message -----
From: "jason" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, October 30, 2001 12:38 PM
Subject: (usr-tc) hiperarc + freeradius woes

-

---

From: [email-masked]
Date: Thu, 01 Nov 2001 03:49:51 +0000

You have left a few items out of the problem description..

1) Whats the code version?
2) Have you tried removing the netmask? Its redundant information.
3) If possible, post a HEX trace of packet.. I would suspect some NULL
padding by the RADIUS server might confuse the HARC.

-M

-

---

From: jason <[email-masked]>
Date: Thu, 01 Nov 2001 04:01:53 +0000

Freeraduis-0.3 vs Cistron-1.6.4 ( i believe )

I have not tried it without the netmask.  I can try it when I have a chance,
but I'm curious why/how this would help?

I've attached tcpdumps from of packets from both radius servers.. Radius2 is
a freeradius server and SVR4 is a cistron server..
The packet dumps are for exactly identical accounts, so there is no
difference in idle timeout for this case..

Thanks

-j

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, October 31, 2001 7:47 PM
Subject: Re: (usr-tc) hiperarc + freeradius woes

> > > my freeradius server is in action.  It works however when talking to
the
> > old
> > > These hiperarcs seem to be finicky beasts and I imagine that either
I'd
> > not

---

From: List <[email-masked]>
Date: Thu, 01 Nov 2001 04:15:14 +0000

Hii..!!
Sorry for this off topic from this list.. but maybe someone can help
me..
Where I find to download manuals to 3com netbuilder router ( model 300
)..
Where I find one specific 3com mailing list about 3com routers??

Thanks if someone help me..

Thanks again..

-