Subject: RE: (usr-tc) badmodems.pl

From: "Stainforth, Matthew" <[email-masked]>
Date: Sat, 16 Oct 1999 05:47:10 +0000

if your time is correct on the server where the report is generated it's
pretty trivial.

$time = localtime(time());
print "Report generated $time\n";

yields

Report generated Fri Oct 15 04:38:28 1999

> -----Original Message-----
> From:	K Mitchell [SMTP:[email-masked]]
> Sent:	Saturday, October 16, 1999 12:20 AM
> To:	[email-masked]
> Subject:	RE: (usr-tc) badmodems.pl
> 
> At 11:42 PM 10/15/99 -0300, you wrote:
> >
> >You could rewrite part of the script to make it output HTML directly to
> >STDOUT so that it generates your stats real-time.  I'm doing this with
> some
> >other SNMP scripts I wrote but, depending on the stats, you might be
> sitting
> >there a while waiting for it to do something.  If you want to run it
> >periodically you might want to consider using WINAT to schedule it if
> you're
> >on NT.
> 
> One other thing, I'd like to include the date/time the report was
> generated. Is there an OID for getting this from the ARC or NMC?
> 
> -- 
> Kirk Mitchell-General Manager        [email-masked]
> Keystone Connect                     Unlock Your World
> Altoona, PA   814-941-5000      http://www.keyconn.net
> 
> 
> -
>  To unsubscribe to usr-tc, send an email to "[email-masked]"
>  with "unsubscribe usr-tc" in the body of the message.
>  For information on digests or retrieving files and old messages send
>  "help" to the same address.  Do not use quotes in your message.

-
 To unsubscribe to usr-tc, send an email to "[email-masked]"
 with "unsubscribe usr-tc" in the body of the message.
 For information on digests or retrieving files and old messages send
 "help" to the same address.  Do not use quotes in your message.

---

From: K Mitchell <[email-masked]>
Date: Sat, 16 Oct 1999 06:09:03 +0000

>print "Report generated $time\n";

That got it, Thanks.

-

---

From: [email-masked]
Date: Sat, 16 Oct 1999 18:50:18 +0000

I'm using 3Com S/A 6.0.90 for now. Any tips on cleaning up the database? It
is getting quite large. TIA!!!!!

Mike Moore
BCSNet

-

---

From: [email-masked]
Date: Sun, 17 Oct 1999 13:03:36 +0000

Mike,

What I do, since S/A yet supports SQL, is I have an SQL server and two 
linked tables for events and calls.  I have an ASP job which I run 
periodically which copies records out of the normal calls and events 
tables into the SQL server calls and events tables, then deletes the 
records in the Access database.  All you need to do then is periodically 
use the MS Access database compress option to shrink the database down 
to something resonable.  Of course if 3Com would ever support an SQL 
server, this would be a mute point.

Jeff Binkley
ASA Network Computing 

U>I'm using 3Com S/A 6.0.90 for now. Any tips on cleaning up the
U>database? It is getting quite large. TIA!!!!!

U>Mike Moore
U>BCSNet

U>-
U> To unsubscribe to usr-tc, send an email to "[email-masked]"
U> with "unsubscribe usr-tc" in the body of the message.
U> For information on digests or retrieving files and old messages send
U> "help" to the same address.  Do not use quotes in your message.

CMPQwk 1.42-21 9999

-

---

From: [email-masked]
Date: Mon, 18 Oct 1999 16:53:44 +0000

There is a macro for purging the contents of the CALLS and EVENTS table in
the database.  It sends output to a CSV text file.

The macro is under Server Setup->Advanced->Database Maintenance.

Afterwords, it makes sense to compact the database.  I recommend saving a
backup copy before and after this operation.

Dominic

-

---

From: [email-masked]
Date: Mon, 18 Oct 1999 16:55:39 +0000

On the UNIX platform, both Oracle and Postgresql are supported.

-