Subject: (usr-tc) Bad Modem monitoring

From: Eric Billeter <[email-masked]>
Date: Tue, 17 Aug 1999 13:36:24 +0000

If you have PERL running

AND

You have MRTG running

AND

you want to be able to monitor modem call failures on the Hiper DSP cards

Email me.  I have some scripts in beta currently and would like your
feedback.  When completed I will release them to the lists.

Eric Billeter
Internet Engineer
Cable One, Inc.

[email-masked]
602-364-6462

-
 To unsubscribe to usr-tc, send an email to "[email-masked]"
 with "unsubscribe usr-tc" in the body of the message.
 For information on digests or retrieving files and old messages send
 "help" to the same address.  Do not use quotes in your message.

---

From: Jamie Orzechowski <[email-masked]>
Date: Tue, 17 Aug 1999 14:11:57 +0000

I would love to have these scripts ... I have mrtg monitoring my calls on
the DSP's ... would like a failiure graph ...

----- Original Message -----
From: Eric Billeter <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, August 17, 1999 7:31 PM
Subject: (usr-tc) Bad Modem monitoring

-

---

From: Eric Billeter <[email-masked]>
Date: Tue, 17 Aug 1999 15:27:46 +0000

What I have now is an external script which polls all modems in the chassis
(DSPs)

It then outputs to a file in HTML format.
You can see a result of the output at http://24.116.0.46\phx-fail.htm
Modems which are failing would be highlighted in red.

I am next going to work on trying to alert via email when a modem is in
errored status, and also rework the error conditional.  I have only worked
on
this today, and I figure on giving it about another day this week.

Because the SNMP walk takes a considerable amount of time I am running this
via a scheduled process and outputting the information to a file, rather
than having it dynamic and run when the page is requested.  Also this will
make the alerting function more practical.

If there are any perl programmers who would like to work on this with me it
would be greatly appreciated.  I am not a perl programmer, although I can do
a pretty good job at cutting and pasting from other scripts.  The current
scripts use some of the modules included with MRTG, as well as a hacked up
version of my hiperdsp.pl script for the snmp walk.

Plug in the community, ip address, and output file into the script then run
it.
Please let me know the results or if you have any suggestions.

Thanks
Eric Billeter
Internet Engineer
Cable One, Inc.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jamie Orzechowski
Sent: Tuesday, August 17, 1999 5:09 PM
To: [email-masked]
Subject: Re: (usr-tc) Bad Modem monitoring

----- Original Message -----
From: Eric Billeter <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, August 17, 1999 7:31 PM
Subject: (usr-tc) Bad Modem monitoring

-

---

From: Jamie Orzechowski <[email-masked]>
Date: Tue, 17 Aug 1999 15:34:41 +0000

my "bad" or "high pitched sound" modem problem has disappeared since I have
flashed the test code (2.0.70) from 3com ... I have not had one problem with
it since I got it up and running on 15 DSP's last week ... if anyone has a
problem with high pitched sound I would recommend contacting a 3com tech for
the code ...

----- Original Message -----
From: Eric Billeter <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, August 17, 1999 9:20 PM
Subject: RE: (usr-tc) Bad Modem monitoring

-

---

From: Eric Billeter <[email-masked]>
Date: Wed, 18 Aug 1999 07:28:26 +0000

Here is an updated version with mail notification.

I am using ntsendmail.pm which is available at
You will need to place ntsendmail.pm in your \perl\lib directory.

http://www.alliancestudio.com/tk/ntsendmail/

Modify the values in the script for each site you want to monitor

$ENV{"NTsendmail"} = "My.mailserver.com";       #Enter your Mail Server Here

my $community="public";                         # Your community String
my $router = "127.0.0.1";                       # IP Address of NMC
my $outputfile = "modem-fail.htm";              # File to output to
my $location = "Phoenix";                       # Location Descriptor
my $sender = "tech\@mycompany.com";             # Mail From (use \@ in mail
address)
my $recipient = "tech\@mycompany.com";          # Mail To (use \@ in mail
address)
my $subject = "$location modems";               # Mail Subject

For errored status I'm using 15% for my threshold.  You can change it on
this line.

		if (@callfail[$i-1] > (@callok[$i-1])*.15) {

Again.. if there are any perl guru's out there who could clean this up it
would be appreciated.

Thanks

Eric Billeter
Internet Engineer
Cable One, Inc.