Subject: (usr-tc) OID for span line in HiperDSP?

From: Jason Englander <[email-masked]>
Date: Tue, 07 Mar 2000 07:01:05 +0000

Anyone know the OID to check up/down/loop/whatever of a T1 plugged into a
HiperDSP?

  Thanks,
  Jason

-- 
Jason Englander <[email-masked]>
Systems Administrator - InterLink L.C.

-
 To unsubscribe to usr-tc, send an email to "[email-masked]"
 with "unsubscribe usr-tc" in the body of the message.
 For information on digests or retrieving files and old messages send
 "help" to the same address.  Do not use quotes in your message.

---

From: Yevgeniy Kruglov <[email-masked]>
Date: Tue, 07 Mar 2000 07:34:23 +0000

Jason,

snmpwalk with 1.3.6.1.2.1.10.18.6.1.10 OID should do it.

Best regards,
Yevgeniy

-

---

From: Jason Englander <[email-masked]>
Date: Tue, 07 Mar 2000 08:36:44 +0000

On Mon, 6 Mar 2000, Yevgeniy Kruglov wrote:

Thanks!  Any idea what the possible values are?  ie. 1 = up, 0 = down?, 2
= loopback?  (I'd rather not unplug one to find out <grin>)

  Jason

-

---

From: Mike Andrews <[email-masked]>
Date: Thu, 09 Mar 2000 20:10:16 +0000

It's a bit mask.  1 is no alarm, 32 is red alarm, 128 is a loopback at the
near end, and so on.  You want to see a value of 1 (only bit 0 set).

Here's a fragment of Perl code I have that checks T1 status on a DSP -- it
was easier to paste this in than try to explain each bit.  :)  (This
doesn't work on a Dual PRI/T1 card, by the way).

      my ($alarm) = &ma_snmp::snmpget ($chassname,
         $usr3com_cfg::nmc_ro_communities{$chassname}, 
         "1.3.6.1.2.1.10.18.6.1.10.$t1");
      print "[No Alarm] " if $alarm & 1;
      print "[Far-End LOF (YELLOW)] " if $alarm & 2;
      print "[Near-End Sending LOF] " if $alarm & 4;
      print "[Far-End AIS] " if $alarm & 8;
      print "[Near-End AIS] " if $alarm & 16;
      print "[Near-End LOF (RED)] " if $alarm & 32;
      print "[Near-End LOS] " if $alarm & 64;
      print "[Near-End Looped] " if $alarm & 128;
      print "[E1 TS16 AIS] " if $alarm & 256;
      print "[Far-End TS16 LOMF] " if $alarm & 512;
      print "[Near-End TS16 LOMF] " if $alarm & 1024;
      print "[Near-End Testcode] " if $alarm & 2048;
      print "[??] " if $alarm & 4096;

Mike Andrews (MA12) * [email-masked] * http://www.bit0.com/
VP, sysadmin, & network guy, Digital Crescent Inc, Frankfort KY
Internet services for Frankfort, Lawrenceburg, Owenton, Shelbyville
"Don't sweat the petty things, and don't pet the sweaty things."

-

---

From: Jason Englander <[email-masked]>
Date: Fri, 10 Mar 2000 03:34:43 +0000

>       print "[??] " if $alarm & 4096;

Thanks!  That'll save some time...

I ran a commandline snmpwalk of that OID on the NMC card and got this:

transmission.18.6.1.10.1025 = 1
transmission.18.6.1.10.2025 = 1
transmission.18.6.1.10.3025 = 1
transmission.18.6.1.10.4025 = 1
transmission.18.6.1.10.5025 = 1
transmission.18.6.1.10.6025 = 1

Then I unplugged the first HiperDSP's T1 (FYI: a channelized T1 - Robbed
Bit is set) and got this:

transmission.18.6.1.10.1025 = 100
transmission.18.6.1.10.2025 = 1
transmission.18.6.1.10.3025 = 1
transmission.18.6.1.10.4025 = 1
transmission.18.6.1.10.5025 = 1
transmission.18.6.1.10.6025 = 1

Any idea what 100 is?  Looks to me like it should be showing 64, no?

  Jason

-

---

From: Jeff Mcadams <[email-masked]>
Date: Fri, 10 Mar 2000 14:33:29 +0000

Thus spake Jason Englander

>Any idea what 100 is?  Looks to me like it should be showing 64, no?

Again, its a bitmask.  64+32+4=100  So, you've got Near End Loss Of
Signal, Near End Loss Of Framing (Red Alarm), and Near End Sending Loss
of Framing Signal.
-- 
Jeff McAdams                            Email: [email-masked]
Head Network Administrator              Voice: (502) 966-3848
IgLou Internet Services                        (800) 436-4456

-

---

From: Mike Andrews <[email-masked]>
Date: Fri, 10 Mar 2000 21:18:10 +0000

> Any idea what 100 is?  Looks to me like it should be showing 64, no?

100 = 64 + 32 + 4. :)  You're got 3 alarm conditions at once.  You're both
sending and receiving LOF if the T1 isn't plugged in...

-

---

From: Jason Englander <[email-masked]>
Date: Fri, 10 Mar 2000 23:12:07 +0000

> sending and receiving LOF if the T1 isn't plugged in...

Thanks guys, I think I just needed a little knock to the head to get the
"oh yeah...".

  Jason

-