Subject: RE: [USR-TC] HELP: Lightning HiPerDSP

From: Joel - Fox Computers <[email-masked]>
Date: Wed, 04 Sep 2002 02:37:45 +0000

Assuming your card isn't in loopback, the Loopback/D-Alarm light is red when you're running CT1's and your DSP is configured for PRI.  No D-channel = D-Alarm.  Changing the Signal Mode to "robbed bit" should take care of that.  Keep in mind, after you make those settings, you have to save to NVRAM, and usually my experience has been that you have to give the card a hardware reset to make all the setting changes take effect.

The easiest way to rule out a problem with that DSP is to try a different one.  It may have not actually gotten hit by lightning, but rather may have just died from the power going on and off.  In fact, your DSP failing may have caused the problem with your HDSL box, instead of the other way around.  Don't know how common it is with DSP's, but I've seen enough other hardware die from that - (for example: a server that's been running for over year without an error, shut it down to blow out the cooling fans, and on startup a hard drive died; a 2-week-old HP Netserver got shutdown for the weekend and on Monday morning barfed up it's $1400 RAID controller, etc)

Another tip - someone told me this along the way - if you've got a DSP that you're not using - don't keep it in the chassis - they can go bad just sitting there.  Configure it, have it ready to go, and put it in a static bag on a shelf.  

To be overly cautious, I have an older chassis hanging in the rack not hooked up to power or anything.  It's got an old 486 NMC and a 70amp power supply in it, and that's where I keep my "spare parts".  In the event of a complete system failure (unlikely, but if it can happen, then it will happen to me) I can power up that old chassis and use it on a temporary basis.

Just my thoughts,

Joel

-----Original Message-----
From: Support [mailto:[email-masked]]
Sent: Tuesday, September 03, 2002 7:07 PM
To: [email-masked]
Subject: Re: [USR-TC] HELP: Lightning HiPerDSP

I agree.  Except that getting that second card configured has been a
problem with it's second alarm light that won't go out - the LPBK/D-ALM
light.
I did try cloning the settings from the first card at one point and saved
them to
the second, but that didn't kill that other light, so I kinda just left it
at that.  I should
have followed it up more at the time, so that I would know for sure now, but
I
didn't.

----- Original Message -----
From: "Joel - Fox Computers" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, September 03, 2002 5:46 PM
Subject: RE: [USR-TC] HELP: Lightning HiPerDSP

If it were me, I would get your backup card configured and give it a try.
In the event your DSP that was plugged in IS blown - I would think you would
want to have the second able to go online at a minute's notice, anyway.

Personally - I have 2 DSP's online and in use, and I keep 3 others
completely configured and ready to run (not that I need that many backups,
just planning for future expansion).  In fact, at one time or another, I've
had all 5 cards online just for the sake of making sure they work.  If it
happened to me, the first thing I would have done was plug in one of my
other known-good DSP's.

Just my opinion.

Joel

-----Original Message-----
From: Support [mailto:[email-masked]]
Sent: Tuesday, September 03, 2002 6:12 PM
To: [email-masked]
Subject: Re: [USR-TC] HELP: Lightning HiPerDSP

OK.  I'll try this.  When it first went out, we got dead air answer.  When I
plugged the T1 into the older equipment and only four modems answered, it
reasoned that the problem was on the T1.  Especially since cycling power to
our HDSL box fixed everthing on our old equipment.  However, when we went
back to the HiperDSP, it now totally missed the card - cycles past it like
it wasn't there.

I also tried swaping the backs of my two HiperDSP cards today.  I figured
that if lightning got though the HDSL modem and got to the HiperDSP card, it
could not have blown the back of the second card (not connected to the T1 at
all), so swaping the back in slot 3 with the one in slot 1 should have (but
didn't ) fix things up.

Anyway, I'll go through the settings with a finner toothed comb and see what
I can find.  It all looks OK.

Thank you,
Todd Chamberlain

----- Original Message -----
From: "Todd Bertolozzi" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, September 03, 2002 2:41 PM
Subject: RE: [USR-TC] HELP: Lightning HiPerDSP

> In regards to the red alarm light:
>
> The DSP may have lost it's config.  Highlight the span portion in TCM and
> click on Configure...Programmed Settings....Trunk Settings.  Make sure
your
> span settings are correct.  You may want to take a quick look under NFAS
> settings and make sure it is set to FAS.
>
> Carrier light needs to be green....if you get that situated, also get into
> the hiperarc and do a "list chassis" . Does everything look normal? You
> should have the HDM listed under it's slot with 24 ports. If nothing is
> listed there you'll get dead air or busies (can't remember which).  You
> might have nmc chassis awareness enabled though which should take care of
> this for you.  "show nmc settings"  If it's disabled though...you'll need
to
> configure the chassis slots manually.
>
> Todd
>
>
>
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Support
> Sent: Tuesday, September 03, 2002 4:31 PM
> To: [email-masked]
> Subject: [USR-TC] HELP: Lightning HiPerDSP
>
>
> Hello & Help.   :-)
>
> On Friday night, we had a pretty good lightning storm here, and about
12:30
> AM, our T1 connected to our 3COM HiperDSP stopped taking calls.  The power
> had been out for a few minutes longer than our UPS's can handle, so some
of
> the servers had reset and some hadn't, depending on the particular UPS.  I
> had initially thought the settings in the DSP had been corrupted in the
> process so that it wouldn't answer (it was answering with dead air) but
when
> we plugged the T1 into our old backup equipment, it only had 4 active
> channels out of 24 (and it wasn't connected or on at the time of the
storm)
> so we then figured the culprit was upstream.  We unplugged the 4 wires
from
> our Pairgain HDSL T1 box to shut the power off to it and then reconnected
> them, and our old equipment started taking 24 calls again.  Good deal -
> fixed...
>
> Or not.  When we plugged the T1 back into the HiperDSP, the green CAR
light
> does not come on and only the red ALARM light is lit.  Calls no longer get
> dead air, they simply get routed past the card and are answered by the
next
> modem pool (our BRI ISDN modem pool) so the entire T1 is ignored and
> bypassed, the same as if it isn't plugged into anything at all.
>
> So, I'm looking for suggestions / help.  The Pairgain HDSL box doesn't
seem
> any worse for the wear after the power reset, so I don't see how a
lightning
> strike would hurt anything past it.  The HiperDSP seems to check out
> otherwise & I can talk to it OK.  I have two HiperDSP cards, but I've
never
> had the second card configured, since I've never had a second T1 and I'm
not
> certain it works at all (it has two red lights lit - ALM and LPBK/D-ALM).
>
> So... Help, please.  Any suggestions or ideas to try would be great.  I'm
in
> Canada, so buying another HiperDSP set is not a cheap / quick thing to do.

> Perhaps there is an idea of something we can try that will better diagnose
> the problem?
>
> Todd Chamberlain
>
>
>
>
> _______________________________________________
> USR-TC mailing list
> [email-masked]
> http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc
>
>
>
>
> _______________________________________________
> USR-TC mailing list
> [email-masked]
> http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc
>

_______________________________________________
USR-TC mailing list
[email-masked]
http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc

_______________________________________________
USR-TC mailing list
[email-masked]
http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc

_______________________________________________
USR-TC mailing list
[email-masked]
http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc

---

From: Joel - Fox Computers <[email-masked]>
Date: Thu, 05 Sep 2002 08:28:04 +0000

Sorry - Number of DTMF Tones is the setting I was referring to.  Set that to zero.

-----Original Message-----
From: Support [mailto:[email-masked]]
Sent: Thursday, September 05, 2002 1:04 AM
To: [email-masked]
Subject: Re: [USR-TC] HELP: Lightning HiPerDSP

K...  Where?  Under TRUNK settings, I don't see "number of digits"
exactly....
At the bottom, I see "overlap receiving inbound digits" set to 12 and five
lines above
that I see "number of DTMF Tones" set to 4, but not "number of digits".  You
have to
talk really slowly and clearly when talking to me, you understand...  :-)

I'm pretty convinced that the hardware is all OK.  I think all that happened
really was
the Telco's Pairgain HDSL T1 Modem had messed up, and while I was trying to
figure
out what was wrong with the Hiper DSP, I probably messed up a crucial
setting.  Once
we gave up and plugged the T1 in to our old backup equipment, we then
figured that
the T1 didn't work in our older equipment either.  We then reset the HDSL
Modem and
our old stuff came to life, but when we plugged it back into the DSP card,
it was still no
go.  Since it's dead-air on both my DSP cards, I'm feeling OK that it's NOT
dead DSPs,
but rather messed up settings.

----- Original Message -----
From: "Joel - Fox Computers" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, September 04, 2002 11:21 PM
Subject: RE: [USR-TC] HELP: Lightning HiPerDSP

Thinking about this some more -

If you're getting dead air instead of busy signals, here's an idea:

I had this happen where the phone company quit sending me DNIS digits for no
apparent reason, got dead air answers because the cards were waiting for the
digits and never getting them.  In the trunk settings on your DSP - change
the "number of digits" to zero and try that.

Joel

-----Original Message-----
From: Support [mailto:[email-masked]]
Sent: Thursday, September 05, 2002 12:04 AM
To: [email-masked]
Subject: Re: [USR-TC] HELP: Lightning HiPerDSP

Hi Lewis.  I tried this with a LoopBack adapter that came with our Equinox
Digital Modem Pools we used to have.  When I initiate the Loopback test by
setting the mode from NoLoop to Payload or Line, the LoopBack LED goes
Yellow (test in progress) but it never comes back from yellow.  Can you
explain
how the sequence should look?  Perhaps the lookback adaptor I have is not
the
same - I haven't built my own yet, but will tomorrow.

Actually, I think the T1 port is OK - at least the CAR light comes on green
and the
PairGain HDLS T1 modem's lights activate correspondingly, just that we get
a dead-air answer.  We've been though the trunk settings over and over, but
I just
don't see anything wrong.  We get the same results on both cards, so we're
back
to trying a loopback to make sure the CAR lights aren't lying.

So, if you could tell me what a successful loopback test should work like, I
would
be grateful.  :-)

Todd Chamberlain

----- Original Message -----
From: "Lewis Bergman" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, September 03, 2002 2:49 PM
Subject: Re: [USR-TC] HELP: Lightning HiPerDSP

> If you just want to check if the circuitry is OK on the DSP you should do
a
> loopback test. You can also make a loopback adapter by crossing the pairs.
Do
> a google search for "t1 loopback" and you'll see the pinout.
> --
> Lewis Bergman
> Texas Communications
> 4309 Maple St.
> Abilene, TX 79602-8044
> 915-695-6962 ext 115
>

---

From: [email-masked]
Date: Thu, 05 Sep 2002 15:22:06 +0000

That's not a test, it's a condition. Yellow means there is a loopback
condition. So far all posts look correct regarding DNIS. If the Telco sends
digits, set it to DNIS, and DTMF tones equal to the number of digits. If
they are not, set it to "no address". This of course assumes your ARC OWNS
the DSP. Do a List chassis" and make sure your ARC owns the DSP's in
question. Then, do a "list Int" and makes sure your modem ports say up and
up. If they are, then more than likely, this is a DNIS digit thing.

Rick
Team Solunet

-----Original Message-----
From: Support [mailto:[email-masked]]
Sent: Thursday, September 05, 2002 11:06 AM
To: [email-masked]
Subject: Re: [USR-TC] HELP: Lightning HiPerDSP

It just stays Yellow forever?  It would be nice if it blinked
a couple times and then went off or something for a
successful test.  Mine goes Yellow no matter what I set
it to pretty much, and it stays that way forever.

----- Original Message -----
From: "Lewis Bergman" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, September 05, 2002 7:24 AM
Subject: Re: [USR-TC] HELP: Lightning HiPerDSP

> On Thursday 05 September 2002 12:04 am, Support wrote:
> > how the sequence should look?
> That's what mine does when I put it on line loopback and put my adapter
in. I
> would have to go dig in the docs to see what a bad one does.
> Try this page for some more troublrshooting help.
> --
> Lewis Bergman
> Texas Communications
> 4309 Maple St.
> Abilene, TX 79602-8044
> 915-695-6962 ext 115
>

---

From: [email-masked]
Date: Thu, 05 Sep 2002 10:33:03 +0000

So, how does one go about checking the hardware then?  I'm fairly confident 
that the hardware works, since the green CAR light comes on and since two DSP 
cards work identically, but it would be nice to do a hardware diagnostic of 
some sort to be certain.

Todd Chamberlain

On 9/5/02 10:34 AM, [email-masked] wrote to SUPPORT:

-> On Thursday 05 September 2002 10:05 am, Support wrote:
-> > It just stays Yellow forever?  It would be nice if it blinked
-> > a couple times and then went off or something for a
-> > successful test.  Mine goes Yellow no matter what I set
-> > it to pretty much, and it stays that way forever.
-> Doesn't seem extremely useful does it?
-> -- 
-> Lewis Bergman
-> Texas Communications
-> 4309 Maple St.
-> Abilene, TX 79602-8044
-> 915-695-6962 ext 115
-> 
-> _______________________________________________
-> USR-TC mailing list
-> [email-masked]
-> http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc

---

From: [email-masked]
Date: Thu, 05 Sep 2002 18:02:08 +0000

OK. That's good to know.  That makes sense in the wording of our older stuff, 
it list it as 'Message Oriented Switch type', which I guess basically 
says "PRI switch type" doesn't it.  OK, well that's a setting we don't have to 
worry about then.  Thanks. :-)

On 9/5/02 12:03 PM, [email-masked] wrote to SUPPORT:

-> On Thursday 05 September 2002 11:52 am, [email-masked] wrote:
-> > They did say they have a DMS100 switch, and they seemed very confident of
-> > that at least.  However, switching that from 5ESS to DMS100 didn't seem to
-> > make any difference.  As well, our older equipment that works is supposed
-> > to 'auto detect' settings (which would be GREAT) and it's "Message 
Oriented
-> > Switch Type" is set to ni1 by default, although switching it manually to
-> > DMS and it still answers....
-> I don't think the switch type will cahnge anything on a channalized T, only 
-> for a PRI
-> -- 
-> Lewis Bergman
-> Texas Communications
-> 4309 Maple St.
-> Abilene, TX 79602-8044
-> 915-695-6962 ext 115
-> 
-> _______________________________________________
-> USR-TC mailing list
-> [email-masked]
-> http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc