Subject: (usr-tc) Hiper Arc Prompts

From: Kevin Hemsley <[email-masked]>
Date: Fri, 20 Oct 2000 05:15:25 +0000

I would like to change the login prompts on my Hiperarcs to be different for
each modem.  I can change the prompt for each modem using HARM, but I can't
find a command using the CLI.  The closest I can find is:

set modem_GROUP slot:1 prompt "some prompt:"

The problem is that this sets the prompt for the entire group, not for each
modem.  I assume that if I can change the prompt for each modem using HARM,
that there must be a CLI command to do the same.

Also, do the Hiper ARCs provide any system variables that can be used in
prompts or messages, such as the current slot or modem?  Such as prompt
"slot:%slot/mod:%modem Login:"

----------------------------------
Kevin Hemsley
Systems Engineer
Microserv Computer Technologies, Inc.
[email-masked]
KB7TYA

-
 To unsubscribe to usr-tc, send an email to "[email-masked]"
 with "unsubscribe usr-tc" in the body of the message.
 For information on digests or retrieving files and old messages send
 "help" to the same address.  Do not use quotes in your message.

---

From: Mike Andrews <[email-masked]>
Date: Fri, 20 Oct 2000 06:57:39 +0000

Here's our login banner, with variables...  don't know if the variables
will work with a prompt though.

set modem_group all message "\r\nDigital Crescent, Inc -- $sysname.dcr.net ($port)\r\n"

Mike Andrews * [email-masked] * http://www.bit0.com/
VP, sysadmin, & network guy, Digital Crescent Inc, Frankfort KY
Dialup/ADSL/ISDN/T1 Internet access for Frankfort KY and surrounding counties
www.fark.com: If it's not news, it's Fark.  (Or something like that.)

-

---

From: Dave Lajoie <[email-masked]>
Date: Fri, 20 Oct 2000 17:13:32 +0000

Kevin,

I'm not sure if this will help but try this ==

Our ARC's prompt$> set modem_group slot:1/mod:1 prompt Desired prompt
	       or> set modem_group slot:1/mod:2 prompt Desired Prompt

Where Desired Prompt ==

This field is an alphanumeric String
        It has a maximum size of 256.
If the string is surrounded by double quotes:
        There can be an escape character '\' inside the quoted string
        if followed by a b, f, n, r, t or v it will cause  special
	characters
        to be placed in the string
                \b = backspace
                \f = formfeed
                \n = newline
                \r = carriage return
                \t = tab
                \v = vertical tab
        if followed by an x, will cause the next two characters to be
        interpreted as a hexadecimal constant.
              x0A = 0x0a
        if followed by any other character, will cause that character to
        be placed in the token
                a Double Quote will place the Double Quote in the token
                a  '\'  will place one '\' in the token

****Like I said, this is just a shot in the dark in answer to your
    question. Hope it will help... good luck:)

Dave Lajoie
Remote Access Administrator
North Country Internet Access
E-Mail: [email-masked]

-