Subject: (usr-tc) radius "Class" attribute

From: Jeff <[email-masked]>
Date: Wed, 27 Sep 2000 20:49:58 +0000

Does anyone know if the "Class" attribute is supported on the hiperARC
or netserver?  Here's the description from RFC2865:

5.25.  Class

   Description

      This Attribute is available to be sent by the server to the client
      in an Access-Accept and SHOULD be sent unmodified by the client to
      the accounting server as part of the Accounting-Request packet if
      accounting is supported.  The client MUST NOT interpret the
      attribute locally.

PS - I tried searching the knowledgebase and the list for this answer but
couldn't find it.  Sorry if it's obvious and I missed it.

--
  Jeff Carneal - Sys Admin - Apex Internet          
  [email-masked] http://www.apex.net (270) 442-5363

  The opinions expressed above aren't really mine.
  They belong to someone else who also refuses to 
  take responsibility for them. 

-
 To unsubscribe to usr-tc, send an email to "[email-masked]"
 with "unsubscribe usr-tc" in the body of the message.
 For information on digests or retrieving files and old messages send
 "help" to the same address.  Do not use quotes in your message.

---

From: Randy Cosby <[email-masked]>
Date: Wed, 27 Sep 2000 21:28:38 +0000

Yes, it is supported in both.  It's quite handy for accounting purposes.
Our radius might put something like "FILTEREDUSER" in the class, which gets
passed back to our accounting and session databases.

Randy

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jeff
> Sent: Wednesday, September 27, 2000 12:45 PM
> To: [email-masked]
> Subject: (usr-tc) radius "Class" attribute
>
>
>

-

---

From: Veda Narayan <[email-masked]>
Date: Thu, 28 Sep 2000 02:07:26 +0000

> or netserver?  Here's the description from RFC2865:
The class attribute is supported by the HiPer arc - The netserver does not 
support it.  Hiper arc 4.1.13 and above does support this.

V

> couldn't find it.  Sorry if it's obvious and I missed it.

===========

-V

==========

-

---

From: Marcelo Souza <[email-masked]>
Date: Thu, 19 Oct 2000 19:43:32 +0000

I'm still having trouble with some ISDN users, that cannot send
e-mails with attached files.
	The common thing among these users is that they're using a TELES
ISDN Winmodem (www.teles.de), and I have may of then, since it's being
sold by the local telco.
	Someone already told me to reduce the MTU in the ARC, but it does
not solve the problem.
	The FW version is:
	
	DSP - 2.1.9
	ARC - 4.1.59

	Any tip?

- Marcelo

-

---

From: Veda Narayan <[email-masked]>
Date: Fri, 20 Oct 2000 01:27:17 +0000

> 	Someone already told me to reduce the MTU in the ARC, but it does

MTU could be your problem if fragmentation of data is required.
What you are saying here is that your clients cannot send emails with 
attachments, which basically tells me that the client is sending the data
to the router (NAS) which then forwards the same to the mail server 
which may ask you to fragment the data.  The question is where did you setup 
the MTU change?  On radius? on the default user? or on the client?

You see in 4.1.59 if this is a MTU problem - then you have to do the
following.

Remove all the MTU values that you send from radius
Set the default user on the HiPer arc to a mtu value of 576 (to start)
Do not set any specific MTU for the user on the client side.

If this does not work, then info on your connection to the mail server 
is necessary, to understand the path MTU.

By any chance can your users send email using hotmail or other email 
with attachments using the same modem?

-V

===========

-V

==========

-

---

From: Marcelo Souza <[email-masked]>
Date: Fri, 20 Oct 2000 21:37:03 +0000

On Thu, 19 Oct 2000, Veda Narayan wrote:

|Quoting Marcelo Souza <[email-masked]>:
|
|> 
|> 	I'm still having trouble with some ISDN users, that cannot send
|> e-mails with attached files.
|> 	The common thing among these users is that they're using a TELES
|> ISDN Winmodem (www.teles.de), and I have may of then, since it's being
|> sold by the local telco.
|> 	Someone already told me to reduce the MTU in the ARC, but it does
|> not solve the problem.
|
|MTU could be your problem if fragmentation of data is required.
|What you are saying here is that your clients cannot send emails with 
|attachments, which basically tells me that the client is sending the data
|to the router (NAS) which then forwards the same to the mail server 
|which may ask you to fragment the data.  The question is where did you setup 
|the MTU change?  On radius? on the default user? or on the client?

	My first try was to set on the default user. It did not work. That
time I had feel complains.
	After that I start telling the client to change on dial
adapter. It did work for some of them, but I still have complains.
	I do not set MTU from Radius.

|You see in 4.1.59 if this is a MTU problem - then you have to do the
|following.
|
|Remove all the MTU values that you send from radius
|Set the default user on the HiPer arc to a mtu value of 576 (to start)
|Do not set any specific MTU for the user on the client side.
|
|If this does not work, then info on your connection to the mail server 
|is necessary, to understand the path MTU.

	The TC is connect at 100Mbps direct to the same switch which is
connect the mail server also at 100Mbps. The MTU of the ethernet of the
mail server is at 1500.

|By any chance can your users send email using hotmail or other email 
|with attachments using the same modem?

	I don't know.

- Marcelo

|-V
|
|
|> 	The FW version is:
|> 	
|> 	DSP - 2.1.9
|> 	ARC - 4.1.59
|> 
|> 	Any tip?
|> 
|> - Marcelo
|> 
|> 
|> 
|> 
|> -
|>  To unsubscribe to usr-tc, send an email to "[email-masked]"
|>  with "unsubscribe usr-tc" in the body of the message.
|>  For information on digests or retrieving files and old messages send
|>  "help" to the same address.  Do not use quotes in your message.
|> 
|
|
|
|===========
|
|-V
|
|==========
|

- Marcelo

-

---

From: Veda Narayan <[email-masked]>
Date: Sat, 21 Oct 2000 01:31:07 +0000

Quoting Marcelo Souza <[email-masked]>:
What version of HiPer arc, DSP code are you using currently?

V

===========

-V

==========

-

---

From: Marcelo Souza <[email-masked]>
Date: Sat, 21 Oct 2000 01:40:48 +0000

On Fri, 20 Oct 2000, Veda Narayan wrote:

|Quoting Marcelo Souza <[email-masked]>:
|What version of HiPer arc, DSP code are you using currently?

	DSP - 2.1.9                                                             
	ARC - 4.1.59      

- Marcelo

|> On Thu, 19 Oct 2000, Veda Narayan wrote:
|> 
|> |Quoting Marcelo Souza <[email-masked]>:
|> |
|> |> 
|> |> 	I'm still having trouble with some ISDN users, that cannot send
|> |> e-mails with attached files.
|> |> 	The common thing among these users is that they're using a TELES
|> |> ISDN Winmodem (www.teles.de), and I have may of then, since it's
|> being
|> |> sold by the local telco.
|> |> 	Someone already told me to reduce the MTU in the ARC, but it does
|> |> not solve the problem.
|> |
|> |MTU could be your problem if fragmentation of data is required.
|> |What you are saying here is that your clients cannot send emails with 
|> |attachments, which basically tells me that the client is sending the
|> data
|> |to the router (NAS) which then forwards the same to the mail server 
|> |which may ask you to fragment the data.  The question is where did you
|> setup 
|> |the MTU change?  On radius? on the default user? or on the client?
|> 
|> 	My first try was to set on the default user. It did not work. That
|> time I had feel complains.
|> 	After that I start telling the client to change on dial
|> adapter. It did work for some of them, but I still have complains.
|> 	I do not set MTU from Radius.
|> 
|> |You see in 4.1.59 if this is a MTU problem - then you have to do the
|> |following.
|> |
|> |Remove all the MTU values that you send from radius
|> |Set the default user on the HiPer arc to a mtu value of 576 (to start)
|> |Do not set any specific MTU for the user on the client side.
|> |
|> |If this does not work, then info on your connection to the mail server 
|> |is necessary, to understand the path MTU.
|> 
|> 	The TC is connect at 100Mbps direct to the same switch which is
|> connect the mail server also at 100Mbps. The MTU of the ethernet of the
|> mail server is at 1500.
|> 
|> |By any chance can your users send email using hotmail or other email 
|> |with attachments using the same modem?
|> 
|> 	I don't know.
|> 
|> - Marcelo
|> 
|> |-V
|> |
|> |
|> |> 	The FW version is:
|> |> 	
|> |> 	DSP - 2.1.9
|> |> 	ARC - 4.1.59
|> |> 
|> |> 	Any tip?
|> |> 
|> |> - Marcelo
|> |> 
|> |> 
|> |> 
|> |> 
|> |> -
|> |>  To unsubscribe to usr-tc, send an email to "[email-masked]"
|> |>  with "unsubscribe usr-tc" in the body of the message.
|> |>  For information on digests or retrieving files and old messages send
|> |>  "help" to the same address.  Do not use quotes in your message.
|> |> 
|> |
|> |
|> |
|> |===========
|> |
|> |-V
|> |
|> |==========
|> |
|> 
|> 
|> - Marcelo
|> 
|> 
|> 
|> 
|
|
|
|===========
|
|-V
|
|==========
|

- Marcelo

-

---

From: Veda Narayan <[email-masked]>
Date: Sat, 21 Oct 2000 15:01:12 +0000

> |What version of HiPer arc, DSP code are you using currently?

You have already tried the MTU and did not work, the only other option that 
remains is to collect debug and identify the issue.  Now since 4.1.59 code is 
quite old, I would suggest that you upgrade to 4.1.13 and then see if there is 
any improvement.  If it does not improve I can sure help you debug the problem.

regards

V

-