Subject: RE: [USR-TC] modem stats via snmp

From: Brian Becker <[email-masked]>
Date: Tue, 30 Jul 2002 22:39:19 +0000

But that is only if the contiguous numbering flag is set...and that only
if you are using certain versions. For Total Scrutinizer, we had to
start checking for version numbers, contiguous numbering flag & E1 or T1
or PRI running on the card.

Brian

Brian Becker
President, Poplar Bluff Internet, Inc. http://semo.net
 
Home of TotallyFabricated.com Software & Web Design
  http://TotalScrutinizer.com - Tech Support Just Got Easier!
 
POBox 190 - Poplar Bluff, MO 63902 - 573.686.9114

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Oliver Francke
Sent: Tuesday, July 30, 2002 4:26 PM
To: [email-masked]
Subject: Re: [USR-TC] modem stats via snmp

Hi,

> 
> Does anyone know how the TC maps port numbers which the NMC uses above

> -
> <slot# * 1000 + span#> to the one the arc uses to report back a
username in 
> OID 1.3.6.1.4.1.429.4.10.1.1.18? Or is there another OID that might
report 
> back a username that uses the same type of numbering scheme?

So the mapping is:

--- 8-< --------------

#!/bin/sh

RCOMM=<your-read-community>

SRV=$1
SLT=$2
MDM=$3

DUM=`expr $SLT \* 256`

INST=`expr 1000 + $DUM + $MDM`

echo $INST

# usrCipUserName 1.3.6.1.4.1.429.4.10.1.1.18
# usrCipDataLinkConn 1.3.6.1.4.1.429.4.10.1.1.20

snmpget $SRV $RCOMM .1.3.6.1.4.1.429.4.10.1.1.18.$INST
.1.3.6.1.4.1.429.4.10.1.1.20.$INST

--- 8-< --------------

So, a possible output may be:

--- 8-< --------------
GetPortInfo.sh srv1.somewhere 1 2
1258
enterprises.429.4.10.1.1.18.1258 =
"aolnet/aol.dlp.Elchenc8.10120100100101de2905.0000.prod"
enterprises.429.4.10.1.1.20.1258 = 10
--- 8-< --------------

corresponds to:

--- 8-< --------------
srv1.somewhere> list conNECTIONS 

CONNECTIONS

                                                        Start
Start
IfName          User Name                   Type   DLL  Date        Time
slot:1/mod:2    aolnet/aol.dlp.Elchenc8.10120100100101de2905.0000.prod 
                                            DIALIN L2TP 30-JUL-2002
20:32:11  
--- 8-< --------------

Hope this helps, Oliver.

-- 
Was hat bei uns die geringste PopulariTAET?

[email-masked]               fon. +49-5246-80-1389
                                           mob.  +49-171-5597734 I used
to have a sig, but I've stopped smoking now.

_______________________________________________
USR-TC mailing list
[email-masked]
http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc

---

From: Oliver Francke <[email-masked]>
Date: Wed, 31 Jul 2002 07:31:01 +0000

Hi Brian,

> if you are using certain versions. For Total Scrutinizer, we had to

Yeah, you're right, but everytime when a version-change INCLUSIVE
numbering-change occured, I kicked someone ;-)

Anyway, the rest should not be very much of a secret...

Regards, Oliver.

[email-masked]               fon. +49-5246-80-1389
                                           mob.  +49-171-5597734
I used to have a sig, but I've stopped smoking now.