Subject: [USR-TC] MRTG modem utilization for Quad

From: Gen Camiling <[email-masked]>
Date: Tue, 30 Apr 2002 02:12:04 +0000

Hello there,

I just want to get any expert advice/suggestion on a certain
issue. I have gotten this MRTG thing to monitor port utilization but when i try
to implement it in one client of mine who still using Quad ana/digi cards
apparently there was no graphic display of the trends (believe me in this part
of the world there are still people using analog access). Feel free to give your
comment. What i did miss? Am looking for the necessary OID for the Quads.

====start of MRTG config====

Target[usage]:1.3.6.1.4.1.429.4.2.1.10.0&1.3.6.1.4.1.429.4.2.1.10.0:[email-masked]
RouterUptime[usage]: [email-masked]  <<< this is hiperarc IP address and
community
MaxBytes[usage]: 150  <<< this is the total amount of lines you have available
AbsMax[usage]: 150
Title[usage]: Number of Modems In Use
PageTop[usage]: <H1>Number of Modems In Use</H1>
Unscaled[usage]: ymwd
ShortLegend[usage]: Modems
XSize[usage]: 380
YSize[usage]: 100
YLegend[usage]: Modems In Use
Legend1[usage]: Modems In Use
Legend2[usage]:
Legend3[usage]:
Legend4[usage]:
LegendI[usage]: Modems In Use
LegendO[usage]:
Options[usage]: gauge

====end of MRTG config====

-- 
Best regards,
Gen 

==================================
Gen Camiling 
Chief Technical Officer                       
International Micro Village, Inc. PHILIPPINES
(63)(2) 7512130

mailto:[email-masked]

==================================

---

From: Stephen Amadei <[email-masked]>
Date: Tue, 30 Apr 2002 03:05:27 +0000

> comment. What i did miss? Am looking for the necessary OID for the Quads.

I take it you are SNMP poking the HiperARCs... the older Quads used the
NetServer, which uses different OIDs.  Even so, I'm not sure if the
HiperARCs will correctly count the Quads... so my solution is to not use
the HiperARCs for counting usage.

What I do is a bit more complicated, so you need to write a little
shell script to put around your call to MRTG.  First I SNMPwalk the
NMC card, for OID .1.3.6.1.4.1.429.1.6.9.1.1.2... this will produce a
list, which I grep for "= 8" (1..idle, 5..ringing, 8..online).  I could
the lines left with 'wc -l' and echo the output to a temporary file that
my MRTG .cfg file points to.  I then call MRTG.

Email me privately if you want my code... for my TC's it became more
complicated (split chassis and double ARCs and I also graph the
temperature), but it's interesting code to chew on.  ;-)

					----Steve
Stephen Amadei
Dandy.NET!  CTO
Atlantic City, NJ

---

From: Charles Sprickman <[email-masked]>
Date: Tue, 30 Apr 2002 00:34:03 +0000

There's also the hiperdsp.pl and t1.pl progs included with mrtg.  They
work fine for both quads and dsps...  Check in the contrib directory of
the mrtg tarball...

Charles

--
Charles Sprickman
[email-masked]

On Mon, 29 Apr 2002, Stephen Amadei wrote:

> _______________________________________________
> USR-TC mailing list
> [email-masked]
> http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc
>