Subject: [USR-TC] Hiper DSP

From: Steve Johnson <[email-masked]>
Date: Wed, 19 Jun 2002 21:47:53 +0000

Is there a way to change the switch type from the command line, instead of 
using the TCM software to do it?  We are switching over to a new phone 
company and I think it would be easier/quicker to script something to do the 
switch type change instead of selecting each card, changing switch type, 
saving, rebooting.. =)

-Steve

---

From: Mike Greene <[email-masked]>
Date: Wed, 19 Jun 2002 22:46:19 +0000

>switch type change instead of selecting each card, changing switch type,

Just change one card, save it, then select all of the rest and copy from 
the first card you changed, then save, reboot and your done.

- Mike

------------------------------------------------
Rock Island Communications, Inc.  (360)-378-5884
http://www.rockisland.com/  San Juan Islands, WA
------------------------------------------------

---

From: Steve Johnson <[email-masked]>
Date: Wed, 19 Jun 2002 22:56:26 +0000

Hmmm Didn't know you could do it like that... I'll give it a try..  But still 
would like to know the command line way =) just in case =)

-Steve

On Wednesday 19 June 2002 03:45 pm, you wrote:
> _______________________________________________
> USR-TC mailing list
> [email-masked]
> http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc
> 
>

---

From: Justin Kendall <[email-masked]>
Date: Thu, 20 Jun 2002 00:04:13 +0000

Steve,
It can be done but it's not all that fun...
You have to telnet or console to the dsp then:
chdev span
set swtype switchtype 

There's a great DSP command refrence here:
http://totalservice.commworks.com/tcsDocs/4.5/10048399/10048399_frames.html
And for HARC here:
http://totalservice.commworks.com/tcsDocs/4.5/10048398/10048398_frames.html

This may only work if you're using PRI signaling, I'm not sure. 

If you're going to telnet into your DSP's you'll have to set them up like so....(this comes in handy quite often and is worth the trouble so I highly recommend it)

Have fun,
Justin Kendall, NetEase, Inc
[email-masked]

 Telnet or console connect to the HiPer ARC as a manage user and follow the steps below: 
          1. Modify each slot for ownership, card_type, and port density via the "set chassis slot" command. 
          2. Set chassis slot (x-y) console yes <Enter> (where x and y can equal slot range with HiPer DSP cards installed) 
          3. Verify correct port creation via the "list interface" command. Slot/mod: ports and Slot/CON:1 ports should now be created. 
          4. add modem_group <name> interface SLOT:X/CON:1 <Enter> (where X = one eligible slot # in line 2)
          5. add network service <name> server_type telnetd socket <unused TCP socket number> data service_type=dialout, auth=off, modem_group="name" <Enter> (where "name" = name in line 4) 
          6. save all <Enter> 
          Note: Only eligible cards with TCS 3.5 software installed (2.0.19or better) can be console enabled 
          Note: Multiple modem groups and network services can be created to allow console access to all HiPer DSP cards installed and under HiPer ARC ownership as long as a unique TCP port number exists for h service created in line 5 above. 
          Note: Above setup steps are for an unsupported configuration with TCS 3.5 software versions. Use above for a troubleshooting scenario only and disable the network service when not needed as long term usage may cause intermittent problems. TCs 4.0 compatible software fully supports this feature.

---

From: Jeff Mcadams <[email-masked]>
Date: Thu, 20 Jun 2002 03:53:20 +0000

Also sprach Justin Kendall
>It can be done but it's not all that fun...

Alternatively, all of these configuration settings are viewable and
settable via SNMP in the manager card.  I think, with the DSPs, that
switch-type can actually be changed on the fly, no need for a reboot
(though a save to NVRAM is obviously desired so settings are retained
after a reboot...fortunately, I believe the save to NVRAM can be
accomplished via SNMP as well).
-- 
Jeff McAdams                            Email: [email-masked]
Head Network Administrator              Voice: (502) 966-3848
IgLou Internet Services                        (800) 436-4456

---

From: Charles Sprickman <[email-masked]>
Date: Thu, 20 Jun 2002 23:37:03 +0000

Here's my semi-annual Mike Andrews usrtoys plug:

http://www.dcr.net/~mandrews/usrtoys/

Something there should let you do this via command line, scripted.

C

--
Charles Sprickman
[email-masked]