Subject: Re: (usr-tc) changing IP pool

From: Justin <[email-masked]>
Date: Mon, 10 Jan 2000 19:16:06 +0000

Kirk,

  You need to add an address from the subnet of the pool that you added to the ethernet interface of the HiperArc that doles out those ip's.  For instance, if you added a pool of size 200, starting address 192.168.1.10, you would need to add an unused IP from that range to the ethernet port of the hiperArc; ie: "add ip network somename address 192.168.1.2 interface eth:1 enabled yes".  Of course, you would need 192.168.1.1 (or other unassigned IP from that range) assigned to the corresponding interface on your Cisco to complete the route.

HTH,

Justin

>I was able to get the new pool in over the weekend with Krish's help, but
>the ARC isn't routing to the new pool. Apparently I'm missing something.
>
>
>-- 
>Kirk Mitchell-General Manager        [email-masked]
>Keystone Connect                     Unlock Your World
>Altoona, PA   814-941-5000      http://www.keyconn.net
>
>
>-
> To unsubscribe to usr-tc, send an email to "[email-masked]"
> with "unsubscribe usr-tc" in the body of the message.
> For information on digests or retrieving files and old messages send
> "help" to the same address.  Do not use quotes in your message.
>

-
 To unsubscribe to usr-tc, send an email to "[email-masked]"
 with "unsubscribe usr-tc" in the body of the message.
 For information on digests or retrieving files and old messages send
 "help" to the same address.  Do not use quotes in your message.

---

From: K Mitchell <[email-masked]>
Date: Mon, 10 Jan 2000 19:57:26 +0000

At 11:10 AM 1/10/00 -0600, Justin wrote:
>Kirk,
>
>  You need to add an address from the subnet of the pool that you added to
the ethernet interface of the HiperArc that doles out those ip's.  For
instance, if you added a pool of size 200, starting address 192.168.1.10,
you would need to add an unused IP from that range to the ethernet port of
the hiperArc; ie: "add ip network somename address 192.168.1.2 interface
eth:1 enabled yes".  Of course, you would need 192.168.1.1 (or other
unassigned IP from that range) assigned to the corresponding interface on
your Cisco to complete the route.

You had me for a second there, than ya lost me  :)
  My apologies for not being router clue'd, and again for not having a
Cisco(I'm working on changing both). My router's an OpenRoute, and does
have the 2nd class C listed and appears to be routing to it ok. I assigned
an IP from the new class C to a server NIC and was able to get to a test
website in that IP from outside my network.
  Back to the TC...I take it then that I need to assign an address from the
new class C to the ARC. I wasn't aware that the ARC could have more than 1
address, and was hoping to leave it with the address it has from my
original class C. I can shuffle things though if that's not possible. I'd
imagine that I should assign the NMC a new address also. Is there any way
to find out the name of the network that's already assigned?
  Here's what I have currently...the pool is from the 204.171.31.0/24 and
the new class C is 204.171.145.0/24
CONFIGURED DEFAULT ROUTERS
  Address  Mask     Gateway           Metric State
  0.0.0.0  0.0.0.0  204.171.31.1      1      ENABLED
HiPer>> sh ip rou

IP ROUTER SETTINGS
IP Router Administrative Status:           ENABLED
IP Static Remote Routes:                   ENABLED
IP LAN Host Address:                       204.171.31.2
IP Autonomous System Number                1
IP Max Table Size:                         11400
IP Max Metric Entries:                     512
IP RIP                                     ENABLED
IP Number RIP Interfaces:                  0
IP Number RIP Neighbors:                   0
IP RIP Flags:                              METRICS
                                           SEND_REQUEST

Thanks,

-

---

From: System Administrator <[email-masked]>
Date: Mon, 10 Jan 2000 20:20:59 +0000

> website in that IP from outside my network.

If that's the case, then it should be safe to assume (remember what your
English teacher told you?)that routing is working except to the HARC.

> original class C.

Your HARC can have more than one IP address assigned to the ethernet
interface.

I can shuffle things though if that's not possible. I'd
> imagine that I should assign the NMC a new address also.

My NMC is on a different subnet than my HARC.  3Com said that's not the way
it was intended, but it works fine for me.

> Is there any way

li ip net

> IP Number RIP Neighbors:                   0

OK, so here's what we need to do:
Add the new pool to the HARC:
  add ip pool poolname init 204.171.145.x size xx
Add new IP address to ethernet interface:
  add ip network somename address 204.171.145.x interface eth:1 enabled yes
Add new default gateway for new IP Pool (point it to your router):
  add ip defaultroute gateway 204.171.145.1
Save it:
  save all

That should get you going!

__________________________________
Justin Ellison
System Administrator
InternetUSA
[email-masked]
http://nebi.com
800-603-3502

-

---

From: K Mitchell <[email-masked]>
Date: Mon, 10 Jan 2000 21:49:07 +0000

>English teacher told you?)that routing is working except to the HARC.

That's a safe assumption  :)

>Your HARC can have more than one IP address assigned to the ethernet

Does it need to have an address from the class C it's using as pool?

>it was intended, but it works fine for me.

It's be easier for me to keep ARC and NMC within the same class C,
whichever one it ends up being.

>> to find out the name of the network that's already assigned?

But that only...ah...I see...what threw me was the original network was
named "IP". I wonder what dummy picked that name 2 years ago :)
Name                            Prot Interface       State Type Network
Address

ip                              IP   eth:1           ENA   STAT 204.171.31.2/C

>  add ip pool poolname init 204.171.145.x size xx

Done

>  add ip network somename address 204.171.145.x interface eth:1 enabled yes

So what's there won't work for 204.171.145.x?
 CONFIGURED DEFAULT ROUTERS
   Address  Mask     Gateway           Metric State
   0.0.0.0  0.0.0.0  204.171.31.1      1      ENABLED

>  add ip defaultroute gateway 204.171.145.1

My router is at 204.171.31.1, so I need to add an 204.171.145.x IP to it also?

Many thanks,

-