Subject: (usr-tc) pmwho question..

From: Steve Monkhouse <[email-masked]>
Date: Mon, 04 Sep 2000 07:47:33 +0000

Hello all..

Ive ben using pmwho now for probably about 2.5 years.. and it works really well for what i need.. anyway.. 

quick question if i may.. 

in the pmwho.c source, its mentioned about setting up the password tables for multiple passwords.. ( which is what we have ).. 
Im having trouble compiling it again though.. 
The original is thus ...........
   
struct {
  char hostname[32];
  char password[32];
} pwtable[] = {
  /* { "pm1", "topsecret" } */
};

my modified one looks like .........
   
struct {
  char hostname[32];
  char password[32];
} pwtable[] = {
   { "pm1", "topsecret" } 
   { "pm2", "topsecret1" }
};

Yet whenever i compile Im getting errors.. is my structure incorrect ??
Thanks in advance.. 

-
 To unsubscribe to usr-tc, send an email to "[email-masked]"
 with "unsubscribe usr-tc" in the body of the message.
 For information on digests or retrieving files and old messages send
 "help" to the same address.  Do not use quotes in your message.

---

From: Dayton Internet <[email-masked]>
Date: Mon, 04 Sep 2000 14:25:02 +0000

What is the text of the error message.

Just out of appearance it looks good, but didyou try:

} pwtable[] = {
   { "pm1", "topsecret", "pm2", "topsecret1" }
};

Just in case the compiler is only looking for one {} 

-- 
--Rich Adams, President, Dayton Internet Services Inc., Dayton, Ohio--
  [email-masked]

-