Subject: RE: [USR-TC] ARC not releasing IP addresses

From: "MacDonald, James" <[email-masked]>
Date: Fri, 16 Aug 2002 05:01:08 +0000

Hint Assigned is: DISABLED

We disabled this due to a previous problem on all chassis'. 

Any other thoughts?

thanks,

Jim

-----Original Message-----
From: V [mailto:[email-masked]]
Sent: Thursday, August 15, 2002 8:06 PM
To: [email-masked]
Subject: Re: [USR-TC] ARC not releasing IP addresses

Do you have 'hint assigned'  enabled?

-V
----- Original Message -----
From: "MacDonald, James" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, August 15, 2002 9:39 AM
Subject: [USR-TC] ARC not releasing IP addresses

> Hi All,
>
> We have 1 hyperarc that seems to have a problem where it can not release
IPs
> previously assigned properly. It sometimes does and sometimes doesn't ...
> eventually the arc  runs out of IP addresses to assign and spews the
> following error:
>
> Aug 15 09:02:12 9L102PDI-H1 At 13:01:46, Facility "IP", Level "CRITICAL"::
> ip_fwd_get_opt: no IP address available for dynamic address assignment
>
> As you can see, the IP addresses (162 of them) are completely used up and
> there are only 7 users online. We don't think this is a code specific
issue
> as we run this code on all ARCs (about 250 of them) and this is the only
one
> getting these errors ... it may be hardware related, but in my experience
> these types of issues are generally code ... so, I'm at a cross-roads so
to
> speak. Has anyone else run into this and found a workaround?
>
> BTW: we can find only 2 ways to correct the issue, rebooting or removing
the
> IP Pools and adding them back ... we generally reboot as that is much
> quicker and less error prone.
>
> System Version: V5.0.83/Non-Encr
>
> 9L102PDI-H1> list ip pools
>
> IP ADDRESS POOLS
> Name                Address        Size InUse State   Route      Unused
> Priority Status
> 9L102-H1-POOL1   216.123.143.17/29 6    6     PUBLIC  AGGREGATE    0    1
> ACTIVE
> 9L102-H1-POOL2   216.123.140.65/27 30   30    PUBLIC  AGGREGATE    0    1
> ACTIVE
> 9L102-H1-POOL3    216.123.132.1/25 126  126   PUBLIC  AGGREGATE    0    1
> ACTIVE
> 9L102PDI-H1> list conNECTIONS
>
> CONNECTIONS
>
>                                                 Start       Start
> IfName          User Name            Type   DLL  Date        Time
> slot:1/mod:4    xxxxxx  DIALIN PPP      14-AUG-2002 21:14:41
>
> slot:1/mod:5    xxxxxx DIALIN PPP      15-AUG-2002 05:13:22
> slot:1/mod:11  xxxxxx DIALIN PPP      15-AUG-2002 13:55:43
> slot:1/mod:13  xxxxxx DIALIN PPP      15-AUG-2002 03:28:04
> slot:1/mod:16  xxxxxx DIALIN PPP      15-AUG-2002 14:04:17
> slot:1/mod:19  xxxxxx DIALIN PPP      15-AUG-2002 10:19:32
> slot:1/mod:21  xxxxxx DIALIN PPP      15-AUG-2002 08:59:12
> 9L102PDI-H1>
>
> Thanks,
>
> James MacDonald, CCNP
> Senior Platform Manager, IP
> Network Operations
> AT&T Canada Corp.
> 370 King St W., 6th Floor
> Toronto, ON M5V1J9
> Ph: 416-204-5793
> Fx: 416-204-5744
> Emergency: 416-204-5700 (NMC Hotline)
> Email: [email-masked]
>
>
> _______________________________________________
> USR-TC mailing list
> [email-masked]
> http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc

_______________________________________________
USR-TC mailing list
[email-masked]
http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc

---

From: V <[email-masked]>
Date: Fri, 16 Aug 2002 05:57:07 +0000

There are two reason basically why IP's do not return back to the pool.

1.  The arc hints an IP to radius and radius does not support hint assigned
feature - so one IP is lost in and is never
     returned back.

2. When the user disconnects, another user connects - the arc forgets to
release the old user's IP.

Clearly since you have hint assigned disabled so its not the issue.  The
second case here is a bug and you would need to upgrade the arc code to a
code where this bug has been fixed.

The other alternative is to use radius to assign IP address and not to
depend on arc to do this.

-V