Subject: [USR-TC] how to format flash on NMC?

From: Mike Greene <[email-masked]>
Date: Mon, 16 Sep 2002 15:25:38 +0000

Still dealing with the NMC problem.

Would like to format the flash and reload a new image on the card.

The instructions say to enter AT{ZF} to initiate a format before the image 
is uploaded, however the NMC ignores that command, the only thing it 
appears to recognize is AT{Z}.

The problem I'm having is that slot 15 (rear view) is showing a red ?, it 
doesn't matter what chassis I have this NMC card in, so it is definitely 
NMC card related.

The hardware rev on the NMC is 3.0  it is the newest version of NMC.

- Mike

------------------------------------------------
Rock Island Communications, Inc.  (360)-378-5884
http://www.rockisland.com/  San Juan Islands, WA
------------------------------------------------

---

From: Todd Bertolozzi <[email-masked]>
Date: Mon, 16 Sep 2002 09:41:01 +0000

Taken directly from commworks knowledge base:

  How to upgrade the Total Control HiPer NMC through the console connection:

(For a faster download set dipswitches 1 and 2 to the on position on the
HiPer NMC card and set your terminal emulation software (Hyperterminal...)
to a 57600 connection rate)

1. Make console connection to HiPer NMC card.

2. Reseat NMC card or choose command and reset from NMC console menu.
3. When you see BIOS Extension Link..... and the bottom of the screen is
blank, enter this command: AT{Z} (it is case sensitive and must be in CAPS).
You should see a message that says Begin download now and a line similar to
the one below will appear and be repeated until the file is transferred or
until the NAC times out.
B0000000023be50 B0000000023be50

4. Using the terminal program, select the appropriate commands to send a
file using the ZMODEM protocol (From Hyperterminal: choose the Transfer
option, send file, set protocol to ZMODEM and browse to find the file). The
file name should end with .DMF.

5. There will be some delay as the download is processed.

6.If the download is successful, a message similar to the following should
appear:
0; Download Successful: File = xxxxxxxxxxxxxxx

7. The card will then reboot.

Todd

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Mike Greene
Sent: Monday, September 16, 2002 11:26 AM
To: [email-masked]
Subject: [USR-TC] how to format flash on NMC?

- Mike

_______________________________________________
USR-TC mailing list
[email-masked]
http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc

---

From: Mike Greene <[email-masked]>
Date: Mon, 16 Sep 2002 16:08:39 +0000

This does not format the flash, or it doesn't appear to because I did it 
several times, even with the older flash of 6.0.28 (also from the KB) which 
was said to cause the flash to be formatted, but alas it wasn't.

In another KB solution there was the command to use AT{ZF} which would 
force a format, however that did not work.

It seems really odd that the NMC would store the chassis card information 
indefinitely since that information is dynamic as you add/remove 
cards.  Yet this one slot (15) seems to be permanently stuck in the memory 
of this card.

- Mike

---

From: Todd Bertolozzi <[email-masked]>
Date: Mon, 16 Sep 2002 10:52:02 +0000

With either that NMC or another NMC is there an alarm light on it?  And if
you looking at the performance trouble lights in TCM for the NMC is there a
manangement bus problem?

Todd

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Mike Greene
Sent: Monday, September 16, 2002 12:09 PM
To: [email-masked]
Subject: RE: [USR-TC] how to format flash on NMC?

- Mike

---

From: Todd Bertolozzi <[email-masked]>
Date: Mon, 16 Sep 2002 16:53:14 +0000

Total Control NMC - Steps to upgrade NMCs with corrupted Flash-RAM:
NMC Flash-RAM is corrupted

  Answer
  Do not perform this procedure on non-corrupted (functional) NMC. Version
6.0.98 will erase the NVRAM on production configurations.
Local - the card is physically available
1. Pull NMC from chassis.
2. Flip dip-switch 5 to the ON position (towards center of board).
3. Insert NMC into chassis.
4. Setup console connection to a terminal.
5. NMC will boot up to User-Interface default settings.
6. If necessary, set NMC IP address. Save and reboot.
8. After card has rebooted, open management connection via LAN or WAN.
9. Actions / Commands: Save chassis to NVRAM.
10. Pull NMC from chassis.
11. Flip dip-switch 5 to OFF position.
12. Insert NMC to chassis.
13. After card has booted, open management connection via LAN or WAN.
14. Download NMC v6.0.99 via LAN or WAN.
15. NMC is now manageable for software download, programmed settings, etc.
Remote - the card is accessible via console only
1. Obtain NMC v6.0.98 and NMC v6.0.99 (SDL file v3.2.0).
2. Setup console connection to a terminal.
3. Use PCSDL to download NMC code.
4. After download, NMC will boot up to NVRAM factory default settings.
5. If necessary, set NMC IP address. Save and reboot.
6. After card has booted to v6.0.98, open management connection via LAN or
WAN.
7. Download NMC v6.0.99 via LAN or WAN.
8. NMC is now manageable for software download, programmed settings, etc.

Todd

-----Original Message-----

- Mike

---

From: Todd Bertolozzi <[email-masked]>
Date: Mon, 16 Sep 2002 17:05:15 +0000

More info you might need:

How to do a PCSDL:
To do a pcsdl the first thing you need is pcsdl.exe program. If it's not
included in the firmware Winzip file you can get it in any Quad Modem code.
Then follow the following steps:
1.Save the Winzip file in your C: drive
2.Create a directory in your C: drive
3.Save pcsdl.exe in this directory
4.Extract the files included in the Winzip file into this directory.
5.Plug the console cable with the null modem adapter to the console port.
Please note for the Total Control NMC card, and the Total Control NETServer
PRI you should plug into channel 1 of the NIC, for the Total Control QUAD
you will need a Total Control QUAD NIC (no null modem needed).
6.Before starting SDL, we recommend that you unload any
terminate-and-stay-resident (TSR) programs running on the PC, TSR slows down
the SDL program considerably.
7.Open an MS-DOS Session
8.Get through MS-DOS into the directory you created.
9.Once you are in the directory that you stored the codes in you can now
issue the pcsdl commands as follows:
pcsdl -p1 -r9600 -vsdn.n.n -vnan.n.n -nsd -nna
Note: Be careful with the baud rate. In most cards it varies according to
the position of the dipswitches. (There's no dipswitches in Hiper DSP. For
help please check links to solutions at the bottom.
Parmeter Purpose
pcsdl executes the PC SDL program
-p selects the communication port (port 1 or 2)
-r selects serial port rate (= to card DIP switch settings)
-vsd Version number of the .sdl file. -subsitute a real number for n.n.n
(-vnd1.0.2)
-vna Version number of the NAC file substitute a real number for n.n.n
(-vna1.0.3)
-nsd Two character prefix of the .sdl file name (example -nsdnm = NMC)
-d specifies the directory path name (optional); -d should be followed by
the directory name where the operation and SDL software are stored
-h displays on line help
-nna Two character prefix of the .NAC file
-ignoreCardID This is an undocumented option that interchanges codes to
certain cards.
Please note: this option is usually used with T1 or PRI code as well as
NETServer code.
An example: code 3.1.96 for a dual PRI is file ep3196.zip. After the unzip
it has two files: Ep010001.sdl and Ep030196.nac. So the string should be as
follows:
pcsdl -p1 -r9600 -vsd1.0.1 -vna3.1.96 -nsdEp -nnaEp
Filename prefixes are required to specify the type of .sdl and .nac file
used in the download. The following table lists all currently defined
prefixes used with the -nsd and -nna parameters of the pcsdl command. These
prefixes may change for future versions of the NAC software.
SDL NAC
Prefix Prefix Card
ct ct channelized T1 Card
dp dp T1 PRI card
t1 t1 DUal T1 card
li li NETServer ISDN card
nm(4MB) hm (4MB) Network Management Card
hm (16MB) hm(16MB)
qf qf double sided QUAD v.34 Analog, Digital, Analog/Digital
qr qr single sided QUAD v.34 Analog, Digital, Analog/Digital
tr lt NETServer token ring card

Todd

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Todd Bertolozzi
Sent: Monday, September 16, 2002 12:53 PM
To: [email-masked]
Subject: RE: [USR-TC] how to format flash on NMC?

  Answer

Todd

-----Original Message-----

- Mike

---

From: Mike Greene <[email-masked]>
Date: Mon, 16 Sep 2002 17:12:02 +0000

>you looking at the performance trouble lights in TCM for the NMC is there a

The only time there is a hub status error is if I insert a card into slot 
15 (regardless of which chassis the NMC is plugged into).  I have 5 
chassis's and two are spares. None of the other NMC cards have a problem, 
just this one unit.

When I do have the ARC in slot-15 and get the hub status red led the 
performance monitor does say "management bus error".  I had this problem a 
while ago and posted about it and did searches on the KB with no luck.

This is a new NMC (came with a bundle) so I may just ask for a swap.

- Mike

---

From: Mike Greene <[email-masked]>
Date: Mon, 16 Sep 2002 17:18:19 +0000

>NMC Flash-RAM is corrupted

Tried this too, no go.

- Mike

---

From: Mike Greene <[email-masked]>
Date: Mon, 16 Sep 2002 17:19:12 +0000

>More info you might need:

Saw this one as well, didn't try it since it looked like it pertained to 
Quad's only, looking again it appears it may work for NMC too.  Will give 
it a go and see what happens.

- Mike

---

From: Iulian Vaideanu <[email-masked]>
Date: Mon, 16 Sep 2002 20:43:17 +0000

i had some strange behaviour on a nmc that i had to configure
(although the problem didn't seem as bad as yours - the snmp
stack merely crashed, making it impossible to configure the card
via tcm), but maybe the solution i found will help:  pull the nac
out, and next to the battery there should be a reset switch.
press it (don't know exactly for how long - 10 seconds seemed
to work for me :)) and then see what happens...

-- 

Iulian Vaideanu
Network Administrator
ASTRAL TELECOM / DNT, Sucursala Iasi
Tel: 0232-252938    Fax: 0232-252933

---

From: Mike Greene <[email-masked]>
Date: Mon, 16 Sep 2002 21:07:22 +0000

>to work for me :)) and then see what happens...

Ah, I saw that button but though "gee that is gonna be hard to press with 
this card in the slot" the slots next to the power supply's have a shield 
blocking access to the circuitry.

I'll give it a shot and see what happens, thanks for the suggestion!

- Mike

---

From: Iulian Vaideanu <[email-masked]>
Date: Mon, 16 Sep 2002 15:19:02 +0000

just out of curiosity...  when the card boots, it performs
some hardware start-up tests (they don't stay on screen long
enough to be examined, but if you use linux & cu, for example,
you may see them by scrolling your terminal up - Shift+PgUp).
well, what do those tests say?  in my case, i had an 'RTC error',
and someone on this list suggested that i should replace
the battery.  luckyly, i found the reset switch, and all
tests came back to normal, as well as the snmp stack.
just let me know if that worked for you as well.

-- 

Iulian Vaideanu
Network Administrator

---

From: Mike Greene <[email-masked]>
Date: Mon, 16 Sep 2002 15:47:01 +0000

>just let me know if that worked for you as well.

Everything comes up OK, no errors at all.  Its the strangest thing I've 
seen with the NMC (I've seen some really, really strange stuff with the 
ARC's though)!

- Mike

---

From: Terry Kennedy <[email-masked]>
Date: Tue, 24 Sep 2002 22:47:22 +0000

Stated in an earlier post that 3.5.107 was avalible for the DSP -- Confused
with 5.3.107 for Arc

Soory for the confusion. Will check closer next time before staing the
un-obvious...

Terry Kennedy