Subject: (usr-tc) Dual channel ISDN problem.

From: Horace Demmink <[email-masked]>
Date: Mon, 04 Oct 1999 18:49:00 +0000

I have been trying to figure out a problem that one of my customers has
been having. They are dialing up with a 3COM NetBuilder to our TC
equipment. The first channel comes up fine, but the second one will not
come up. The NetBuilder attempts to bring it up, fails, and waits a few
seconds before trying again. ISDN is $.08 per call in this area so they
are racking up quite a bill. I have never seen this before with any other
customer, and as far as I know they are the only ones with a 3COM
NetBuilder, so I am assuming that it is a problem or misconfiguration with
their router. Is anyone else familiar with these things? Thanks very much
in advance for any help or advice anyone can offer.

We are running:

ARC 4.2.32-1
DSP 2.0.81

Here is the relevant section of their radius entry:

username        Auth-Type = System
                Service-Type = Framed,
                Framed-IP-Address = xxx.xxx.xxx.xxx,
                Framed-IP-Netmask = 255.255.255.255,
                Framed-Protocol = PPP,
                Framed-Route = "yyy.yyy.yyy.yyy/30 0.0.0.0 1",
                Framed-Routing = None,
                Framed-MTU = 1500,
                Idle-Timeout = 0,
                Port-Limit = 2,
                Framed-Compression = Van-Jacobson-TCP-IP

And the following is about a minutes worth of a dump of a monitor ppp from
the arc:

Decode tracing started, press ESCAPE to stop; press X for hex tracing.

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf d8 2e c8 68 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 00 00 00 00 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 00 00 00 00 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Outgoing PPP Data on interface: slot:15/mod:21 
    PAP        ACK               
Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 00 00 00 00 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 00 00 00 00 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Outgoing PPP Data on interface: slot:15/mod:21 
    PAP        ACK               
Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 00 00 00 00 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 00 00 00 00 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 18 d8 2e c9 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Outgoing PPP Data on interface: slot:15/mod:21 
    PAP        ACK               
Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 00 00 00 00 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 50 68 6f 6e 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 00 00 00 00 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Outgoing PPP Data on interface: slot:15/mod:21 
    PAP        ACK               
Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf d8 2e c8 68 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 00 00 00 00 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 65 6c 64 20 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Outgoing PPP Data on interface: slot:15/mod:21 
    PAP        ACK               
Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 00 2e c8 68 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 54 48 49 53 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 6e 64 20 4a 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf d8 2e c8 68 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Outgoing PPP Data on interface: slot:15/mod:21 
    PAP        ACK               
Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 81 d8 2e c9 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 39 36 36 3b 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf d8 2e c8 68 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 

Outgoing PPP Data on interface: slot:15/mod:21 
    PAP        ACK               
Incoming PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_REQ          00 cc f7 cf 69 d8 2e c1 

Outgoing PPP Data on interface: slot:15/mod:20 
    LCP        ECHO_RPLY         c4 56 fa 71 
Tracing stopped, Return/Enter to re-start, ESCAPE to quit.

-- 
Horace Demmink
PathWay Computing

-
 To unsubscribe to usr-tc, send an email to "[email-masked]"
 with "unsubscribe usr-tc" in the body of the message.
 For information on digests or retrieving files and old messages send
 "help" to the same address.  Do not use quotes in your message.

---

From: Mike Wronski <[email-masked]>
Date: Mon, 04 Oct 1999 20:17:57 +0000

|-----Original Message-----
|From: [email-masked]
|[mailto:[email-masked]]On Behalf Of Horace Demmink
|Sent: Monday, October 04, 1999 11:45 AM
|To: [email-masked]
|Subject: (usr-tc) Dual channel ISDN problem.
|
|
|
|I have been trying to figure out a problem that one of my customers has
|been having. They are dialing up with a 3COM NetBuilder to our TC
|equipment. The first channel comes up fine, but the second one will not
|come up. The NetBuilder attempts to bring it up, fails, and waits a few
|seconds before trying again. ISDN is $.08 per call in this area so they
|are racking up quite a bill. I have never seen this before with any other
|customer, and as far as I know they are the only ones with a 3COM
|NetBuilder, so I am assuming that it is a problem or misconfiguration with
|their router. Is anyone else familiar with these things? Thanks very much
|in advance for any help or advice anyone can offer.
|
|We are running:
|
|ARC 4.2.32-1
|DSP 2.0.81
|
|Here is the relevant section of their radius entry:
|
|username        Auth-Type = System
|                Service-Type = Framed,
|                Framed-IP-Address = xxx.xxx.xxx.xxx,
|                Framed-IP-Netmask = 255.255.255.255,
|                Framed-Protocol = PPP,
|                Framed-Route = "yyy.yyy.yyy.yyy/30 0.0.0.0 1",
|                Framed-Routing = None,
|                Framed-MTU = 1500,
|                Idle-Timeout = 0,
|                Port-Limit = 2,
|                Framed-Compression = Van-Jacobson-TCP-IP
|
|
|And the following is about a minutes worth of a dump of a monitor ppp from
|the arc:
|
|Decode tracing started, press ESCAPE to stop; press X for hex tracing.
|
|Incoming PPP Data on interface: slot:15/mod:20
|    LCP        ECHO_REQ          00 cc f7 cf d8 2e c8 68

Your PPP trace is of the channel that is already up and is of now use for
debugging this problem. What needs to be seen is the LCP seesion through IPCP on
the first channel and then the PPP trace of the second channel failing..

-M

-

---

From: Ahmed Saeed <[email-masked]>
Date: Mon, 04 Oct 1999 20:18:41 +0000

Horace, 

The ppp traces indicate that the NetBuilder is sending LCP Echo request 
packets to determine link quality. Also, these packets can be used for 
loop back mechanism.

In each case, the hiper arc is sending the correct packets. This is not 
the case. 

For ISDN to terminate, LCP extensions need to be configured and 
exchanged. 
If you do not see these PPP LCP packets and the link is already down 
before this level, then the issue needs to be debugged from the modem 
level. 

Kindly post the mon ppp traces - if any -

Ahmed 

-

---

From: Horace Demmink <[email-masked]>
Date: Tue, 05 Oct 1999 18:49:57 +0000

> the first channel and then the PPP trace of the second channel failing..

Hmm, how do I go about getting this info?

-- 
Horace Demmink
PathWay Computing

-