Subject: [USR-TC] SNMP enable?

From: Lewis Bergman <[email-masked]>
Date: Tue, 23 Jul 2002 13:49:43 +0000

I have tried using snmpget for every OID I can think of. None of the ones that 
seem to work for everyone else give anything except the system uptime for me. 
Memory, CPU, modem usage... . They all return system uptime. Is there 
something i need to enable on the chassis?

an example of how I am doing it follows:
[root@lewis ~# snmpget ipnumber public 1.3.6.1.4.1.429.4.3.1.3.0
system.sysUpTime.6.1.4.1.429.4.3.1.3.0 = Timeticks: (941622234) 108 days, 
23:37:02.34

That is supposed to be for memory. It doesn't matter what IOID I use it always 
comes back the same.
-- 
Lewis Bergman
Texas Communications
4309 Maple St.
Abilene, TX 79602-8044
915-695-6962 ext 115

---

From: Oliver Francke <[email-masked]>
Date: Tue, 23 Jul 2002 13:53:26 +0000

Hi Lewis,

> [root@lewis ~# snmpget ipnumber public 1.3.6.1.4.1.429.4.3.1.3.0

Well, if it's the "ordinary" cmu-snmp-suite, don't forget to prepend the
OID with a dot "."

Should do the trick :-)

Regards, Oliver.

-- 
Was hat bei uns die geringste PopulariTAET?

[email-masked]               fon. +49-5246-80-1389
                                           mob.  +49-171-5597734
I used to have a sig, but I've stopped smoking now.

---

From: Sean Barrett <[email-masked]>
Date: Tue, 23 Jul 2002 14:02:03 +0000

Hi All-

Been a while since I posted here, but I am curious if anybody has
managed to use a HIPER system to route Fax and Dialup traffic on the
same DSP with call-type routing? Jeff's last e-mail about the AS5300 got
me thinking about it. 

Sean

---

From: Todd Bertolozzi <[email-masked]>
Date: Tue, 23 Jul 2002 14:30:48 +0000

Prepend meaning this:

.1.3.6.1.4.1.429.4.3.1.3.0

BTW....there's a nifty program called getif that has a nice mib browser on
it which will allow you to put the 3com mibs into it's database and more
easily walk the tree to find the OID's you are looking for.

http://www.wtcs.org/snmp4tpc/testing.htm

Todd

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Oliver Francke
Sent: Tuesday, July 23, 2002 9:53 AM
To: [email-masked]
Subject: Re: [USR-TC] SNMP enable?

Hi Lewis,

Should do the trick :-)

Regards, Oliver.

_______________________________________________
USR-TC mailing list
[email-masked]
http://mailman.xmission.com/cgi-bin/mailman/listinfo/usr-tc

---

From: Lewis Bergman <[email-masked]>
Date: Tue, 23 Jul 2002 14:44:41 +0000

> Prepend meaning this:
I did do that and got this:
[root@lewis ~# snmpget ipnumber public .1.3.6.1.4.1.429.4.3.1.3.0
Error in packet
Reason: (noSuchName) There is no such variable name in this MIB.
Failed object: enterprises.429.4.3.1.3.0

> http://www.wtcs.org/snmp4tpc/testing.htm
Thanks, I'll look into it. But, till I get a dimple snmpget to work I think I 
might be wasting more time.
-- 
Lewis Bergman
Texas Communications
4309 Maple St.
Abilene, TX 79602-8044
915-695-6962 ext 115

---

From: Todd Bertolozzi <[email-masked]>
Date: Tue, 23 Jul 2002 14:54:32 +0000

Okay....tell me exactly what you want...don't be greedy, I have other things
to do.  Also...which card are you trying to get this info from?

Todd

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Lewis Bergman
Sent: Tuesday, July 23, 2002 10:39 AM
To: [email-masked]
Subject: Re: [USR-TC] SNMP enable?

> http://www.wtcs.org/snmp4tpc/testing.htm
Thanks, I'll look into it. But, till I get a dimple snmpget to work I think
I
might be wasting more time.
--
Lewis Bergman
Texas Communications
4309 Maple St.
Abilene, TX 79602-8044
915-695-6962 ext 115

---

From: Lewis Bergman <[email-masked]>
Date: Tue, 23 Jul 2002 16:31:30 +0000

On Tuesday 23 July 2002 09:58 am, Todd Bertolozzi wrote:
> Okay....tell me exactly what you want...don't be greedy, I have other
> things to do.  Also...which card are you trying to get this info from?
I want to be able to get Modem utilization. I have the OID's that vast 
multitudes seem to be able to use which I got from the tc web page so many 
have referred to on this list.

I am trying with the NMC's IP. When I tried the HARC's IP number it didn't 
respond to snmpget. Maybe I have the HARC set up wrong for this? I Haven't 
been able to find any docs on this type of thing at CommWorks but would 
gladly accept a RTFM with a link.

I am totally lost here for anyone who hasn't already noticed.
If you have time to help i appreciate it. If not, I entirely understand.
-- 
Lewis Bergman
Texas Communications
4309 Maple St.
Abilene, TX 79602-8044
915-695-6962 ext 115

---

From: Todd Bertolozzi <[email-masked]>
Date: Tue, 23 Jul 2002 17:25:29 +0000

1.3.6.1.4.1.429.4.2.1.10.0 to get the ports used off a hiperarc.  Make sure
that the hiperarc is setup properly by doing a list snmp communities.  Make
sure your NMS is in the access list with RO permissions.

Todd

-----Original Message-----
Sent: Tuesday, July 23, 2002 12:26 PM

---

From: Lewis Bergman <[email-masked]>
Date: Tue, 23 Jul 2002 19:09:16 +0000

> sure your NMS is in the access list with RO permissions.
Here is what I get:
HiPer>> list snmp commUNITiES

SNMP COMMUNITIES
Community Name
IP Address      Access        Community Pool                   Validate 
Address
<my.private.comm.here>
208.29.17.202   Read/Write                                     useAddress

It is using the above that I get only the time. Should the useAddress be 
something else?
As for my management station being in the ACL, where would I find that at? I 
have the IP of the computer I am testing with list in the TCM's hiperarc 
config in the default networm management station space and the read community 
string in the default community string space. Anything else I am missing?
-- 
Lewis Bergman
Texas Communications
4309 Maple St.
Abilene, TX 79602-8044
915-695-6962 ext 115

---

From: Oliver Francke <[email-masked]>
Date: Tue, 23 Jul 2002 19:11:09 +0000

Lewis,

> gladly accept a RTFM with a link.

OK. then, even without setting up SNMP on the HARC you are able to get
the values via the NMC:

snmpget <nmcip> <ReadWriteCommunity>@15000 <OID>

whereas 15000 is the HARC-slot mult. by 1000.

The other story is for example:

add snmp community <read-only> address 1.2.3.4 access RO
add snmp community <read-write> address 1.2.3.4 access RW

where 0.0.0.0 should fullfill your management station-IP.

Hope this helps, Oliver.

[...]

---

From: Lewis Bergman <[email-masked]>
Date: Wed, 24 Jul 2002 13:57:45 +0000

Todd and Oliver,
Thanks for your help. I added the my monitoring computer and it started 
working. It is very humbling to fight with something for so long and be so 
far behind most others. Oh well, back to climbing my steep learning curve.

-- 
Lewis Bergman
Texas Communications
4309 Maple St.
Abilene, TX 79602-8044
915-695-6962 ext 115

---

From: Oliver Francke <[email-masked]>
Date: Wed, 24 Jul 2002 14:06:29 +0000

Lewis,

> far behind most others. Oh well, back to climbing my steep learning curve.

Well, haven't we all began somewhat in the past with the first

snmpwalk nmcip rcomm<ENTER>

command? 

;-)

Regards, Oliver.

---

From: Stephen Rivera <[email-masked]>
Date: Wed, 24 Jul 2002 22:58:59 +0000

I'll ask the 3com instructor tomorrow in class.