Subject: RE: (usr-tc)Disconnect User Problem

From: "Stainforth, Matthew" <[email-masked]>
Date: Wed, 22 Dec 1999 20:38:41 +0000

I've found that "disc user" from the ARC CLI will send an accounting STOP
record, however, a "reset modem slot:x/mod:y" won't, thereby causing ghost
records in the RADIUS tracking.  It might be something to look out for if
you try to reset the actual interfaces via SNMP.

Matthew Stainforth  ||  Technical Services Manager ||  BrunNet Inc.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, December 22, 1999 1:24 PM
> To: [email-masked]
> Subject: Re: (usr-tc)Disconnect User Problem
> 
> 
> I do.. snmp get the names from the ARC and the telnet session 
> to dico the
> user.
> 
> I wish I had the SNMP OID to reset a specific modem.... 
> 
> Paul Farber
> Farber Technology
> [email-masked]
> Ph  570-628-5303
> Fax 570-628-5545
> 
> On Wed, 22 Dec 1999, Nicolas St-Pierre wrote:
> 
> > 
> > 
> > [email-masked] wrote:
> > > 
> > > I use a similiar setup via a web page (php3/snmp to list 
> users, time on,
> > > ip, slot etc) then a simple perl script usig Net::Telnet 
> to disconnect
> > > users passed to it via a list.  Works well.  Plus a human 
> get the final
> > > say if a person get booted.
> > > 
> > 	Why wouldn't you use SNMP to disconnect users as well? 
> Seems easy
> > enough if you already list users per interface to see who's 
> on.  I use a
> > snmpset of .1.3.6.1.4.1.429.4.10.1.1.27.interface# with the string
> > "RESET" and the user's gone.
> > 
> > Just a thought,
> > 
> > Nick
> > 
> > -- 
> > Nicolas St-Pierre
> > Systems Engineer
> > Internet Access Solutions Ltd.
> > Tel (905) 469-4953
> > Fax (905) 469-4954
> > 
> > -
> >  To unsubscribe to usr-tc, send an email to "[email-masked]"
> >  with "unsubscribe usr-tc" in the body of the message.
> >  For information on digests or retrieving files and old 
> messages send
> >  "help" to the same address.  Do not use quotes in your message.
> > 
> 
> 
> -
>  To unsubscribe to usr-tc, send an email to "[email-masked]"
>  with "unsubscribe usr-tc" in the body of the message.
>  For information on digests or retrieving files and old messages send
>  "help" to the same address.  Do not use quotes in your message.
> 

-
 To unsubscribe to usr-tc, send an email to "[email-masked]"
 with "unsubscribe usr-tc" in the body of the message.
 For information on digests or retrieving files and old messages send
 "help" to the same address.  Do not use quotes in your message.

---

From: [email-masked]
Date: Wed, 22 Dec 1999 21:12:39 +0000

Shouldn't it?  Once the ARC see's the interface drop/reset it should send
the stop with a terminate cause.

Paul Farber
Farber Technology
[email-masked]
Ph  570-628-5303
Fax 570-628-5545

-

---

From: Nicolas St-Pierre <[email-masked]>
Date: Wed, 22 Dec 1999 22:27:31 +0000

Interesting, 

As Paul mentionned, I would expect the ARC to send accounting stop data
with the appropriate termination cause.  In any case, I believe there is
a way to issue a disconnect user command through SNMP instead of a Modem
reset.  I've yet to figure it out completely, so any help from this list
will be welcomed! (Especially from the 3Com people)!

Active session information can be "walked" with the
.1.3.6.1.4.1.429.4.2.1.46.1. SNMP tree.  .1.3.6.1.4.1.429.4.2.1.46.1.6
for example, will walk the interface names per username.  The rest of
the OID is composed of the Username (ascii values) and the SessionID. 
So for my username draggy (100.114.97.103.103.121), the OID returned
would be:
.1.3.6.1.4.1.429.4.2.1.46.1.6.100.114.97.103.103.121.173123 =
"slot:4/mod:12"

In this case 173123 would be the SessionId.

To disconnect the user, the ARC MIB has: .1.3.6.1.4.1.429.4.2.1.46.1.5
  
       uumActiveSessionAction  OBJECT-TYPE
        SYNTAX  INTEGER {
                disconnect(6)
                }
        ACCESS  write-only
        STATUS  mandatory
        DESCRIPTION
                "We need to be able to disconnect all users with a
                 particular user name"
        ::= { uumActiveSessionEntry 5 }                

I assume that by writing the integer 6 with a snmpset on the OID
.1.3.6.1.4.1.429.4.2.1.46.1.5."username in ascii" I would disconnect the
username from the ARC.  However, I've been unable to do this since I get
back different errors from snmpset.  I get unknown OID if I set an
integer 6 to the OID above (with and without the SessionId appended),
and I get a packet error if I set anything other than the integer 6.

Perhaps this user disconnection would send the accounting data.  I'm
unsure whether the modem disconnect snmpset actually sends out the
accounting STOP or not.  If it doesn't then I'd consider this a flaw in
the way the ARC operates.

Nick

-

---

From: [email-masked]
Date: Wed, 22 Dec 1999 23:03:27 +0000

my understanding is that it should generate an accouting message on the
interface no matter how the user is dropped.

I use the oid you mention to get user info... but I have also been
unsucessful in resetting a modem via snmp.  I'm tempted to log the packets
with a sniffer and see what's up.... but the telnet method of disc user x
is working fine.  

Paul Farber
Farber Technology
[email-masked]
Ph  570-628-5303
Fax 570-628-5545

-