Subject: (usr-tc) OSPF doesn't announce RADIUS learned addresses?

From: Antonio Querubin <[email-masked]>
Date: Wed, 05 Sep 2001 16:24:54 +0000

I'm trying to convert from RIP to OSPF on a pair of HIPERARCs and so far
OSPF is able to announce the addresses in the multi-aggregate address
pools to the rest of the net.  It's picking up routes from the other
devices (a mix of Ciscos, Redbacks, Junipers, and Ascend MAX) as well as
the default route from our border routers.

However, when a PPP dialer receives their IP address via RADIUS instead of
from the configured address pool, OSPF doesn't announce the address.  The
address is seen if one does a 'list ip network' and it's pingable.  But
none of the other devices on the LAN receive any announcement from the
HIPERARC.  I do have an OSPF sendpolicy that covers every possible address
we might announce.  If I revert back to RIP, the address learned from
RADIUS is announced via RIP.  Anybody have an idea on what I might be
missing here?

anunu2> show ospf global

GLOBAL OSPF SETTINGS
Router ID:                                 64.65.64.36
Administrative Status:                     ENABLED
OSPF Version Number:                       2
Area Border Router Status:                 DISABLED
Autonomous System Border Router Status:    DISABLED
Type-of-service (TOS) Support:             OFF
External LSDB Limit:                       -1
Multicast Extensions Support:              OFF
Exit Overflow Interval:                    0
Router's Support for OSPF Demand Routing:  OFF
OSPF Traps:                                ENABLED

anunu2> list ospf host
OSPF HOST TABLE
   HostIpAddr/Mask  Metric   AreaId
   64.65.75.176/28       1   0.0.0.1
   64.65.75.192/26       1   0.0.0.1
     64.65.76.0/26       1   0.0.0.1
    64.65.76.64/27       1   0.0.0.1
    64.65.76.96/28       1   0.0.0.1

anunu2> list ospf send

OSPF Send Policies:
Source  Address/Mask       Action
ANY     000.000.000.000/0  Do Not Advertise
LOCAL   064.065.064.000/18 Advertise

anunu2> list ospf int
OSPF INTERFACE TABLE
IfIpAddr/IfInd  AreaId          IfType AdminStat IfState      Metric
64.65.64.36     0.0.0.1         BC     ENABLED   OtherDsgRtr  1

anunu2> show ip network backbone

SHOW IP  NETWORK backbone SETTINGS:
Interface:                                 eth:1
Network Address:                           64.65.64.36/25
Frame Type:                                ETHERNET_II
Status:                                    ENABLED
Reconfigure Needed:                        FALSE
Mask:                                      255.255.255.128
Station:                                   64.65.64.36
Broadcast Algorithm:                       IETF
Max Reassembly Size:                       8192
WAN Type:                                  N/A
Remote IP Address:                         0.0.0.0
IP Routing Protocols:
                                           OSPF
IP Routing Metric:                         1
RIP Interface Export Metric:               0
IP RIP Routing Policies:
IP RIP Authentication Key:

-
 To unsubscribe to usr-tc, send an email to "[email-masked]"
 with "unsubscribe usr-tc" in the body of the message.
 For information on digests or retrieving files and old messages send
 "help" to the same address.  Do not use quotes in your message.

---

From: Charles Sprickman <[email-masked]>
Date: Wed, 05 Sep 2001 19:34:01 +0000

What happens if you enable ASBR?

Charles

| Charles Sprickman                  | Internet Channel
| INCH System Administration Team    | (212)243-5200
| [email-masked]                     | [email-masked]

-

---

From: Antonio Querubin <[email-masked]>
Date: Wed, 05 Sep 2001 23:07:43 +0000

> What happens if you enable ASBR?

If I recall correctly, there was no change in behaviour.  However, I've
fiddled with so many parameters the past couple of days that I might have
been hitting the wrong combination while ASBR was enabled.  I'll enable it
again and we'll see what happens.

-

---

From: Antonio Querubin <[email-masked]>
Date: Thu, 06 Sep 2001 02:59:45 +0000

yOn Wed, 5 Sep 2001, Antonio Querubin wrote:

> Date: Wed, 5 Sep 2001 11:05:13 -1000 (HST)
> From: Antonio Querubin <[email-masked]>
> To: [email-masked]
> Subject: Re: (usr-tc) OSPF doesn't announce RADIUS learned addresses?
>

That seems to have done the trick.  Even works with the default
send-policy.  Thanks for the hint!

-