Subject: (usr-tc) Radius and VPN-Neighbor

From: "G. Douglas Davidson" <[email-masked]>
Date: Thu, 03 Feb 2000 19:45:05 +0000

I am having some difficulty getting VPN-Neighbor to work.  My setup is as
follows:

HyperArc Version: 4.2.32
IEA Next Hop Routing:                      ENABLED
IEA Send Unsolicited Proxy Arp:            DISABLED
IEA Force Next Hop Route:                  DISABLED
IP proxy ARP for all dialin addresses:     DISABLED

IP RIP Flags:                              METRICS
                                           SEND_REQUEST

I am using an altered version of Livingston's 2.1 Radius.  On the Livingston
side it _appears_ that the VPN-Neighbor attribute is being sent:

Thu Feb  3 11:29:14 2000: [24758] sending accept to 198.144.34.36/1645.66
Thu Feb  3 11:29:14 2000: [24758] Service-Type = Framed-User
Thu Feb  3 11:29:14 2000: [24758] Framed-Protocol = PPP
Thu Feb  3 11:29:14 2000: [24758] USR-PW_VPN_Neighbor = 198.144.34.46
Thu Feb  3 11:29:14 2000: [24758] Framed-IP-Address = 255.255.255.254
Thu Feb  3 11:29:14 2000: [24758] Framed-MTU = 1500
Thu Feb  3 11:29:14 2000: [24758] message sent to 198.144.34.36/1645.66 code=2,
length=50

But when I am doing a "mon radius" for the user on the USR box it only shows
receipt of all of the attributes with the _exception_ of the VPN Neighbor
attribute.

Does "mon radius" show all attributes transmitted, or only those that are acted
on or understood?  I'd like to know if the VPN-Neighbor attribute is even being
transmitted (although from the Radius stats, it looks like it is.)

Thanks!

-- 
-----
G Douglas Davidson                      | CityNet, Inc.
[email-masked]                    | Pittsburgh, PA
voice: 412.481.5406			| fax: 412.431.1315

-
 To unsubscribe to usr-tc, send an email to "[email-masked]"
 with "unsubscribe usr-tc" in the body of the message.
 For information on digests or retrieving files and old messages send
 "help" to the same address.  Do not use quotes in your message.

---

From: Brian <[email-masked]>
Date: Thu, 03 Feb 2000 20:31:22 +0000

What attribute id are you using.  I have used:

VENDORATTR  429	USR-VPN-Neighbor	36872	ipaddr

successfully.  It has to be one hop away to work however.

> transmitted (although from the Radius stats, it looks like it is.)

-----------------------------------------------------
Brian Feeny (BF304)     [email-masked]   
318-222-2638 x 109	http://www.shreve.net/~signal      
Network Administrator   ShreveNet Inc. (ASN 11881) 	      

-